PDA

View Full Version : Half-Life 1 Glitches in Anthology?


Lethan
11-05-2009, 10:17 PM
I bought Half-Life Anthology, got it installed and started playing, but I noticed a few problems in Half-Life 1 when playing, here are some of them:

When killed, the Scientists and Security Guards won't fall over dead, instead they will sit down and shake their head repeatedly.
(This does not happen in Blue Shift or Opposing Force)

Here is a picture of a dead Security Guard:
http://i33.tinypic.com/xmtvtf.jpg

The HECU Grunts are not human marines, but are all green robots, instead.
(The Grunts in Blue Shift are normal marines)

Here is a picture of one of the dead robots.
http://i38.tinypic.com/33cvvas.jpg

The NPCs will sometimes fade away when killed, instead of dropping to the floor, or exploding into bits, (Especially from explosives like the grenade)
(Once again, this doesn't happen in Blue Shift or Opposing Force)

I don't know what's wrong with Half-Life 1, the other two games work fine, so does anyone know what's wrong or have suggestions on what I should do to fix the problems?

EDJE
11-05-2009, 11:30 PM
1.) It look like the death animation has become mixed up with another animation.

2.) Ditto, except instead of an animation, it's a skin.

3.) I'm pretty sure they're supposed to fade when killed from bullets. Dunno about the grenade problem.

trenmost
11-06-2009, 06:50 AM
both of you have the censured, german version of HL. Change your steam to english, or change the game language to english (right-click on Half-Life in steam, properties, Language panel)

Stixsworld
11-06-2009, 06:51 AM
Issue is that you have the censored version...no clue how or why...but that is what it is...

---Stixsmaster

Chrstph
11-06-2009, 06:53 AM
1.) It look like the death animation has become mixed up with another animation....

I think he bought a German Version of the game.
I also have the censored German Version with Robots and so on.
There are two Solutions:

Switch the Game-Language to English [Eigenschaften -> Sprache]
-or-
He has to edit/copy some Files -> except of the German Robot-Voices, the Game is then uncut.

Lethan
11-06-2009, 09:58 AM
A censored version?
I checked the Language on the game, and it was English. I also checked the content lock in-game, it was off.
Like I said before, Blue Shift and Opposing Force aren't effected by the same problems in Half-Life 1, so I don't think they are censored.
So, how would I go about editing the files?

MADDOGGE
11-06-2009, 10:04 AM
You can try reinstalling or just contact support and have them give you the correct version.


This has happened to others recently in the last couple months and they fixed it.

masta_chef
11-06-2009, 10:07 AM
Just to make sure: Do you live in Germany?
Also the first thing you should do with any Valve game when problems like this arise is to Verify game cache files (right click the game in your "my games" list, click properties, then click the local files tab, then "Verify ...").
I'm actually tempted to switch the language to German to see what this is like :D

Lethan
11-06-2009, 04:21 PM
Well, I tried reinstalling Half-Life, it didn't work, so I contacted Steam Support and now I'm waiting for a response. Thanks for the help and letting me know about the German version.
Also, no, I live in the U.S.

kommandojoe
11-06-2009, 04:32 PM
Didnt know the germs got sweet robots of DOOM! Might have to check that out lol.

JustinL
11-11-2009, 03:54 PM
If you are experiencing this issue, and you are not in a region where the low violence version of required, please contact Steam Support. We will be happy to assist you.

Lethan
11-12-2009, 05:24 PM
I got an email from Steam Support today telling me that a content lock has been removed from my account, I was then given further instructions on what to do next, and sure enough, the problems are fixed! There's human soldiers and all the blood and guts you could ever want. Thanks Steam Support!

EDJE
11-12-2009, 07:52 PM
Yay, blood and guts!

MADDOGGE
11-12-2009, 08:32 PM
Hahahahahahahahahahaa!

RottenApple32
11-15-2009, 09:18 AM
both of you have the censured, german version of HL. Change your steam to english, or change the game language to english (right-click on Half-Life in steam, properties, Language panel)

So this only affects the German version?

PMY
04-30-2010, 01:59 PM
Same problem here. I've bought a usual retail version of Half-Life 1 Anthology in country where no low-violence version is requiered (confirmed by my local publisher). But im my case Steam Support did nothing to solve this problem.

I got an email from Steam Support today telling me that a content lock has been removed from my account, I was then given further instructions on what to do next, and sure enough, the problems are fixed! There's human soldiers and all the blood and guts you could ever want. Thanks Steam Support!

It seems that Steam Support is not always so efficient after all.
First they answered me that content lock is "only dependent on the territory the game was purchased in". But after i noticed that there shouldn't be any content lock in my regional version(sic!) and asked to fix this problem somehow they just evaded doing something ("we are unable to remove this content lock") and closed my question ticket instead of clarifiyng why they can't do anything. Thanks Steam Support!

So is there any way to solve this problem on my own?

green_meklar
05-01-2010, 11:47 AM
PMY, check out this page:
https://support.steampowered.com/kb_article.php?ref=4917-GLXC-1280

gorpie
05-01-2010, 12:02 PM
Geez, one would think Support could have sent PMY that page/link... Whatever.

PMY
05-01-2010, 12:18 PM
PMY, check out this page:
https://support.steampowered.com/kb_article.php?ref=4917-GLXC-1280

Unfortunately this didn't work (at least in my case).
I tried also to delete the whole [HKEY_CURRENT_USER\Software\Valve\] from registry and ClientRegistry.blob from Steam directory (one can find such advice on different forums) but this didn't work either.