PDA

View Full Version : Steam won't load Store/Community pages...


Necrobile
11-25-2009, 05:13 PM
This has been a problem for monthes, almost a full year. 70% of the time when I load my Steam client, it will not load any pages. I can see my game tab just fine. My games update without a problem. But when I try to go to the store/community tab, it's just a blank white screen, with my mouse cursor showing that it's "loading". But no matter how long I let it load, nothing.

I can't buy a game through Steam. I can't try a demo through Steam. I can't even change my account information, all because of this. It's greatly annoying.

For those of you who actually care enough to try helping, yes, I have updated my IE client. Yes, I have checked all ports on my router, and have it configured properly. I've done all my windows updates(so far). I've uninstalled/reinstalled Steam(and lost game saves because of it). What annoys me the most, is that my room-mates Steam client loads perfectly every single time he starts it. But mine only happens once in a blue moon. It's honestly getting to the point where I'm just going to uninstall it, and say to hell with Steam/Valve. I really don't know what else to try to get this to work, and there's no point in keeping it if it won't work.

I am using WinXP, if that helps. If anyone has any suggestions, please let me know. It really sucks with the Black Friday sales going on, because I can't even look at what's available to purchase/download.

Maddoghalo
11-25-2009, 05:21 PM
Have you tried updating Flash+Java? That fixes that problem most of the time. Or if you have, uninstall and re install it?

Necrobile
11-25-2009, 05:31 PM
Have you tried updating Flash+Java? That fixes that problem most of the time. Or if you have, uninstall and re install it?

I thought my Flash was up to date, but I guess not. After I installed the update, Steam worked. I hope that's the culprit right there, and Steam isn't just pretending to work, to give me that false sense of security. lol

Thank you, though, I do appreciate the help. If that ends up being the culprit, then you are awesome, my friend. Have a happy Thanksgiving. :)

Maddoghalo
11-25-2009, 05:33 PM
Haha no problem, you have a great Thanksgiving too.

Necrobile
12-03-2009, 07:11 PM
Well, bumping this back up, because apparently updating my flash didn't work. After updating, it worked fine. But I've been busy lately, so after that, I haven't messed with Steam much.

Just now, I loaded up Steam to see what new sales are about, and once again, I'm getting the blank white screen. IE is up to date, Flash is up to date, Java is up to date, all my Windows updates are done.

This is frustrating beyond imagination. I see no reason for this to be happening, but, here it is, happening. Any other ideas out there? I like Steam(when it works), and I like Valve games.

Nekomancer
12-03-2009, 07:23 PM
Java update is nice, but unnecessary for Steam as Steam uses no Java.

Rogabr
12-04-2009, 01:08 AM
Bump for solution, also happens to me, and i'd like to beable to browse the store

Ahnteis
10-28-2011, 04:21 PM
I deleted clientregistry.blob and it magically started working again.