PDA

View Full Version : How to fix Widescreen!


mesaone
12-02-2009, 09:24 PM
Thanks to Voodooman and StingingVelvet from the forums at Widescreengaming.com and also theme instructions from Vishal Gupta from askvg.com plus some of my own adjustments, you can run Dark Sector in widescreen and correct FOV with no d3dwindower!

here's my tutorial. It seems long, but it is easy and does not pose any threat of permanent damage to your system.

With the instructions I have received on Widescreen Gaming Forums, plus Theme instructions from Vishal, plus a few of my own trial-and-error adjustments, here is a screenshot -- windowframe almost visually non-existant. Here is a complete How-To!



Sorry for the bad image quality, it's the only site i know of that can host full size pics. Check the properties, this is 1920X1080 so what you see is whats on the screen -- I didnt trim these images. The top bar of the window is cut off because of custom move (check steps 8-9)

http://www.freeimagehosting.net/uploads/d738bdaff0.jpg

http://www.freeimagehosting.net/uploads/7e301975b8.jpg

http://www.freeimagehosting.net/uploads/e7e6f4d4da.jpg


So here's how, for those running a 1920x1080 setup (or any 16:9 just plug in your numbers)

One thing to warn you, I use a vista build. If you are using XP or Win7, the process to change the Theme might be easier. If you have a higher Vista Build than "Home" version, you can change to a 3rd party Theme without steps 2 -4.

1. After making a backup (I just copy and paste and rename to "[orig]filename.xxx") open your Editor.cfg and alter the X and Y variables. Here is a copy of my Editor.cfg file

+version=3

[CacheCfg,/Types/CacheCfg]

[MRU,/Types/RecentDatabase]
HistorySize=16
Tables={
{
typeName=Scene
items={
/Levels/Mission01/Scene1Cinematic.scene,
/Levels/Mission02/Market.scene,
/Levels/Mission02/Start.scene,
/Levels/Mission01/Escape.scene,
/Levels/Mission01/Start.scene
}
}
}

[MainDarkitect,/Editor/WinRect]
SizeX=1920
SizeY=1080

[MainGameFullScreen,/Editor/WinRect]
SizeX=1920
SizeY=1080

[MainGameWindowed,/Editor/WinRect]
PosY=17
SizeX=1920
SizeY=1064

[PhysicsDebugRenderOptions,/Types/DebugRenderOptions]




Then save the file in its original location.


2. Download Vishal's "Vista Black Theme" here -- http://www.askvg.com/vista-black-theme-for-windows-vista/

3. Follow the instructions for GLAZZ here (easy) http://www.askvg.com/how-to-install-and-use-3rd-party-themes-in-windows-vista/

5. Switch to the black theme. What I did was open up Control Panel -> Personalize -> Theme -> Select "Vista Black" from dropdown menu -> Save As -> save to desktop So anytime I just open that THEME file from my desktop and I can switch around, instead of going to Personalize

6. Set taskbar to autohide and untick the "keep taskbar on top of other windows" item

7. Open Dark Sector, make sure size is good.

8. Right-click top window frame, select "Move"

9. Press arrow keys to adjust frame position so that no visual borders are visible on the laft, right, or bottom

10. Quit Dark Sector


Now you're set! This is a one-time thing, you won't have to do all this every time you want to play Dark Sector. Every time you launch DS, you're gonna have to switch to the Vista Black theme, but since we have a shortcut on the desktop thats no problem. DS should save frame position in Editor.cfg, so there will probably be those extra PosX and PosY lines. But thats fine!


Try it out. I have noone else to confirm this, but as you can see from screenshots (taken with PrintScreen key, not FRAPS capture) I have done this on my rig and it looks good.

mesaone
12-03-2009, 02:42 PM
oh, sorry one more thing to do....

Open DS.cfg in the Configs folder (same place as Editor.cfg) and enter this line above resolution information...

Graphics.FullScreen=0

e_2
01-03-2010, 10:20 AM
Actually, I don't think this "fixes" the real issue with widescreen. I was never able to see the full hud info (rounds in gun, etc.) that pops up when you get ammo. Nor was I able to look straight up or down (frustrating when fighting end boss's tentacles).
The game thinks that it's 4:3 but crops the top and bottom. A.K.A. the lazy man's widescreen.

mesaone
01-04-2010, 06:11 PM
yeah it's vert- but it looks great... I'm not getting any of the HUD cut off on my system. I would prefer proper widescreen implementation but it isn't in this game.

Alienware Gamer
01-31-2010, 09:54 PM
Sorry that does not fix anything it just repositions the screen a little. I cba to take pics of the 360 version I also own (hey it was real cheap only 5 new!! I wonder why!).

When you play the game in 4:3 pillarboxed you can see the problem vs 360 16:9 mode as its FOV & HUD issues which unless you reach certain parts of the game are hard to spot initially.

I would advise anyone with a widescreen monitor or HDTV to avoid buying unless you like 4:3 last century aspect ratios & FOV!!!

Russian Drink
05-06-2010, 10:58 PM
This game is actually pretty fun!

I retain my desktop resolution of 1920 1080 but simply set the game to Windowed mode (using Graphics.Fullscreen=0 command from above) but set the width and height to 1600 900.

The catch is that you just have to stop caring about seeing a little bit of your desktop as you're playing the game.

Shrmtales
12-19-2010, 06:04 AM
I done something different and easier! my screen allows to change from wide to more narrow screen hence prior loading i change it and once in i change back to wide and problem solved!!!