PDA

View Full Version : choke/loss with FreeBSD


eger
07-16-2004, 11:07 AM
wondering if anyone has any ideas on how to cut down choke and loss?

mainly loss is usually between 1 and 4. it rarely drops to 0 on my FreeBSD 4.10 server. i don't really notice it. but it bothers me that it is even there. and i'm sure customers will notice it.

Specs:

Dual Xeon 2.8ghz
1GB ECC RAM
RAID1 2x80GB SATA Drives

On my Redhat server withmuch lower specs (dual 1.2ghz p3) i see hardly any choke/lag.

These are on the same connection. 2 ports away on the switch.

connections is 100mbit uplink to the net, dedicated bandwidth in colo facility.

any ideas?

a2g-Mike
07-16-2004, 02:35 PM
I have heard of this before but don't seem to experience it myself. If you look around the hlds_linux archives, there is a long thread on it somewhere :)

XGS-Barry
07-16-2004, 02:49 PM
I accidently posted a new thread about this instead of replying to your post. Forum Noob :P

Well before thinking it is a problem with your setup please make sure the clients are not "tweaking" thier client side config.cfg file. If the server is not set to allow the maxupdaterates at 100 and a client changes thier client side rate above the nromal 20-30 then they will recieve choke on any server that is not properly set. I seen alot of this happen when CAL first started altering the update rates in the cal.cfg. 2 solutions is you can put the following in your server.cfg file or make sure the clients dont change there updaterates and choke themselves out. I found that putting the commands in the server.cfg file is much easier

sv_maxupdaterate 100
sv_minupdaterate 20

eger
07-16-2004, 11:20 PM
i guess i can't find the thread in the archives you are talking about. someone said the debian-linux package runs better than thee stock one. i may give it a try.

i'm pretty sure its not a rate/bandwidth issue. it happens when im the only one in the server too.

hop over to the server on linux (again just myself) 0 loss and 0 choke. loss jumps to 1 for a split second maybe every 5 mins. on the freebsd loss never even hits 0. usually 1 -4.

i'll keep my eyes peeled for an answer.

a2g-Mike
07-17-2004, 02:58 AM
There is no reason for loss. This is a bit of a stretch, but you could try 5.2.1-RELEASE. I have had no problems with it. I use a mixture of linux_base-8 and linux_base-debian and have had problems with neither. We have 13 or so servers running FreeBSD 5.2.1-RELEASE. Don't let people make you believe it isn't stable, it has performed beyond great for us.

Also, on hlds_linux look in the archives under the month of may for the subject "Chokes...", that is what you're looking for.

CIDER
07-17-2004, 11:34 PM
Originally posted by a2g-Mike
There is no reason for loss. This is a bit of a stretch, but you could try 5.2.1-RELEASE. I have had no problems with it. I use a mixture of linux_base-8 and linux_base-debian and have had problems with neither. We have 13 or so servers running FreeBSD 5.2.1-RELEASE. Don't let people make you believe it isn't stable, it has performed beyond great for us.

Also, on hlds_linux look in the archives under the month of may for the subject "Chokes...", that is what you're looking for.

what are the server specs a2g?

sidonhy
07-20-2004, 02:21 AM
Recompile your kernel with

options HZ 10000

I get a ping under 5 in lan after this with a Pentium M server with no pingboost :D