PDA

View Full Version : Update Problem


mcnum
07-16-2004, 11:41 AM
Hi there,
we have some problems updating our CS-Servers.

We use this update-command:

217-20-117-69:/home/games/domclan/hlds# ./steam -command update -game cstrike -dir /home/games/domclan/hlds/ -username xxx -password xxxx -remember_password

Checking bootstrapper version ...
Getting version 8 of Steam HLDS Update Tool

The "Getting version 8 of Steam HLDS Update Tool" stays all the time and nothing happens. Hope you have any ideas! Thx, MC

3-ranger
07-19-2004, 05:51 AM
Hi,

is the Server behind a router, is it a dedicated or you have activated the firewall and didnt opne the ports?

mcnum
07-19-2004, 10:36 AM
Originally posted by 3-ranger
Hi,

is the Server behind a router, is it a dedicated or you have activated the firewall and didnt opne the ports?

No Firewall or Router there...

3-ranger
07-19-2004, 10:47 AM
Hi,

i have this problem also. I want to test a server with vmware. My PC is behind a router, so i have think this problem is because the router. hmm....!?

Edit:
Yesterday it didnt work. After i have updated my system it works.hmmm lol

Do you use only the updatetool or the 400 MB hlds file?

mcnum
07-19-2004, 02:24 PM
Originally posted by 3-ranger
Hi,

i have this problem also. I want to test a server with vmware. My PC is behind a router, so i have think this problem is because the router. hmm....!?

Edit:
Yesterday it didnt work. After i have updated my system it works.hmmm lol

Do you use only the updatetool or the 400 MB hlds file?

Im using the updatetool.

I installed a fresh cs-server with the updatetool on saturday which worked without any problem. I copied the new version of the updatetool to another server and updated this server also without any problem, then i tried the next one but the same problem occoured as i described in my first post.

...

3-ranger
07-19-2004, 02:29 PM
i have also the problem, when i want to update a installed server with the updatetool.....

using debian 3.0r2

pr!x
07-19-2004, 03:32 PM
I have got another problem, I run the updatetool and the following error appears...

"Checking bootstrapper version ...

AssertPreCondition
Name: NonNullFilePath
Expr: !sFile.empty()
Line: 334
File: ../../../Common/Misc/FileUtil.cpp
Aborted"


I am using Suse 9.0 - this error appeared first a few days after the last update ?! :-/

TethiS
07-20-2004, 03:59 AM
woa, some glitches between the new "steam" binary and your suse ditro??..

kanarip
07-20-2004, 11:42 AM
When I updated the first server (in a row of 16), it *really took a lot of time*, about half an hour.

Then it says you have to restart the tool.

When you do, you'll see the update tool verifying and updating all kinds of files.

Don't forget to shut down your running hlds_l's :P

In the end, I decided to cssh:

screen -A -m -d -S Steam_CS16_GD ./steam -command update -game cstrike -dir /home/GameDrome/cs1.6 -username GameDrome -password **** -remember_password

:P

mcnum
07-20-2004, 12:21 PM
Originally posted by kanarip
When I updated the first server (in a row of 16), it *really took a lot of time*, about half an hour.

Then it says you have to restart the tool.

When you do, you'll see the update tool verifying and updating all kinds of files.

Don't forget to shut down your running hlds_l's :P

In the end, I decided to cssh:

screen -A -m -d -S Steam_CS16_GD ./steam -command update -game cstrike -dir /home/GameDrome/cs1.6 -username GameDrome -password **** -remember_password

:P

What message did you get when you updated the server?
Same like mine: "Getting version 8 of Steam HLDS Update Tool" ???

kanarip
07-20-2004, 02:39 PM
Yes...

Start ./steam the first time, and it'll get a new version of the update tool.

Suppose they didn't manage to put the new version of the update tool into a tarball and release it... :/

The second time you start the update tool however, if the first run has finished, updates your server.