PDA

View Full Version : Control issues are making the game unplayable for me, any solutions?


SH_Algernon
12-21-2009, 10:59 PM
I seem to have some very bad control issues with this game. I can cope with plenty of smaller bugs, but because of the controls I gave up on this game, so I'm trying to get them fixed and hopefully finishing this one at least once.

So anyway, I'm using X360 gamepad, and the control mapping is the default one which the game proposed. Since the game shows numbers instead of actual X360 buttons, this is a reminder of how the four main action buttons are mapped:
Button 1 - A (green button)
Button 2 - B (red button)
Button 3 - X (blue button)
Button 4 - Y (yellow button)
The colors game gives to those buttons do not actually correspond with the colors of these buttons on the actual X360 gamepad, but this isn't of much importance, I memorised the above scheme well enough to use it in real-time.

Now, I noticed 3 particular problems with the controls.
1. Guns sometimes won't fire - this isn't related to the four main action buttons, and it's actually one of the lesser problems. So basically, I push the left trigger to aim, but then pressing the right trigger won't fire the gun in SOME cases. In MOST cases it works just fine, but now and then, pressing the right trigger simply won't do anything. Regardless of the fact that the gun is loaded and ready (this problem doesn't seem to happen with keyboard/mouse combination).
2. I can't zoom on the maps - When I open the map, the game says to press button 2 (which is the red button) to zoom. But pressing it simply closes the map. I can't remember what other buttons do, except that button 3 (the blue one) takes me to the Objectives screen, which works as it should, but I still can't find a button to zoom in on the map.
3. I can't free myself from the needlers - And this is the most serious bug on the list. Because I played the game until the sewers part, where you are attacked by 3 needlers at once. I have 8 shotguns shell and 9 pistol bullets, but it's not enough to take them all out, as they are hard to target, and actually deflect most of the bullets I fire at them (when the bug nr. 1 doesn't prevent me, that is). That's why I have to keep close to them and use melee attacks often. So it's basically impossible to avoid their grabbing attack. Now, when they grab you, the game randomly chooses between any of the 3 main actions buttons (it chooses any button except button 4 i.e. the yellow one), or in case of keyboard/mouse controls, between the left and right mouse buttons. Then you have to start pressing the shown button rapidly in order to free yourself. And this works maybe in 1 of 10 tries for me. Basically, no matter how fast or slow I press the given button, most often Alex doesn't manage to free himself, which is a express route to Game Over screen. I'm sure I ain't doing anything wrong, because in some cases, I actually pressed the button much slower, or even screwed up and pressed the wrong one before actually pressing the correct one, and I still succeeded. Yet, pressing the correct button as fast as humanly possible without actually breaking the controller, or my hand, doesn't always manage to pull it off.

Well, that's what I noticed until now. And I'm sure the above button mapping is correct, because I entered the control rebinding screen and tried pressing every single one of them to ensure that I'm doing everything right (but I didn't save anything upon exiting this screen). Besides, MOST of the actions in the game actually respond to the appropriate (or shown during the game) buttons... MOST, but not all.
The controller is also 100% working properly, because right now I'm having a very good time playing Dead Space with it.

I do hope of having this issue resolved, as I want to continue playing Homecoming as soon as I'm done with Dead Space. But without working controls, what's the point? I'm stuck in the sewers, and figured that even if I do get past this part with the help of the sheer luck, having so much difficulty so early in the game, means the problems can only get worse later on. I also don't like the keyboard and mouse combination in this game, but the third problem persisted even with this control scheme, which I only tried for a short time.

In the case it may help, I have the UK DVD version of the game, running on high quality in 1280x1024 resolution. Here are my system spec:
Motherboard: Gigabyte GA-M720-US3, AM2+ socket
CPU: AMD Athlon X2 "Kuma" 7750+ Black Edition
HDD1: Hitachi 80 GB SATA disk (for the system)
HDD2: Maxtor 300 GB PATA disk (the game is installed on this one)
Graphics: Sapphire ATI Radeon 4870 1GB DDR5
Sound: Creative X-Fi Xtreme Music (with 5.1 speaker configuration)
Input: Logitech Multimedia Keyboard/Logitech MX510 Mouse/X360 Gamepad
OS: Microsoft Windows XP Professional with Service Pack 3

Nothing is overclocked, and all other games I've tried run just fine.

Nickq2007
12-25-2009, 02:56 AM
I haven't played this game with a gamepad - with the PC version.

I just say, give the mouse/keyboard default setup a shot... It's a lot smoother than you would expect. The button mash sequences are then given to mouse 1 and 2 instead of incorrectly labeled buttons, and the gun shooting issue never showed up for me... I did however witness it on a friend's 360 with the trigger.

Dead-Boy
12-29-2009, 01:10 AM
Hi, sorry you got suckered into buying this horrible coded game.


http://forums.steampowered.com/forums/showthread.php?t=1055370

Try this... it worked for me.

I had originally finished this game via keyboard mouse.

Remember not to try to change the controls in game, as it will most likely cause the game to get all messed up (by way of controls), I tried to change controls back, but for some reason it wouldn't work after. I had to go into the .cfg and change stuff around in there before the game would work correctly after trying to change stuff.

Konami = FAIL
Double Helix = EPIC FAIL
Steam = Slap across the face for still selling this game even though it has horrible support and horrible bug/glitches.

Pr3d4t0R
07-15-2010, 05:12 AM
i have a possible solution for this, there is a program called Xpadder, basically whatever are the default controls, you can use this external program to remap your controls go here http://www.xpadder.com/
if you can try to get 5.7 version, because now you have to pay for the newer releases, shouldn't be too hard to find, hope this helps