PDA

View Full Version : Fallout 3 intsalls patch 1.7 every time again when I start the game...


MondPrinzessin
12-25-2009, 12:13 PM
My Fallout 3 GOTY says every time I start the game theres an update through windows live aviable, than installs version 1.7 and starts the game again.

This happens every time I start the game.

Its really anoying but without the patch I cant save the game, so I have to patch it again and again....

Hack Scudder
12-25-2009, 06:07 PM
That's weird. It should already be up to date. Have you tried downloading the latest version of GFWL? I have the retail version of GOTY, and it is already patched to 1.7. I assume the Steam version is also up to date, so I would guess this is a problem with GFWL.

MondPrinzessin
12-26-2009, 07:39 AM
What exactly is GFWL?
And yes I think it is already up to date but the stupid windows live wants to update it first to 1.6. than 1.7 and that every time when i want to play the game :o

Hack Scudder
12-26-2009, 07:43 AM
What exactly is GFWL?
And yes I think it is already up to date but the stupid windows live wants to update it first to 1.6. than 1.7 and that every time when i want to play the game :o

GFWL = Games for Windows Live. You need to make sure you have the latest version of it. I don't know what version is installed with the Steam download, but the version that came with the retail disc was out of date and I had to update it myself.

MondPrinzessin
12-26-2009, 08:33 AM
Ok, I already triead that, deleted the one that was installed, downloaded it manually from the windows live website and now still the same error...

Hack Scudder
12-26-2009, 08:50 AM
Ok that is definitely unusual. It sounds like your installation is corrupt. Right click on the game in Steam, go to Properties, Local Files, and Verify integrity of game cache. If that doesn't fix it, just delete it and reinstall it.

Neureus
12-30-2009, 12:20 PM
Same problem here. I've already checked the integrity of the game, but it makes no difference. Everytime I start the game, GFWL asks me to install patch 1.7. I install it and the game starts while it it is patching, automatically. By doing an Alt+Tab, I can see that the patching process isn't reacting anymore, so I have to cancel the process with the task manager. I start the game again and it wants me to patch again. Endless loop...

Using Windows 7 Home Premium x64 and the german Steam version of Fallout 3: GotYE.

Any idea??

RaggedyAndy
01-03-2010, 12:42 AM
Same problem here. I am running Windows 7 Home 32 bit and the german version of Fallout 3 GOTY from Steam. I am wondering if this might be a localization issue. Anyways i have searched for days now and did not find a solution to this yet. Steam Support sends me over to Microsoft support but i somehow have the feeling that this is not a Games for Windows issue, at least not only. It's something going wrong with the combination of the (german?) Steam version and Games for Windows IMHO.

So far i did not get a clue out of the LIVE support section, i have no idea whom to contact there and how. The problem doesnt appear to be very common, i did not find an entry describing this issue in the forums on GFW or even Bethesda itself. I really hope someone looks into this soon anyways, it is very annoying.

One question though: so far i am playing without logging into Games fow Windows and it appears to work. Do you guys know what the Games for Windows login is required for at all?

RaggedyAndy
01-06-2010, 08:10 AM
Here's what i am doing to work around the issue. I've downloaded the patch 1.7 from the web and i'm starting the game by patching it every time. By doing this manually i dont have to wait for the download from Games for Windows every time i start the game and i can log into my account normally.

I've contacted Steam support again about this as for me it seems to be an issue with Steam and/or Patch 1.7 rather than Games for Windows. Hope the guys there find a final solution quickly.

MondPrinzessin
01-08-2010, 09:10 AM
Yeah I tried that too but that is also anoying every time, is just another way to install it again an again. xD

I think too its a steam problem, maybe not a problem that everyone has, but think its a steam problem. My friend had it too and someday it was gone, so he dont needed to patch it anaymore but he didnt do anything specail to fix it.

Mallefitz
01-08-2010, 02:06 PM
My Fallout 3 GOTY says every time I start the game theres an update through windows live aviable, than installs version 1.7 and starts the game again.

This happens every time I start the game.
Same Problem here ... Win7 Pro 64Bit (German)

isamu99
02-24-2010, 06:07 AM
Guys where exactly do we look to see which version we have?

Galegrey
06-23-2010, 02:29 PM
Same Problem with german Fallout 3 version. (Win7 Home 64Bit)

Jito463
06-23-2010, 03:37 PM
Guys where exactly do we look to see which version we have?

Simplest way, would be to check the properties of fallout3.exe in your Fallout 3 directory. The version number should be 1.7.0.3 (which would be the 1.7 patch).

Teraku
06-23-2010, 04:01 PM
Try using the GFWL disabler. Move your saves out of the My Documents/My Games/Fallout 3/save/(yourname), then use the GFWL disabler.

noxwyll
06-24-2010, 04:26 AM
same problem here.
lanucher verison says
1.1.12
I also talked to steam support
then i tried to contact bethesda support but it seems
you can't contact it. fail

Galegrey
06-24-2010, 11:21 AM
my fallout3.exe version is 1.0.0.15 :(

Maybe somebody can upload a german 1.7.0.3 exe?
Or is that illegal?

noxwyll
06-24-2010, 01:01 PM
i think so
also just new exe won't
work you need the whole patch
updated fallout3.esm etc
also look at the verison of fallout3launcher.exe not fallout.exe for the right version number

Galegrey
06-24-2010, 01:05 PM
i think so
also just new exe won't
work you need the whole patch
updated fallout3.esm etc
also look at the verison of fallout3launcher.exe not fallout.exe for the right version number

FalloutLauncher.exe is 1.1.12.0. Not really better.:mad:

Jito463
06-24-2010, 02:32 PM
i think so
also just new exe won't
work you need the whole patch
updated fallout3.esm etc
also look at the verison of fallout3launcher.exe not fallout.exe for the right version number

No, Falloutlauncher.exe is 1.2.14.0, while Fallout3.exe is 1.7.0.3, which is the correct patch version. You always want to check the primary executable, not the launcher executable.

@Galegrey
Check your properties in Steam for Fallout 3, and make sure the game is set to update automatically. Steam should already have the patch ready to download.

Galegrey
06-25-2010, 12:47 AM
Game is set to update automatically.
When I start the game with Fallout3ng.exe there is no problem, but with the standard Fallout3.exe/launcher.exe there is this update loop from GFWL.

Because the Fallout3.exe is not up to date I cant install any mods. That annoying me.:o

Jito463
06-25-2010, 09:21 PM
Have you tried verifying the game cache? It might even be worth renaming your Fallout 3 directory (as a backup), and re-downloading the game.

noxwyll
06-26-2010, 11:10 AM
i have launcher version 1.7 and fallout3.exe version 1.0

asdfzxc920
06-26-2010, 11:21 PM
If it's Steam that keeps patching it every time, try disabling automatic updates.

noxwyll
06-29-2010, 10:39 AM
steam doesnt try to update it

JCA
07-18-2010, 10:29 AM
A workaround that fixed the Problem for me, is to make a copy of Fallou3ng.exe and rename the copy to fallout3.exe.

Now it runs as 1.7 and Mods are working

Kellerassel
08-10-2010, 03:14 AM
same problem with german version and win7 home prem. 64bit

KarlMonster
08-12-2010, 04:31 PM
Quote: "Try using the GFWL disabler. Move your saves out of the My Documents/My Games/Fallout 3/save/(yourname), then use the GFWL disabler."

What is the GFWL disabler, and where are its controls?

Personally, I prefer to play without signing into GFWL (because I hate it, its annoying and unnecessary).

SaarElwood
08-15-2010, 07:33 AM
I have the same problem.
Everytime when I start the Game is the Version on 1.0 and GFWL try to update the Game to 1.7

I hope somebody will fix this problem

av3nger911
08-16-2010, 09:03 AM
A workaround that fixed the Problem for me, is to make a copy of Fallou3ng.exe and rename the copy to fallout3.exe.

Now it runs as 1.7 and Mods are working
This isn't neccessary, but your tipp helped me. I decided to delete the fallout3.exe - now the game only checks the version of Fallout3ng.exe which is up to date and now I can play with version 1.7 :)

True_MD_Geist
08-17-2010, 08:12 AM
simply download the latest update MANUALLY!!!
This works fine!

SaarElwood
08-18-2010, 07:38 PM
simply download the latest update MANUALLY!!!
This works fine!

No, this doesn't work for me!
Have you restarted the Game after the update over steam? Because I have this problem allready then!

Kaoschan
08-20-2010, 03:14 AM
I got the same:

Windows XP SP3
Fallout 3 GOTY Low-Violence German Version

freshly dwnloaded from Steam, and checked the file versions.

Fallout3.exe - 1.0.0.15
FalloutLauncher.exe - 1.1.12.0

Checking File Integrity via Steam does nothing (Steam tells me that all files passed the test)

And me too got the endless GFWL 1.7 loop AND the DLC's are not working properly

True_MD_Geist
08-20-2010, 03:19 AM
The Game startet automatically after the manual update.
I got the AT-Version of it! I guess windows live cant handle the different .exe

I bet it only has disfunctions with the low violence version.



@kaoshan

just start the game via the launcher und click on data files
simply hock up everything in the list and you got your DLC´s
U can start Fallout via the Fallout3ng.exe

sutkus
08-20-2010, 09:45 AM
Have the same problem here, GFWL wants to install the 1.7 patch on every start. And yes, it's the german kindergarten version XD

av3nger911
08-23-2010, 12:28 PM
Have the same problem here, GFWL wants to install the 1.7 patch on every start. And yes, it's the german kindergarten version XD
Did you try to delete the fallout3.exe?

gundie
08-28-2010, 02:21 AM
The solution for this is simple (ive had the same problem with the austrian version)

Just go to the official site http://fallout.bethsoft.com/
and download the newest patch for the language you use and install it.
exe files now both have the correct version and gfwl wont bother you agin :)

noxwyll
09-01-2010, 09:19 AM
Ok I finally got the solution. Its as follows:
1. Install the Patch normally.
2. Quit Fallout 3
3. Go to steam/steamapps/common/fallout3(GotY)/
4. Move the files Fallout3.exe , Fallout3.exe.cat and Fallout3.exe.cfg to your Desktop
5. In the same folder are the files Fallout3ng.exe , Fallout3ng.exe.cat and Fallout3ng.exe.cfg You have to rename them.
- Fallout3ng.exe to Fallout3.exe
- Fallout3ng.exe.cat to Fallout3.exe.cat
- Fallout3ng.exe.cfg to Fallout3.exe.cfg
6. Run Fallout3, you get asked to update Windows Live (For the last time :D) say yes and let it run till its updated. It will quit Fallout3 at end.
7. Run Fallout 3. Live will download your LIVE profile now.
8. You are done. Your game is UP-TO-DATE
Launcher/Running trough Steam/Fallout3.exe works all just fine now.

SHOULD THIS BREAK YOUR GAME MOVE THE 3 FILES BACK FROM THE DESKTOP INTO THE FOLDER! (BUT IT WON'T BREAK ANYTHING!) THIS IS JUST IMPORTANT FOR CONTRIES THAT GOT THE NO GORE VERSIONS.

SaarElwood
09-02-2010, 05:49 PM
Wow, this works!

THANKS!

HANOI
08-08-2011, 01:34 AM
@noxwyll

Thanks alot! Works perfect ;)

rimshotkiller
09-09-2013, 09:22 AM
Noxwyll you evil genius it worked... :D thanks a lot!