PDA

View Full Version : Shadow of Chernobyl can't save anything


admiral_teal
01-04-2010, 05:23 PM
Bought the game during the sale yesterday and I can't save any settings or games, at all, on Vista32 using my ASUS M50vm. I can load the game and play it just fine, and it doesn't crash, but if I change a setting (say the resolution, for example, or a hotkey) then exit the game, the change doesn't keep. And when I try to save games, it gives me a normal looking "saving" message which completes without issue, but no game saves appear in any folder.

The game is working perfectly... and is completely unplayable, without the ability to save. I've seen virtually no reports of similar problems in some brief searches on google, and none of them offer any kind of solution.

Anyone know of any possible solutions to this?

edit: since there was no crash, I didn't attach a log... but even if I wanted to, the C:\Users\Public\Documents\STALKER-SHOC\ folder simply doesn't exist.

I have already attempted multiple restarts and a full re-install.

marie pavie
01-04-2010, 05:32 PM
Hit F3 & search for where it is saving them, & then edit fsgame.ltx (maybe). Just guessing here.

admiral_teal
01-04-2010, 06:08 PM
I tried to save a game as "stalkersoctestsavefile", which I searched for through all the hidden/unindexed files on my machine. Nothing came up, though I have little trust for Vista's built-in search.

admiral_teal
01-04-2010, 06:12 PM
When I checkedfsgame.ltx, this is what it contained

$app_data_root$=true|false|C:\|Documents and Settings\All Users\Documents\STALKER-SHOC\
$game_data$ = false| true| $fs_root$| gamedata\
$game_ai$ = true| false| $game_data$| ai\
$game_spawn$ = true| false| $game_data$| spawns\
$game_anims$ = true| true| $game_data$| anims\
$game_levels$ = true| false| $game_data$| levels\
$game_meshes$ = true| true| $game_data$| meshes\
$game_dm$ = true| true| $game_data$| meshes\
$game_shaders$ = true| true| $game_data$| shaders\
$game_sounds$ = true| true| $game_data$| sounds\
$game_textures$ = true| true| $game_data$| textures\
$game_scripts$ = true| false| $game_data$| scripts\
$game_config$ = true| false| $game_data$| config\
$level$ = false| false| $game_levels$
$game_saves$ = true| false| $app_data_root$| savedgames\
$logs$ = true| false| $app_data_root$| logs\
$screenshots$ = true| false| $app_data_root$| screenshots\
$downloads$ = false| false| $app_data_root$| downloads\
$mod_dir$ = false | false | $fs_root$ | mods\

This is definitely not correct... Changing the $app_data_root to "C:\Users\Public\Documents\STALKER-SHOC" did not fix the problem though.

marie pavie
01-04-2010, 06:39 PM
Try F3 for ".sav", I don't know what steam defaults to.

admiral_teal
01-04-2010, 07:10 PM
That found a pile of PREY and Borderlands saves, but nothing else.

Ganjalo
01-06-2010, 08:53 AM
Hi,

I've a similar problem. I searched in the Steam directory and it appears that the STALKER directory (at least one part of it) is on readonly.

I tried to set him in normal mode, but there's nothing to do : he came back on read only automatically. I even deleted and downloaded the game again.

I think you have the same problem, admiral_teal.

So, if someone knows how to help us out with this read only...


By the way, please forgive my french's english.

brightsphere666
01-06-2010, 10:45 AM
I've been having the same problem too! Downloaded the game from STEAM this morning, got it updated to version 1.005. Try to save, get a short confirmation message when returning to the HUD, but no save file is accessible when i open the load game menu.

WentBallistic
01-06-2010, 04:11 PM
C:/Documents and Settings/All Users/Shared Documents/stalker-shoc

is where it saves in XP. If that folder is missing in Vista create one if you are sure that filepath in the OP is right. The stalker-shoc folder in XP is small case. Or you could try creating the XP path. Running in XP compatability? Just trying to think of something. Sorry I'm not more help.

Asemodeus
01-06-2010, 11:19 PM
For some reason it says that I can't get into my all users folder, that I don't have permission. Which is ♥♥♥♥♥♥♥♥ because I do. What sort of obscure admin button do I have to click to get into that file?

Phil Bolton
01-08-2010, 03:54 AM
I had this problem when I got SoC at Xmas:-

By default the game saves to a folder called "C:\Users\Public\All Users\STALKER-SHOC\" or something like this - I don't remember exactly.
Whatever, I think it is a legacy from XP. and in my case with Vista64, the folder didn't exist.
My solution -
In the Steam folder for SoC is a file called "fsgame" -
In my case it is:-
C:\Program Files (x86)\Games\Steam\steamapps\common\stalker shadow of chernobyl\fsgame
But it IS in your steamapps folder wherever you have that!

Open the folder "fsgames" with notepad and edit the first line of the file to direct the savegames to to where you want them.
The line you need to change starts
"$app_data_root$=true|false|C:\xxxxxxxxx" where xxxxxxxx is the default "Users\Public\AllUsers\" or somesuch.

In my case I have
"$app_data_root$=true|false|C:\Program Files (x86)\Games\Steam\steamapps\common\stalker shadow of chernobyl\STALKER-SHOC\" And I put it there because that's where the SoC game files are.

When you make the change in Notepad - save the change.

Note that if you ever use Steam to validate local files, then this will re-write the "fsgame" file back to default.

Hope this helps - it worked for me

Phil

Chevyboy88
01-08-2010, 04:08 AM
For most Vista/7 users the vanilla settings should work just fine as the folder will be created in the directory indicated by the fsgame file.

If you do experience problems for whatever reason Phil's solution should work just fine.

It is likely that the problem surfaces due to insufficient permissions, likely running as administrator or disabling UAC (not suggested) would also fix the issue.

If you are uncomfortable or unfamiliar with adjusting permissions Phil's solution is very simple and easy to do.

For Vista, the "stock" file from steam will create the folder in your PUBLIC documents directory, not your <username> directory, also a common mistake.

Ganjalo
01-08-2010, 04:41 AM
Phil Bolton, you're a genius!

Worked well for me! Thanks!

andy50us
10-03-2010, 07:53 PM
Well I have had this game for almost a year now and I have the same problem with the save games. I completely uninstalled it due to this I had even contacted steam and the creators of the game just to get no reply from the creators and steam telling me to go to the creators. Its a damn shame that the people that bought the game were forced to find a fix for this when they shoulda just fixed it their damn selfs instead of releasing a game with known bugs like this.