PDA

View Full Version : Windows 7 File/Folder Permissions


CptGemini
01-07-2010, 08:41 PM
Ok here it goes.....

For some reason all folders across all 3 of my drives are set as read only. When I go to unset read only on any given folder it looks like it goes through all fine and dandy but when I go back to check on it its still set as read only.

I have gone and checked to be sure I had the proper permissions and that was all right and proper.
I have booted into safe mode and tried it there as well, also tried logging into the hidden administrator account and tried to unset read only from a folder and no go.

Anyone have any suggestions on what I can do to fix the issue? I have been trying to change some of my addon settings in wow and everytime I login I have to reset everything since nothing can be saved due to the above mentioned issue.

my specs:
AMD Phenom II 940 Black Box
8GB Corsair XMS RAM
Geforce 295 GTX (1792 MB)

Hope I explained everything good enough.

EDIT: here is a link to some more detailed stats on my system http://www.clanugsm.com/CPTGEMINI-PC.html

Fuzz Bucket
01-07-2010, 08:50 PM
I know the HFS+ driver I'm using in windows makes my HFS+ volumes read-only. I'm guessing there are certain circumstances that will make Windows force a file system to be read-only. Other than that, all I can tell you is that I've had nothing but trouble with permissions in Windows.

CptGemini
01-07-2010, 08:55 PM
Well whatever it is, its damn annoying lol. Everything on all my drives are set as read only. Hell google chrome wouldnt even stay logged in and im suprised IE is even working.

I almost resorted to using my cell phone browser to post here lol

damaged
01-07-2010, 09:06 PM
Hello,



Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows,Windows components and accessories, and other programs.



For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder's Properties dialog box. As a result, Windows Explorer does not allow you to view or change the Read-only or System attributes of folders.



There is a work around that we can use the Attrib command at a command prompt (Cmd.exe) to view or to remove the Read-only or the System attributes of folders.



The following is the syntax for the Attrib command:



C:\>attrib /?
Displays or changes file attributes.

ATTRIB [+R | -R] [+A | -A ] [+S | -S] [+H | -H] [+I | -I]
[path][filename] [/S [/L]]

+ Sets an attribute.
- Clears an attribute.
R Read-only file attribute.
A Archive file attribute.
S System file attribute.
H Hidden file attribute.
I Not content indexed file attribute.
[drive:][path][filename]
Specifies a file or files for attrib to process.
/S Processes matching files in the current folder
and all subfolders.
/D Processes folders as well.
/L Work on the attributes of the Symbolic Link versus
the target of the Symbolic Link



For example, If we'd like to view the Read-only or the System attributes for the folder C:/Test, just type the following command:



attrib C:\Test



If we'd like to remove the Read-only attribute and to set the System attribute for the folder C:/Test, use the following command:

attrib -R +S C:\Test



For more information, please refer to the below KB article:



You cannot view or change the Read-only or the System attributes of folders in Windows Server 2003, in Windows XP, or in Windows Vista

http://support.microsoft.com/kb/326549/en-us



Thanks.



Regards,
Neo Zhu -MSFT


Source: http://social.technet.microsoft.com/Forums/en/winserverfiles/thread/915ad151-45d2-4962-9328-d707df507eea

CptGemini
01-07-2010, 09:22 PM
I followed instructions in the above mentioned article and below was the error.

D:\>attrib -r d:\Games\World of Warcraft\WTF
Parameter format not correct -

damaged
01-07-2010, 09:26 PM
Try:

attrib -r +s d:\Games\World of Warcraft\WTF

If UAC applies, make sure the cmd prompt is run as administrator (right click Run as administrator on command prompt shortcut).

CptGemini
01-07-2010, 09:28 PM
Yea I did that one as well and got the same error message.

Any new folder I create on any of my drives start out as read-only and stay read-only when I try to unset them within windows.

damaged
01-07-2010, 09:33 PM
EDIT: Try this:

attrib -r "d:\Games\World of Warcraft\WTF"


It's the spaces.

<newline>

CptGemini
01-07-2010, 09:52 PM
Well it didnt give me any errors that time but when I go to check the folder via windows explorer or however you want to put it, read-only is still ticked on.

EDIT: i double checked the attribute at the dos prompt and it shows right and proper like I want it, I am going to load the game and see if anything saves like i want it to.

damaged
01-07-2010, 09:58 PM
Well it didnt give me any errors that time but when I go to check the folder via windows explorer or however you want to put it, read-only is still ticked on.

The reason is in my first post.

"Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows,Windows components and accessories, and other programs.

For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder's Properties dialog box. As a result, Windows Explorer does not allow you to view or change the Read-only or System attributes of folders."



So, to view the read only attributes, you should not use Explorer, instead at the command prompt type:

attrib "d:\Games\World of Warcraft\"

You will note that there is no R attribute on files in the WTF folder.

Issue a:

attrib +r "d:\Games\World of Warcraft\WTF\*"

then:

attrib "d:\Games\World of Warcraft\"

You will see the R attribute applied to the files in the folder WTF.

So it is the files that matter, the folders R attribute on folders is meaningless.

<newline>

CptGemini
01-07-2010, 10:03 PM
Yea i did that command at the dos prompt to check the folders attribute and it was correctly set.

I just got into the game and reset my junk and then reloaded the game to see if it stayed and its all right and proper. Thanks for the assistance :D.

damaged
01-07-2010, 10:05 PM
Yea i did that command at the dos prompt to check the folders attribute and it was correctly set.

I just got into the game and reset my junk and then reloaded the game to see if it stayed and its all right and proper. Thanks for the assistance :D.

No problem. Glad it worked for you. :)

marie pavie
01-07-2010, 10:43 PM
http://www.blogsdna.com/2159/how-to-take-ownership-grant-permissions-to-access-files-folder-in-windows-7.htm
Might've worked too.

CptGemini
01-07-2010, 11:19 PM
Yea i checked those permissions too, I probably spent the better part of 2 hours fiddling around with various things and possible fixes before I came here and got it fixed. Was so damn annoying, so annoying I was ready to go install my copy of vista and not use windows 7 since I didnt have any problems until I started using it.

Washell
01-08-2010, 01:39 AM
Did you do an upgrade or a clean install? If you did an upgrade you can't really blame windows 7.

CptGemini
01-08-2010, 09:30 AM
It was a clean install with my restored backup and I am thinking that may be what did it. Next time I make a backup I will have to be careful what it picks.

CptGemini
03-01-2010, 10:07 PM
Back to having the same problem again only this time I am getting an access denied error and I am typing it in as follows.


D:\Games\World of Warcraft>attrib -r +s "D:\Games\World of Warcraft\Data"
Access denied - D:\Games\World of Warcraft\Data

T Rush
03-01-2010, 10:23 PM
I got turned on to this You may want to futz with the ownership ....

Maybe this (http://www.mydigitallife.info/2009/05/21/take-and-grant-full-control-permissions-and-ownership-in-windows-7-or-vista-right-click-menu/)? haven't really needed it yet, but it might help you

CptGemini
03-01-2010, 11:25 PM
I got turned on to this haven't really needed it yet, but it might help you


Thanks, that worked