PDA

View Full Version : Fixed stuttering issue to crash


Alkpaz2
01-08-2010, 01:38 PM
This is using Windows 7 Ultimate 64bit
Ran the game by the main directory (right click on sacred2.exe and go to compatibility tab) with run in XP SP3 mode with admin checked, as well as applying to all users. The game works even with maxed settings no stuttering then crashing at all!

Hope this helps anyone with the same problem..

My rig:
CPU: i7 975 3.33
GPU: BFG Geforce 295 GTX

The rest is blah blah blah..

P.S. I also revoked it using the tool.. this could have had an effect as well..

Jenge
01-11-2010, 08:43 PM
This does indeed help, but the game still likes to freeze the box forcing a hard reset. I own like 170 other games on Steam that don't do this... considering the amount of problems reported with Sacred2 (and its lack of support/patches/company going out of business) play at your own risk.

At least it finally came down from $50, though $30 is still a bit steep for this one.

Jenge
01-12-2010, 05:17 AM
Turning off PhysX acceleration in the NVidia control panel may help freezes too

Jenge
01-12-2010, 01:23 PM
Not a single freeze/crash/issue since setting compatibility mode and disabling PhysX acceleration in the NVidia control panel. They should have patched this...

Crusader
02-17-2010, 11:20 PM
I still get the occasional freeze when transferring between locations (aka going inside a cave/leaving a cave), in which CAD is needed to 'fix'. Otherwise it runs fine.

Phileosophos
02-18-2010, 03:58 PM
Thanks for the thread, Alkpaz2. Your fix didn't work for me, but it did put me on the right track. I got the game working on my system (also Windows 7 Ultimate 64-bit edition) by setting compatibility to "Windows 98/Windows Me" and running as administrator. I still get the audio stuttering if I set it to any flavor of Windwos XP, but it goes away completely if I use Win98/Me instead. Go figure.

I can turn on all the graphical goodies and I can even enable OpenAL audio, which gives noticeably better surround sound. I get a nice smooth framerate (averaging around 45 FPS) unless I enable PhysX support, and then it drops in some spots down to the high teens. Thanks for the help!

wipeout364
02-27-2010, 01:31 PM
Thanks, worked for me as well. Running in windows XP SP3 mode and physx disabled.

Elcardil
05-05-2010, 02:16 AM
Works for me also, thank you very much.

tekhedd
05-07-2010, 02:03 PM
This is using Windows 7 Ultimate 64bit
Ran the game by the main directory (right click on sacred2.exe and go to compatibility tab) with run in XP SP3 mode with admin checked, as well as applying to all users. The game works even with maxed settings no stuttering then crashing at all!


Sadly, this did not work for me.

I'm running the steam version (2.43?) on Win 7/64 Ultimate, 9800M and a selection of internal or USB audio cards. I get stuttering at the main menu and a crash either at the menu or intro movie.

I've tried XP and 98 compatibility modes, the -skipopenal and -nocpubinding flags, and running as administrator, separately and in combination.

Oh yes, and I've re-installed openal and physx to the latest versions, and have disabled physx.