PDA

View Full Version : Windows 7 + CS:S starts to launch then stops?


jaybear
01-19-2010, 03:10 PM
So I've recently installed Windows 7 32-bit Home edition and I did a clean install of Steam.

Whenever I click on CS:S and then launch, the little box pops up and it says that it's preparing to start the game and then it disappears and nothing happens. I was wondering if anyone could help me so I can play... Thanks a ton.

djkissmybum
01-19-2010, 06:52 PM
Right click on game - Properties - Local files - Verify cache

spooksmagee
01-20-2010, 12:09 AM
More info here: https://support.steampowered.com/kb_article.php?ref=6218-USFX-5568

jaybear
01-20-2010, 06:42 PM
I tried that stuff and it still just...doesn't launch after the little box goes away, any other ideas?

jaybear
01-20-2010, 06:42 PM
Unless it's some sort of driver?

jaybear
01-20-2010, 06:50 PM
My drivers are all up to date :(

NitrousX
01-20-2010, 07:19 PM
Try deleting the Clientregistry.blob file in your steam directory (C:\Program Files\Steam\).

jaybear
01-20-2010, 07:33 PM
I did that... still no luck. I've updated every driver and all. It say's I'm In-Game for like 2 seconds then stops. :(

spooksmagee
01-20-2010, 10:13 PM
You could also try launching the game below your default resolution, something like 800x600. You can do it with a launch option command, I don't know them off the top of my head though. Also try launching the game with an older version of directx, like 8. Try updating you bios drivers too.

Last resort would be to reinstall Windows 7 I guess.

doykA
01-21-2010, 07:57 AM
You could also try launching the game below your default resolution, something like 800x600. You can do it with a launch option command, I don't know them off the top of my head though. Also try launching the game with an older version of directx, like 8. Try updating you bios drivers too.

Last resort would be to reinstall Windows 7 I guess.

The launch commands are

-w 800 -h 600

for 800x600 resolution.

it.me
01-21-2010, 08:37 AM
Jaybear are you running dual screens?

If so i personally posted a fix i found a while back that i found somewhere else and it sorted it perfectly for myself and other user's with this problem.



Edit: Found this...


FIX:
- Navigate to your SteamApps folder (usually "C:\Program Files\Steam\SteamApps\[Username]\counter-strike source")
- Right click the "hl2.exe"
- On the compatibility tab check the checkbox "Disable Desktop composition" and "Disable Visual Themes". Apply the changes
- Now start CSS as usual

Extra Note: Turn off UAC (Cos to be blunt it's Pants!)

So if this is the case that you are running dual screens this will fix it 100% without any other third party software that some other people/threads are saying you need to install some garbage software.

Anyway even if you don't have dual screens it maybe an idea to try this out just to see.

good luck, IT ;)


PS. I wish someone would make a sticky on these forums for this Win7 fix for all to know instead of trolling through to find it :confused:

jaybear
01-21-2010, 09:56 AM
No I just have one monitor...but I'll try it anyways

it.me
01-21-2010, 10:54 AM
No I just have one monitor...but I'll try it anyways

Ok. Let us know if it works for you please.

There is also talk of unticking "Enable Steam Community In-Game" in Steam settings/In-Game as that as been known to cause some problems for people on Win7 also.

I do hope you finally get it sorted as i was gutted when i first upgraded to Win7 only to find that CSS didn't want to run anymore.

You could also try on http://www.sevenforums.com/ for some really good support.

Best of luck,

IT

jaybear
01-21-2010, 12:24 PM
Thats weird, I get an error that says this game is currently unavailable at this time, now.

it.me
01-21-2010, 01:26 PM
Thats weird, I get an error that says this game is currently unavailable at this time, now.

Hmm sounds like you have something more sinister going on then. Just undo what the original fix said in my first post. Or try unticking one of them then run CSS again and then the other.

Anything is worth a shot i suppose and if you still have no luck check around on the Sevenforums link i posted earlier. You never know you may come up with something positive ;)

dragonspirit97
08-03-2010, 04:06 PM
hey i having the same problem as jaybear if u could update the forum or if jaybear got his css working i would like to know because i am really REALLY eger t get back on css....

hisham.albeik
08-03-2010, 05:38 PM
try disabling ingame overlay. right click css, properties, general tab, uncheck ingame steam community.

brandonnys
08-03-2010, 05:51 PM
Hey, I'm having the same issue as Jaybear, except mines with a totally clean installation of Windows 7 Pro.

Here's what I did:

1. Installed Windows.
2. Updated Video Drivers (GeForce GTS250)
3. Ran Windows Update and disabled the UAC
4. Installed Steam
5. Downloaded CSS
6. Tried to play, no go.
7. In hl2.exe properties, disabled visual themes and desktop composition, and checked the "Run as Administrator" option.
8. Tried to play, No Go.
9. Disabled In-Game Community.
10. Tried to play, NO GO.

Any Suggestions?

brandonnys
08-03-2010, 06:09 PM
Got a fix for my issue.

1. Go to the CSS Directory ( ..\Steam\steamapps\[USER NAME]\) and either rename or delete the CSS folder (I renamed mine to counterstrike source.old).

2. Run the game from within Steam. It should re-extract your game cache files and you should be able to play.

dragonspirit97
08-05-2010, 02:36 PM
try disabling ingame overlay. right click css, properties, general tab, uncheck ingame steam community.

i already have done that
i think this may be the problem:: im starting to think before i got win 7 my css was hacked to not pull up, and i mite think that may-maynot effect in the new copy of my OS
or
it could be that when i got win7 that i have to trun on a certain thing to make certain apps to work, but if there is one i cant find.
or
there could be a miss config file in one of /all of my game files that win 7 may have deleted in the process of installing. the part were it allows the game to run after the preparing to launch

dragonspirit97
08-05-2010, 02:38 PM
Got a fix for my issue.

1. Go to the CSS Directory ( ..\Steam\steamapps\[USER NAME]\) and either rename or delete the CSS folder (I renamed mine to counterstrike source.old).

2. Run the game from within Steam. It should re-extract your game cache files and you should be able to play.

sound like a good idea
ill try it:D:cool:

dragonspirit97
08-05-2010, 02:41 PM
if this works brandon.... u will be worshiped like a god!! GOD MAN!!
:D:D:D:D:DD:D:D:D:D

dragonspirit97
08-05-2010, 02:52 PM
i tried it for gmod becuz i had this problem for all my games and new ones like alien swarm, it didnt work.(i changed the name i have yet to do the other

dragonspirit97
08-05-2010, 06:01 PM
hey bradon it didnt work
:'(

TyFytr
08-06-2010, 08:16 AM
any new updates? I'm having the same issue. I reinstalled CSS yesterday and then when I went to play it didn't work. I selected CSS and then the Steam box came up saying that it's starting CSS, but then nothing. I was looking at some logs but nothing really stuck out to tell me as to why it would not load...

dragonspirit97
08-10-2010, 10:04 AM
i need help updating my drivers on my dell insprion 1501.

i dowload the download list from dell and i add the driver update checked to to list to update, but the download list keeps saying that it dosent have any downloads!..?
HELP??

lSolol
08-10-2010, 11:16 AM
go to windows task manager go to steam.exe end process then reload steam...I also have windows 7 it does it to me from time to time

md3
08-10-2010, 11:43 AM
Go to you steam folder. Delete everything execept the steam application file. Then run the only remaining file. THis will require you to redowload your games, but it should fix your problem. Make sure to back up your cstrike (if you want to save your configs and whatnot) before deleting the files mentioned above.

dragonspirit97
08-20-2010, 09:00 AM
go to windows task manager go to steam.exe end process then reload steam...I also have windows 7 it does it to me from time to time

HELP DIDNT NOT WORK!!!
.-..-..-.
(SOS)
:eek::(