PDA

View Full Version : Horrible FPS


ScullZomBeN
03-04-2010, 07:47 PM
Just bought the game today, and basically can not play because of how sluggish it is. Moving my mouse in the menu's is even delayed. I move my mouse, and then 2 seconds later it moves on the screen. The triangles in game move extremely slow, and just ruins it.

Specs

i5 661 @ 3.3Ghz
4GB DDR 3 Ram
Ati 4870 1GB
Windows 7 Ultimate 32bit.

Any help available? Tried looking on the Galcon forums and nothing there either.

PwerLvlAmy
03-04-2010, 07:49 PM
Is there any moiuse smoothing or mouse lag reduce in the option ? if yes desactive it ! The mouse lag happen when i use these option in some of my game!

freibooter
03-05-2010, 01:35 AM
Are you using the new Steam UI beta?

I'm experiencing the same thing all of the sudden. As of today Galcon Fusion is causing my CPU to spike at 100% and is absolutely unplayable.
It might be related to me finally getting the new Steam UI overlay working again (I think there is a known bug with it) but it is doing the same thing after disabling the Steam overlay so I'm not sure.
I'm pretty puzzled by this since GF worked perfectly fine in the beginning and just when I was getting into it I can't get it to run properly any more.
The odd thing is that the Galcon Fusion process isn't the one maxing out my CPU, it appears to be busy with a gigantic number of system calls. At the moment it's pretty unplayable ... but I'm sure it will be sorted out quickly (an update addressing a lot of issues has already been promised).

My specs:

Athlon 64 X2 4200+
2GB DDR
Geforce 250 GTS
Windows 7 Ultimate 32bit

ScullZomBeN
03-05-2010, 04:10 AM
Yes I am using steam beta.

freibooter
03-05-2010, 05:31 AM
I just tried again ... everything is 100% unchanged to four hours ago ... I didn't even turn off my PC while I went outside. No updates to Steam, no updates to GF and everything is smooth again. And it's not like it was an odd fluke earlier, I really tried to launch it very often and tried a lot of different settings, nothing worked.
This is certainly the weirdest glitch I have experienced in a long time ...

Update: ... and it's back! 100% CPU, my graphics card is starting to boil and I'm only in the single player selection screen - WTF?


Update 2: ... and in the time I wrote this update everything went back to normal ... I am thoroughly confused.

freibooter
03-06-2010, 01:09 AM
... I simply don't understand what's causing this but Galcon Fusion is the only game that can currently almost bring down my entire system.

I'm really looking forward to the promised update now.

ScullZomBeN
03-06-2010, 02:07 AM
Still unplayable. I have seen some Galcon Mods posting on these forums, so, any options for me?

freibooter
03-06-2010, 11:24 AM
Still unplayable. I have seen some Galcon Mods posting on these forums, so, any options for me?

I don't think it's plural "mods" ... it's a single guy named phil as far as I know and he also appears to be the sole developer.
And I assume he doesn't work 24/7 and probably took the weekend off. :)

But he kept mentioning that an update fixing several bigger bugs(hopefully including one that causes ours) was just around the corner. Let's hope it will be on Steam soon.

Nanno
03-06-2010, 02:21 PM
Sorry you guys are having trouble. I'm Phil's wife, and I'm sort of holding down the fort while he's away at GDC. He's been crazy busy the last couple of days and now he's in transit to San Francisco, but he should be keeping up with things once he gets there. I'll make sure he sees this thread. Once again, sorry ya'll are having issues!

freibooter
03-06-2010, 02:50 PM
@Nanno

I wasn't worried. I'm pretty sure this is just an unlucky combination of several factors that will be sorted out sooner or later.
But thank you so much for your great support, GF really is a surprisingly fun game and that's why I couldn't wait to play it again. :)


@ScullZomBeN

Did you by any chance try to run the game in a window? I know I did (that's how I like to play my coffee break games so I can keep an eye on other things). I forced Aero to be disabled in GalconFusion.exe's compatibility settings and it appears to be working again for now. :)
It's still confusing that sometimes the game works like a charm and at other times it's unplayable ... I'll keep an eye on it, maybe disabling Aero is a good solution for now.
Even if you're not running it in a window, forcing Aero off might be a solution for now.

ScullZomBeN
03-06-2010, 03:54 PM
Cheers for the update Nanno.

Frei - I have tried it windowed, but still the same issue. Will try it with Aero disabled.

Edit - Still same issue with Aero disabled.

Nanno
03-07-2010, 07:46 AM
By the way, you guys may want to check out some of the threads in the Support section on the Galcon Fusion forums at our website. http://www.galcon.com/forums/33/38/

Phil has answered a lot of questions there, so it could be the solution to your problem is found in one of those threads.

philhassey
03-07-2010, 09:28 AM
Hi,

Galcon doesn't run well on all systems. There are some video cards it just doesn't like. However, here are two things you can do which fixes it for most people:

- Make sure you have the very latest nvidia/ati/intel drivers for your card, Galcon uses opengl and sometimes the windows-included drivers just don't work with it.

- Right click on your desktop > properties > display settings > 32 bit > -- The current build of Galcon requires 32 bit to render quickly.

- Wait until I can get this update out, it might also improve things.

I hope that helps!
-Phil

freibooter
03-07-2010, 11:39 AM
Once again, thanks for your support phil. :)

I'm usually and currently using the latest WHQL Nvidia drivers (the ones that were pulled because of the fan-control issues, but my card wasn't really affected and never goes over 50% fan speed anyways).

My display settings are 32bit but I do have a dual monitor set-up, I'm wondering if that is tripping Galcon Fusion. Other OpenGL games are not affected at all and I thought that Nvidia's OpenGL support was pretty solid in comparison.

As I said before, this is a very odd bug as it really doesn't happen all the time ...


Anyways, a couple of questions:

* Any planned ETA for the new update on Steam?
* Is the beta on Galcon.com newer than the version on Steam?
* Can we use any version of Galcon Fusion with the GF-account created with the Steam version (i.e. non-Steam. Linux, Mac?)
* If we can and do, will our GF-trophies won in other versions of the game register as Steam achievements after running the Steam version again?

philhassey
03-07-2010, 09:31 PM
- I've finished the update, just waiting on steam to correct an issue with the steam client so the invite feature works.

- Yes :)

- Yes :) Feel free to have it on your home and office machine!

- No, to get Steam achievements you must achievement the achievement while playing Galcon on Steam.

Cheers!
-Phil

philhassey
03-07-2010, 09:33 PM
Also - I'm curious about the dual monitor issue. If you disconnect one of the monitors, does Galcon run fast again?

Thanks!
-Phil

ScullZomBeN
03-08-2010, 03:27 AM
Tried with latest drivers and 32 bit (which was already set) and still no dice. Will wait for update. Hopefully shouldn't be long considering you have finished it.

Thanks for your help.

ScullZomBeN
03-16-2010, 01:24 PM
So ... About that update?

Mr_Pantaloons
04-11-2010, 02:32 PM
I had the same problem a few months ago. Galcon Fusion uses OpenGL, so if you don't have it properly installed or is missing somehow then you guys need to update your drivers to get proper OpenGL functionality. Once I did that my problem went away and I've been happily gaming ever since :D