PDA

View Full Version : Solved my freezing problems - may be suitable fix for others


GeriatricLemon
03-10-2010, 09:58 PM
I have finally found a resolve for my frustrating freezing issues:

My problems with crashing of the game was primarily a sudden freeze with a sound byte still audible and a normal graphic displayed, but frozen. The only way out of this was a hard reboot. It would happen randomly, but often, sometimes not even in a game, just in the loading screen.

After much mucking around with making sure all drivers were updated, bios's were the latest and running the game at bare minimum's with my video cards at basic settings and my cpu at it's original non over-clocked settings, I was still getting problems.

The fix:
Through control panel I disabled the Realtek on-board sound. Instant success - no crashes, played for hours on end and happy as larry - except no sound was an issue.

Fortunately for me my graphics cards have HDMI sound support so I have used that instead - the only downside to that is for general use the screen is a tiny bit out of focus, but in-game it is perfect.

****If you are having issues with constant freezes then I'd suggest a quick test is to disable your sound through control panel/devices and see if it remedies it.******

Obviously this isn't a fix for the other problems like closing to desktop but it is one solution that has satisfied me immensely and has made the game playable.

Others have found that by putting in a sound card they have cured this problem.


My current settings for the game are as follows and I enjoy about 140fps and no lag:

[WindowSettings]
Width=1920
Height=1080
Fullscreen=true
RefreshRate=60
VSync=false
[Sound]
Quality=high
VoipEnable=true
SpeakerCount=0
[Graphics]
Effects=medium
Soldiers=medium
Vehicles=medium
Overgrowth=medium
Undergrowth=medium
StaticObjects=medium
Terrain=medium
Shadows=high
Bloom=false
HSAO=false
MSAA=6
Water=medium
MainQuality=custom
Texture=high
DxVersion=11
Aniso=4
Detail=medium
RenderAheadLimit=
Fov=70


My current working setup:

Operating System: Windows 7 Ultimate 64 bit
CPU:Intel Core i7 920 @ 4.2GHz
Motherboard: ASUS P6X58D Premium - Bios 0703 (Latest)
Cooling: Noctua NH-D14 (The beast)
RAM: 12Gb Corsair HX3X12G1600C9 XMS3DDR3 runnng at 1600MHz
Graphics Card(s): 2 x Crossfire Mode Sapphire HD5870 Vapor-X - (In overdrive mode)
Latest Manufacturer supplied BIOS to each card
GFX Driver version: ATI Catalyst 10.2 (tried 9.12, 10.1 and now latest 10.2)
Sound Card: On Board RealtekŪ ALC889 8-Channel High Definition -DISABLED
Sound card driver version: 6.0.1.5959
Router/Modem: Netgear DGN3500

XEshamX
03-10-2010, 10:20 PM
hmm, i have an xfi so maybe thats why i can play all the time

justachap
03-11-2010, 01:30 AM
how do you turn it off?

Doom721
03-11-2010, 01:36 AM
Yeah I love my creative xfi card, turn on all the shiny settings and 3d surround sound when I play games

Athariel
03-11-2010, 02:09 AM
Its worth posting this on the electronic arts.co.uk forums so the devs can see it and intiate a fix.

Takenover83
03-11-2010, 02:24 AM
I suggested that fix to many folks having the same problem in this thread (http://forums.steampowered.com/forums/showpost.php?p=13940327&postcount=13). Glad to see it worked for someone.
Could have something to do with onboard sound. Try disabling, if possible and using a difference source for sound (usb, pci, etc)


Source: http://www.techspot.com/article/255-battlefield-bad-company2-performance/page8.html

oeuf
03-23-2010, 01:06 PM
Just out of curiosity. Did this solution fix your online multiplayer problem or singleplayer or both?
Because I can play SP just fine, but then i get the crash/freeze/soundloop in MP. I'm using onboard sound by the way. i'll try to disable that tonight when i get home and see what happens. Thanks for the advice though.

GeriatricLemon
03-23-2010, 06:02 PM
Only seemed to have the problem with MP and it fixed it completely.

Valdez
03-30-2010, 10:06 PM
I have an xfi extreme gamer sound card, and i still get the problem. I have a friend with an auzentech soundcard, and he still gets the problem

FocusPocus
03-30-2010, 10:18 PM
my issue was due to overclocking and setting the ram timings using xmp profile instead of manually, also didnt check with prime 95, had to downlock my OC to 4ghz instead of 4.2 to be stable.

Morrowhen
10-02-2010, 01:07 AM
[WindowSettings]
Width=1920
Height=1080
Fullscreen=true
RefreshRate=60
VSync=false
[Sound]
Quality=high
VoipEnable=true
SpeakerCount=0
[Graphics]
Effects=medium
Soldiers=medium
Vehicles=medium
Overgrowth=medium
Undergrowth=medium
StaticObjects=medium
Terrain=medium
Shadows=high
Bloom=false
HSAO=false
MSAA=6
Water=medium
MainQuality=custom
Texture=high
DxVersion=11
Aniso=4
Detail=medium
RenderAheadLimit=
Fov=70



Could aggressive settings cause "crash to desktop" as well? I just copied and pasted your setting.ini file over to mine. I played for 2 hours with no problems.. don't know what to make of this.

My settings were all maxed out before.. but I held 50+ fps