PDA

View Full Version : Crysis 1 Crashes When Changing Settings...


Grunt121
03-22-2010, 07:41 AM
Ok, so playing Crysis i thought my new comp might handle highest graphics on the full screen resolution (1920x1080) ofcourse it lagged like crazy so i went back into options and tried to change them, it crashed as soon as i i clicked OK in the little "Are you sure you want to make these changes" thing, it also happend when i tried playing Multiplayer, i know peeps say to use Crysis Wars but i was curious, so i clicked Save Password, and it crashed again. Bare in-mind that i DID download the demo of crysis before i bought the game, no problems at all... this also doesnt occur with crysis wars or crysis warhead, this HAS to be something to do with steam...unless anybody knows better?

:eek: halp!

GrandMaster_J
03-22-2010, 10:59 AM
What anti virus are you using?

There is an issue if you are using avg, and saving/making any settings changes.

If you are using avg, open tools in avg, then advanced settings.
go to the section that says resident shield - directory excludes.

add path, documents> my games> crysis.
(I'm using windows 7, so yours might be a little different, but close)

If you're not using avg, then I don't know. But that's what fixed mine when I was having that issue. COuldn't save any changes, or switch to fullscreen :P

Grunt121
03-22-2010, 07:09 PM
i have tried this, and it didnt change it, still crashed >_<

Vitruvian Man
03-23-2010, 03:33 PM
I'm having the same issue, and I also tried the AVG fix and that didn't work. Any time I make changes to settings or try and log into the multi player it crashes on me. I also tried playing some single player and it was very laggy, not to sure if it's the same issue or not.

Any know fixes would be great.
Thanks.

Nutoi
04-24-2010, 10:17 PM
Any ♥♥♥♥en clue?

I want to play online...

JayEm187
04-25-2010, 03:17 AM
Same problem here... Changing the compatibility to Vista (SP2) worked at first, but doesn't anymore.

Grunt121
04-25-2010, 06:30 AM
Guys, it has been solved! It was a problem with Windows Security being damn stupid! all you gotta do is Go to C:/Users/[yourname]/My Documents/My games and there you should see some crysis folders! (especially Crysis itself!) now what you do is right click the crysis folder, and click properties, on properties go to secutiry and click the edit button, Click Add and type in the words EVERYONE, after the Everyone thing spawns in the box, click Ok and apply, wallah! it should work! if it doesnt, as said before, try the AVG fix <3

Mack_Mittenz
04-26-2010, 07:42 PM
Ok, so playing Crysis i thought my new comp might handle highest graphics on the full screen resolution (1920x1080) ofcourse it lagged like crazy so i went back into options and tried to change them, it crashed as soon as i i clicked OK in the little "Are you sure you want to make these changes" thing, it also happend when i tried playing Multiplayer, i know peeps say to use Crysis Wars but i was curious, so i clicked Save Password, and it crashed again. Bare in-mind that i DID download the demo of crysis before i bought the game, no problems at all... this also doesnt occur with crysis wars or crysis warhead, this HAS to be something to do with steam...unless anybody knows better?

:eek: halp!

I had this same problem, just go to your crysis properties and go to the compatibilty tab, scroll down to display desktop composition and disable it,apply then hit ok, it should work. Tell me if it works.

Kcriton
12-13-2013, 08:50 PM
Its AVG

Disable it and the game works perfectly.

This is using the DVD based game not Steam version though so I dont know if its the same