PDA

View Full Version : NVidia SLI supported?


mwoody
03-23-2010, 01:49 PM
In the demo, I noticed that darker scenes - in particular the opening cutscene - were almost pitch black save for a strange visual noise. In the final version, this problem seems to have gotten even worse, with the opening scene almost completely unplayable.

For example, this is a screenshot from the "dark tower" benchmark, taken via FRAPS (it's not just a black square, but you'll need to see it full size to pick anything out):
http://img153.imageshack.us/img153/3156/justcause22010032315281.th.jpg (http://img153.imageshack.us/i/justcause22010032315281.jpg/)

I tried disabling all graphical options, updating drivers, changing around NVidia driver options - eventually I found the cause: SLI. Disabling SLI drops the framerate considerably (as would be expected), but it immediately fixes the problem.

Has anyone else experienced this issue or, conversely, had good luck with SLI? I'm running dual GTX280s, and I can post a dxdiag if necessary, but first I just wanted to confirm that the game supported it at all.

With all the fancy GPU rendering and CUDA stuff this game does, it would be a damn shame to be limited to only one card.

Dudechill
03-23-2010, 02:11 PM
It works fine with my GTX295, and its always sli... so. idk mane

Alkpaz2
03-23-2010, 02:27 PM
Check out the Benchmark results thread. One guy in there is running SLI. You may want to PM him.

http://forums.steampowered.com/forums/showthread.php?t=1195861

General Jameson

born2expire
03-23-2010, 09:57 PM
my SLI'ed 275's work flawless, check your drivers. I'm running the newest 197.13's

CaptainDingo
03-23-2010, 10:03 PM
Something's seriously messed up with that cutscene just in general. I run the rest of the game pretty nice and smooth on medium/high settings, but for no particular reason that cutscene runs at like 5 FPS and in slow motion.

There's not much to see anyways, so at least you're not missing much. :p

Oh, but if this is affecting gameplay, then I could definitely see the urgency of the issue...

mwoody
03-27-2010, 01:34 AM
Yeah, that first cutscene is weirdly slow, but I suspect that's a different issue.

As to my problem, I did eventually fix it by completely uninstalling and reinstalling the NVidia graphics drivers. It may also have been a strange result of an incorrectly installed Rivatuner, as I removed that at the same time - I know, I know, changing two experimental variables at once, but I just wanted the thing fixed.

Anyway, just noting it here so it's searchable in case someone else has the same issue.

thegame696911
03-28-2010, 12:05 AM
I'm running Dual 8800's and the game is crashing randomly. Sometimes I can play for an hour, sometimes 5 minutes. When it crashes it's pretty odd, the screen basically explodes with frames broken and the game slows waaay down. Hopefully a patch fixes these problems.

Dateranoth
03-28-2010, 10:39 AM
I'm running Dual 8800's and the game is crashing randomly. Sometimes I can play for an hour, sometimes 5 minutes. When it crashes it's pretty odd, the screen basically explodes with frames broken and the game slows waaay down. Hopefully a patch fixes these problems.

I'm getting this same issue. Two 8800GTX's in SLI and the issue sometimes carries over to windows. Must be a driver problem. Sometimes I can simply disable and then enable SLI and it fixes the problem. However, sometimes I get the frames broken on the windows desktop itself, and I have to reboot.

Intel Core i7 920 @ 4Ghz
6GB 1600MHZ DDR3
8800GTXs SLI 197.13 WHQL Drivers
Windows 7 64bit

1680x1050 resolution and problem happens regardless of settings.

DARKNIGHT
03-28-2010, 11:03 AM
I do not have any issues with my gtx 280s in sli. I am running on 195.62 and the performance is great in this game.

The new drivers do not work so great for my setup, so im sticking to the older drivers for now.

i7 920
sli 280
6gb ram
win 7 64bit.
1920x1200.

thegame696911
03-28-2010, 11:27 AM
I'm getting this same issue. Two 8800GTX's in SLI and the issue sometimes carries over to windows. Must be a driver problem. Sometimes I can simply disable and then enable SLI and it fixes the problem. However, sometimes I get the frames broken on the windows desktop itself, and I have to reboot.

Intel Core i7 920 @ 4Ghz
6GB 1600MHZ DDR3
8800GTXs SLI 197.13 WHQL Drivers
Windows 7 64bit

1680x1050 resolution and problem happens regardless of settings.

I'm having the exact same problem.

Dateranoth
03-28-2010, 11:55 AM
I do not have any issues with my gtx 280s in sli. I am running on 195.62 and the performance is great in this game.

The new drivers do not work so great for my setup, so im sticking to the older drivers for now.

i7 920
sli 280
6gb ram
win 7 64bit.
1920x1200.

I might need to roll back. I didn't realize the older drivers had a SLI profile for Just Cause 2.

Rumtruffle
03-28-2010, 12:59 PM
that visual noise is film grain.

yes, its incredibly ugly and distracting. its there for everyone unless you switch it off.

do so by doing the following.

right click just cause 2 in steam.
select properties
select launch options

type into the text box :-

/filmgrain=0

win

NuKehl2
03-28-2010, 01:26 PM
In the demo, I noticed that darker scenes - in particular the opening cutscene - were almost pitch black save for a strange visual noise. In the final version, this problem seems to have gotten even worse, with the opening scene almost completely unplayable.

For example, this is a screenshot from the "dark tower" benchmark, taken via FRAPS (it's not just a black square, but you'll need to see it full size to pick anything out):
http://img153.imageshack.us/img153/3156/justcause22010032315281.th.jpg (http://img153.imageshack.us/i/justcause22010032315281.jpg/)

I tried disabling all graphical options, updating drivers, changing around NVidia driver options - eventually I found the cause: SLI. Disabling SLI drops the framerate considerably (as would be expected), but it immediately fixes the problem.

Has anyone else experienced this issue or, conversely, had good luck with SLI? I'm running dual GTX280s, and I can post a dxdiag if necessary, but first I just wanted to confirm that the game supported it at all.

With all the fancy GPU rendering and CUDA stuff this game does, it would be a damn shame to be limited to only one card.

I think something is wrong with your vid card i'm running duel 8600gts no prob with 60 fps

Dateranoth
03-28-2010, 01:44 PM
I thought I had tried all the settings off, but I turned soft particles off and have been able to play for over an hour without any problems.

DARKNIGHT
03-28-2010, 01:46 PM
I might need to roll back. I didn't realize the older drivers had a SLI profile for Just Cause 2.

They dont have that, but you can make a profile yourself, although ive run the game fine without a profile and just standard sli settings.

Dateranoth
03-30-2010, 06:15 PM
I thought I had tried all the settings off, but I turned soft particles off and have been able to play for over an hour without any problems.

Scratch that. Still having the problem. I'm going to disable SLI and see if that does anything. I also noticed that it happens almost exclusively while I'm in the air, particularly flying.