PDA

View Full Version : Horrible performance after ALT+Tabbing.


Larry1212
03-28-2010, 08:50 AM
I started a game last night on max settings(AA off) in a resolution of 1920x1080, everything ran smoothely, got a high enough FPS(Didn't actually check but it must've been above 60 atleast), I got to the first village and explorable area. Everything was fine but then I alt tabbed to my desktop.

When I tabbed back into the game it was very sluggish, unresponsive and I seemed to be getting around 10FPS. It was pretty much unplayable so I saved up, exited the game and went to sleep. I woke up this morning, turned on my computer, started The Witcher, loaded my save file only to see that the performance was still horrible and unplayable. At this point I turned all settings to low, filtering off, resumed my game. It had no effect, the game was still unplayable.

I then, painstakingly, made my way to a house, went in only to see that my FPS shot up to what it normally was. I exited the house to see that performance plummeted again.

Is this a known issue? Any work arounds? As is it's just unplayable in open areas.

Short Version: I alt tabbed, tabbed back in and have had terrible performance ever since even though i've restarted my computer and set all settings to low.

Edit:

My Specs:
Quad Core i5-750(2.67Ghz)
ASUS 1gig 5770 "CuCore"
4Gigs DDR3 1600Mhz RAM
Win7 Home Premium 64Bit.

Salith
04-29-2010, 11:57 AM
A LOT of games have problems when you alt-tab.
The trick is, don't.
If you are desperate to do other things, then run it in a window.

deadwulfe
05-03-2010, 08:22 AM
I agree with Salith. However, I have a theory with some games that if you ESC to a menu, alt-tabbing back into the game is less likely to result in problems. My hypothesis is that since there's a lot less going on with drawing the menu, then there's less to be messed with when leaving the game.

paragordius
06-20-2010, 10:07 AM
I'm bumping this thread because I'm having a similar problem with my game as well, although the problem persists even if I disable Steam Community. Whenever I load up a save I get about 5-10 fps until I talk to an NPC, then my fps bumps right up to around 60 and stays there until I decide to exit the game.

The only workaround I've found is saving near an NPC I can talk to if I plan to stop playing, as it's the only way I get playable framerates when I boot the game back up later. Any help would be appreciated.

I'm using the texture mods along with the FCR and scabbard mod if that makes a difference.