PDA

View Full Version : Oblivion won't start


Elfendahl
03-30-2010, 10:33 AM
I got the Oblivion GOTY Deluxe yesterday and it will open up to the menu with Play, Data Files, Options etc. When I click play nothing happens. I have tried verifying the cache, defraging both my hdd and the game, deleting the Oblivion file in My Games. I also tried going to the Oblivion.exe and OblivionLauncher.exe files and running with different compatibility settings. Anything else I should try?

jakeguy5678
04-12-2010, 05:32 PM
I think I have the same prolem too. Can anyone help?

Dethstar
04-15-2010, 05:40 AM
Did you mod the game?. Or has it had a steam update?

Changes to game files can sometimes do this. I only use a non steam or GFWL version as I heavily mod it. But if I remove a key mod or change a key file this happen then too. Fortunately timeslips Oblivion mod manager helps identify where the problem lies so I can fix it. I am not sure how the steam version works in this regard.

If you were using mod manager before hand you could probably still identify the problem but after the event it wont help you. Certainly would recommend it going forward. You can see the saves and if the game isnt loading properly very often this is why. It will also hi light other files issues and conflicts. A very useful diagnostic tool even if your not really into modding.But if your playing vanilla oblivion unmodded your really missing a whole universe of content which you could be getting free from the mod community. See www.tesnexus.com etc

jakeguy5678
04-15-2010, 03:05 PM
I dont have any mods

von_bunnell2
04-29-2010, 09:09 AM
I have the same problem with Oblivion GOTY Deluxe. I installed no mods. I just bought it a couple days ago and have tried everything listed on the forum and official Oblivion website forum...

It freezes right after I click Start New Game.

My computer was a top of the line gaming computer for 2009 so hardware isn't an issue (I even tried low med and high settings).

Thechuz
05-02-2010, 01:09 AM
I cant even get into the menu, i can get past the little menu, but then when the logo for bethesda shows up i get the good old ''This game has stopped responding''

von_bunnell2
05-02-2010, 02:30 PM
I have the same problem with Oblivion GOTY Deluxe. I installed no mods. I just bought it a couple days ago and have tried everything listed on the forum and official Oblivion website forum...

It freezes right after I click Start New Game.

My computer was a top of the line gaming computer for 2009 so hardware isn't an issue (I even tried low med and high settings).

I finally found what worked: I only had to set bmusicenable=0

cspirz
05-04-2010, 03:08 PM
The odd part of this is that until I got the latest steam update, Oblivion was working fine on my system. I wish I hadn't re-installed the game, because now it's not running, no matter what bmusicenable is set to. Steam has yet to answer my support email. Looks like it's back to disk media for me. What good is steam if you can't play the game you purchased?

FarisSedana
05-05-2010, 02:48 AM
How do i try the bmusicenable thing? :S my game isnt working either =( it startss up like afterr i press playy and it doess the silver bethesda signn then it just stops workingg and freezez/doesnt load :( help anyone? :(

Zikco
05-05-2010, 05:05 AM
Go to 'My Documents\My Games\Oblivion' Open the Oblivion.ini in there with Notepad, search for & find the string you want to change (ctrl-b), make the change, save & exit and you're done. :)

Baja43
05-08-2010, 11:55 PM
I tried setting bmusicenable=0 because it was set to 1, and it affected nothing. When I try and start my game, it loads up the Bethesda logo and quits after 2 seconds. It isn't that something failed to load because if I push escape before it finishes loading the logo, it starts actually loading the game. Anything else that someone can suggest?

And before you ask, this is the Oblivion: GOTY edition, I bought it through steam

von_bunnell2
05-10-2010, 04:07 PM
some people also have to set
bSoundEnabled=0

it is the one right below
bMusicEnabled=0

don't forget to save and then restart game... but I have heard that it doesn't work for all systems...

If you have an older video card you may need to try lower video settings.

Jajuka
06-10-2010, 05:38 PM
**POSSIBLE FIX**

I was having the exact same problem as everyone here. I was able to fix it by deleting everything in My Documents\My Games\Oblivion folder. Start the game after that and it will redetect everything again. I've at least been able to get to the character creation screen now. Hope it works in-game too.

Control
06-10-2010, 09:43 PM
I got mine to work...kinda.

I had the same problem everyone else had, after hitting play on the initial screen, everything goes blank and the game crashes.

On the start-up screen I went to Data Files then checked the "Oblivion.esm (Master File)" option.

From there I could get the game to load only in windowed mode. However, the sound would not work.

gimpymoo
06-11-2010, 01:22 AM
Same problem here.

meFreeman
06-11-2010, 10:02 AM
Wen you start the game launcher, try to click on PLAY, if you spend some time in options or data files the game wont start, if this hapens, try again, but dont go to those options. Anyway, the changes you make on data files or options will be saved, so don't worry to go back there.

Nickname P
06-11-2010, 10:11 AM
Same problem here, tried everything what you guys listed here. Nothing has worked.

Greggy_D
06-11-2010, 12:02 PM
Same problem here, tried everything what you guys listed here. Nothing has worked.

Ditto. Game will not start. Same symptoms and all suggested fixes in this thread do not work.

Here are the problem details:


Problem signature:
Problem Event Name: APPCRASH
Application Name: Oblivion.exe
Application Version: 1.2.0.416
Application Timestamp: 462392c7
Fault Module Name: Oblivion.exe
Fault Module Version: 1.2.0.416
Fault Module Timestamp: 462392c7
Exception Code: c0000005
Exception Offset: 0002b77f
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: 27c8
Additional Information 2: 27c8ce5af7a07bedf550bd9c573901b3
Additional Information 3: e56e
Additional Information 4: e56e9cfaf3cd1084b6b4c016d12ce64c

Nickname P
06-12-2010, 06:41 AM
So.. is Bethesda working on this one or did i waste my money?

AP Erebus
06-12-2010, 07:23 AM
I just had an issue where, after apparently downloading the game, it wouldn't load (open but then hang at a black screen before anything showed up).

I verified the game cache and now it's downloading another 2gb of data.

Hmmm... just hmmm.

zachyattacky
06-14-2010, 08:22 AM
I had this problem as well, and what worked for me was to go into

C:\Program Files (x86)\Steam\steamapps\common\oblivion

and launch oblivion through the 'OblivionLauncher' when I clicked this the play, options, data files etc, menu popped up. I clicked play, it popped up again, I clicked play once again and it's worked if I do this ever since. Hopefully this works for some of you

Peltar
06-14-2010, 09:52 AM
Same issue here, bought it this past friday. I load the game after the launcher and i get this issue. The same thing has happened to me on fallout 3 as well. I am not sure if this is a steam issue or what, but if i am not the only person having this issue then i would assume it isn't only me.

ProG87
06-14-2010, 04:14 PM
I've had the same problem. bought it on sale last week, after the initial install it crashed when I clicked play then I had to restart steam. When I did it automatically started downloading a new update, so after that I tried again and it loaded up some but crashed before the main menu screen, so I restarted steam and it started downloading another update which was much smaller. I assume the crashes are because its not fully patched yet, so you should all try updating some more if you can.

kferin
06-14-2010, 04:22 PM
**POSSIBLE FIX**

I was having the exact same problem as everyone here. I was able to fix it by deleting everything in My Documents\My Games\Oblivion folder. Start the game after that and it will redetect everything again. I've at least been able to get to the character creation screen now. Hope it works in-game too.

I LOVE YOU.
i wish i saw this before i wrote some seriously angry support mail to steam.

CombatantDuck
06-14-2010, 06:06 PM
Nothing listed in this thread has helped me yet..

BeardmanBeard
06-14-2010, 08:08 PM
Currently having the same issue as OP (click play on loader, game crashes) and still haven't found a fix. It was working fine not to long ago, I've had it for awhile, and it is no longer working. Pretty unrad.

SirGawaine
06-15-2010, 06:29 AM
Same thing happening to me. I tried all the fixes in this thread and tried Google. Still nothing. Is Steam going to fix this in the future?

Lunsmann
06-16-2010, 09:48 PM
I am also unable to play the game - I bought it the other day, and have tried every little thing I can find in this forum to no avail. The game launches into the main menu no problem, I can go through all the options menus no problem. I can even go into the new game menu but it locks up (ie stops responding) as soon as I click ok.
It also stops responding if I click on exit the game.

The only thing I haven't tried yet is to delete all local content and download it again (5 gig is 20% of my monthly data allowance). Has anyone else been able to get the game to work by going about it this way?

Lunsmann
06-17-2010, 07:43 PM
Oh well looks like I have wasted my money on this piece of ♥♥♥♥.

even a full re-download has not made one iota of difference. ♥♥♥♥!

jesepi
06-17-2010, 08:04 PM
This has been working fine till today, so I don't think it was something any of us did.

zachyattacky
06-18-2010, 07:59 AM
Alright, after my previous "fix" that only worked for me it stopped working again, and now I've been able to get it to start by clicking "play" at the menu, then the box goes away and nothing happens, if I eject my disk drive after the menu goes away the game immediately launches without fail... it's worked a few times now, maybe it will for some of you as well.

sytto
06-18-2010, 10:27 AM
Don't want to read three pages.

Have you installed the unofficial patch?

SkullTheTroll
06-18-2010, 06:05 PM
Mine worked fine two days ago when I last played it, but today it dies when I try to start it "Oblivion failed to start (error code 54)"

SkullTheTroll
06-18-2010, 06:11 PM
Okay, mine fixed by logging out of steam and logging back in. No more error code 54.

Lunsmann
06-19-2010, 06:43 AM
Don't want to read three pages.

Have you installed the unofficial patch?

I have not installed any patches - my game is as it installed via steam. Is there a patch I am supposed to install to make it work? :confused:

Dr. Cthulhu
06-19-2010, 08:54 PM
I cant even get into the menu, i can get past the little menu, but then when the logo for bethesda shows up i get the good old ''This game has stopped responding''

Same problem, it was working before, now it just does this. No mods.

workerbee10
06-20-2010, 10:01 AM
Okay, here's another potential solution I discovered after trying every single thing in this thread. It worked for me, so you might as well try it if you're still having difficulties.

Disable "Enable Steam Community In-Game" under Properties in the right-click context menu in Steam (as in, right-click Oblivion in the Library tab). That did it for me.

Lunsmann
06-22-2010, 06:52 AM
Nope, no luck for me.

TheRumster
06-22-2010, 12:53 PM
I had this problem as well, and what worked for me was to go into

C:\Program Files (x86)\Steam\steamapps\common\oblivion

and launch oblivion through the 'OblivionLauncher' when I clicked this the play, options, data files etc, menu popped up. I clicked play, it popped up again, I clicked play once again and it's worked if I do this ever since. Hopefully this works for some of you


REPPED! That worked for me as well. I moved my current save out of My Games, deleted all, started up, started a new game, saved, then put my current save of 20+ hrs in, and it loaded fine.

I AM NEVER MODDING THIS GAME AGAIN!!!! I have redownloaded it 2 times to clear out the /Data folder and restore it. I have had luck with DarNIfied, so I may install just that one. It f's up the game, I guess unless you really know what your doing - I must not. Well anyway THANKS

ayguesvives
06-24-2010, 02:44 AM
mine fixed by :
going into the date files menu and clicking on the "restore default"
this should only leave the oblivion esm box checked
after that you check each box one at a time and test the game
apologize for my english and my soccer team behaviour...:eek:

Lunsmann
06-26-2010, 11:56 PM
Mine fixed also - slightly different route. But at least I can now play the damn game.

1] Delete local content (steam version)
2] Go to store & buy DVD version
3] Install & Patch DVD version
4] bUse Joystick=0
5] bMusicEnabled=0
6] Launch Oblivion and start new game - voila it now works.

Sucks that I had to go this way, but I had tried everything else with the steam version and just could not get passed the "stops responding at start new game". Ah, well so in the end it cost me AU$35.00, still not a big outlay for so many hours of entertainment. :):rolleyes:

death95317
06-27-2010, 07:53 PM
i fixed it by turning off V-Sync

Edit:
I figured this out After clean reinstall and choosing options.
I hardly use v-sync. seems to cause me more problems than not

workerbee10
06-28-2010, 09:02 AM
Mine fixed also - slightly different route. But at least I can now play the damn game.

1] Delete local content (steam version)
2] Go to store & buy DVD version
3] Install & Patch DVD version
4] bUse Joystick=0
5] bMusicEnabled=0
6] Launch Oblivion and start new game - voila it now works.

Sucks that I had to go this way, but I had tried everything else with the steam version and just could not get passed the "stops responding at start new game". Ah, well so in the end it cost me AU$35.00, still not a big outlay for so many hours of entertainment. :):rolleyes:

Huh? There's absolutely no difference between the Steam version and DVD version, Steam is just a hub. What the heck was the point of doing that? You could have changed those options in the .ini file like everyone else who has the Steam version.

You wasted $35 AU, man. The fix you mentioned can be done in the Steam version, like other people in this thread have already mentioned.

Lunsmann
06-29-2010, 12:05 AM
Huh? There's absolutely no difference between the Steam version and DVD version, Steam is just a hub. What the heck was the point of doing that? You could have changed those options in the .ini file like everyone else who has the Steam version.

You wasted $35 AU, man. The fix you mentioned can be done in the Steam version, like other people in this thread have already mentioned.


:mad: didnt you read my previous posts in this thread. ????

I HAVE ALREADY TRIED ALL THESE TRICKS IN THE STEAM VERSION.

Jeez. I wasted AU$10 buying it on steam. NOT $35, simple maths.

I gave up on it & bought the dvd, at least now I also have something tangible in my hands, not just some 1's & 0's in a file. This is the first steam game I have had trouble with, and no official help from steam ?? do they monitor these forums at all? :confused:

Lunsmann
06-29-2010, 12:06 AM
i fixed it by turning off V-Sync

Edit:
I figured this out After clean reinstall and choosing options.
I hardly use v-sync. seems to cause me more problems than not


where did you find the v-sync option?

*[edit] - nevermind, I found it

Glyde62
06-29-2010, 07:18 AM
Okay, here's another potential solution I discovered after trying every single thing in this thread. It worked for me, so you might as well try it if you're still having difficulties.

Disable "Enable Steam Community In-Game" under Properties in the right-click context menu in Steam (as in, right-click Oblivion in the Library tab). That did it for me.

Thanks,That got mine working via the STEAM Gui, Use to have to go into the folder and start it via there

wookieepelt
07-05-2010, 11:46 PM
**POSSIBLE FIX**

I was having the exact same problem as everyone here. I was able to fix it by deleting everything in My Documents\My Games\Oblivion folder. Start the game after that and it will redetect everything again. I've at least been able to get to the character creation screen now. Hope it works in-game too.

This worked for me. Thank you very much.

miprocin
07-10-2010, 06:22 PM
I can't get this game to work at all.

I tried all the tricks in this thread and none work.

If I delete all the ini files, when it tries to detect video settings it says my hardware was not recognized. All my drivers are up-to-date.

The best I've gotten it to do so far is get to the part where it displays all the legal / copyright info and fades to black. The game just hangs there with the text barely visible.

Sys Specs:
i7 920
6GB RAM
nVidia 8600 GTS
Windows 7 x64 Ultimate

I assume there's no refunds...

Bondey6678
12-24-2010, 03:11 PM
**POSSIBLE FIX**

I was having the exact same problem as everyone here. I was able to fix it by deleting everything in My Documents\My Games\Oblivion folder. Start the game after that and it will redetect everything again. I've at least been able to get to the character creation screen now. Hope it works in-game too.


WORKED AN ABSOLUTE TREAT!

YOU GENIUS! I absolutely love you right now

mindstream
12-30-2010, 11:21 AM
Dunno if this will do anything for all of your issues, but I find when I have trouble with games not working, doing this helps:

Right click on the game in library>properties>local files tab>verify integrity of game cache

Hope it helps, GL.

SakkBoi
12-30-2010, 01:55 PM
I cant even get into the menu, i can get past the little menu, but then when the logo for bethesda shows up i get the good old ''This game has stopped responding''

I just bought oblivion GOTY deluxe edition (was waiting for oblivion to finally go on sale) and this same thing happened to me. Whenever I tried to start the game I would get the launcher window and could manipulate options/settings, but whenever I hit the play button the game would crash just as the bethesda logo was about to show. I went through this whole thread and none of the suggestions helped me. Then I did some googling and found an outside forum thread that gave me the solution that worked for me. The problem was due to Oblivion sometimes having problems with secondary monitors. I had to go into my nvidia control panel and disable the second monitor. After that Oblivion starts up every time without problems. I hope this helps somebody else too.

Solid_Static
12-30-2010, 03:08 PM
Same thing here. Nothing seems to works.

1337warrior
12-30-2010, 05:26 PM
Alright, after trying everything I got working with default+no fullscreen option.

Edit

How to get the game working.

1: Make no changes
2: Launch the game without vsync and no fullscreen.
3: wait until game loads.
4: Close game and start again with fullscreen Enable at options.

Amblin
12-31-2010, 02:08 PM
just picked this up on sale and stuck at the directx install, it's hanging as far as I can see, my dx is bang up to date.

If I cancel it then I can't get past clicking play. My video cards are not recognized but show up in the menu as 8800gts 512's (which they are, sli'd). drivers are the latest too.

Fecked off with this, but will keep trying./

ValkyrieSS
12-31-2010, 02:25 PM
Originally Posted by workerbee10 View Post
Okay, here's another potential solution I discovered after trying every single thing in this thread. It worked for me, so you might as well try it if you're still having difficulties.

Disable "Enable Steam Community In-Game" under Properties in the right-click context menu in Steam (as in, right-click Oblivion in the Library tab). That did it for me.


worked for me !!!

Akano
01-01-2011, 05:41 PM
aaaargh, i'm going crazy, nothing mentioned in here works for me =( i got windows 7 ultimate 64-bit... if you need anything else on info, i'll be glad to give it.. i just wanna play T.T

3doubled
01-03-2011, 03:11 PM
I have tried every fix on this forum and others I found on Google. I cannot get past a few seconds in the game (if I'm lucky). If the incorrect resolution has been set in fullscreen mode then I cannot even get into the game, it just crashes immediately. When I do get into the game it stutters for a few seconds... then becomes smooth and playable (luring you into a false sense of accomplishment)... then crashes seconds later.

i7 920
6 GB RAM
ATI 4890
Win 7 Ultimate 64-bit

I have:
1) Re-downloaded the game (no mods)
2) Verified the integrity
3) Updated my AMD drivers
4) Disabled the Steam Community In-Game menu
5) Tried deleting the files in ...\My Games\Oblivion to force a re-detect
6) Tried disabling sound (not like that's a fix anyway)***
7) Run with and without my secondary monitor
8) Rebooted several times for kicks and giggles
9) Prayed to the gods of oblivion to give me a f***ing break!

Looking at the forum posts of those who have listed their PC specs, I see a trend that this problem is occurring on Win 7 64-bit machines.

***Edit: Looking at the Bethesda support forums I've found that Windows 7 is not supported for Oblivion. However, by setting in the oblivion.ini file in \My Games\Oblivion:

bMusicEnabled=0
bSoundEnabled=1

You may avoid the sound error that is likely causing most crashes. I can report that this works in my case. This fix is contrary to what many have been posting, where we were instructed to set both values to 0. Setting both to 0 did not stop the game from crashing in my case.

WikingDK
01-04-2011, 11:37 AM
**POSSIBLE FIX**

I was having the exact same problem as everyone here. I was able to fix it by deleting everything in My Documents\My Games\Oblivion folder. Start the game after that and it will redetect everything again. I've at least been able to get to the character creation screen now. Hope it works in-game too.

Works for me :) thanks a lot

Johnny_Warmongr
01-04-2011, 06:32 PM
Same problem here....running Oblivion GOTY Deluxe Edition. After deleting the .ini file in my documents and double clicking the game in the game library I get the message that Oblivion will detect my video settings. After that I get the message: Your video hardware is unrecognized. video quality settings defaulting to medium quality. After I close the box for that message the game crashes. When I try to start the game after that (without deleting the .ini file) the game immediately crashes without trying to detect my video settings. Here's the error log:
Problem Event Name: APPCRASH
Application Name: OblivionLauncher.exe
Application Version: 1.0.0.1
Application Timestamp: 443532f8
Fault Module Name: OblivionLauncher.exe
Fault Module Version: 1.0.0.1
Fault Module Timestamp: 443532f8
Exception Code: c0000005
Exception Offset: 0000c2ed
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: 51dd
Additional Information 2: 51dd5632ec49c0b0482fa3180364c4ed
Additional Information 3: f73e
Additional Information 4: f73e7dbc74bc4c08ca9962c351ed364d


Ive tried all of the possible fixes that have been posted so far. All drivers have been updated and I don't have multiple displays. Thanks in advance

Win 7 Ultimate 64-bit
i7 920 Processor
6gb Ram
Ati Radeon HD4850
Onboard Sound Realtek HD 7.1
Sound blaster Audigy 2 Zs soundcard (for surround sound headphones)

RavenBladeDV
01-05-2011, 12:38 PM
I'm not sure which of the above options I used to get this game working, because I tried many before discovering another issue. If you're running in full screen, you can't have more than one monitor running (Win7 x64) or the game will crash at launch. Go into the display properties and set only one monitor to be the display. Then the game should launch in full screen.

Hope it helps.

Johnny_Warmongr
01-08-2011, 07:36 AM
*bump*
Nothing that has been posted so far has worked for me and I'm still waiting for a reply from Steam support on this issue.

Johnny_Warmongr
01-08-2011, 02:29 PM
Well, I finally got Oblivion to work. After searching the internet for days, uninstalling Oblivion and uninstalling/reinstalling sound/video drivers, I finally found a link that talked about issues with installed codecs. So I started thinking and remembered installing a codec pack for wmp a few months ago. I couldn't figure out how to disable or remove the codecs since I didn't remember exactly which codec pack I had installed so I dl'd the K-lite mega pack x64... mainly for the tweak tool. Anyhow, I installed the codec pack, opened the tweak tool to see what I could do(didn't have to tweak anything though)then tried running the game and viola!! It didn't crash... created a character went through the intro sequence and started playing.

Hopefully this can help anyone who has had a similar issue.

willgreg123
05-15-2011, 01:25 PM
I used OLDBLIVION and it WORKED!
I highly reccomend trying it to fix this problem.

Phr4g
05-16-2011, 09:16 PM
I can't get this game to work at all.

I tried all the tricks in this thread and none work.

If I delete all the ini files, when it tries to detect video settings it says my hardware was not recognized. All my drivers are up-to-date.

The best I've gotten it to do so far is get to the part where it displays all the legal / copyright info and fades to black. The game just hangs there with the text barely visible.

Mate, you described EXACTLY my problem. If i press ESC button before that, it locks up as well. Pretty dissapointed =(

I got a nVidia GTS 250 4gB ram quad core AMD Phenom II 2,8Ghz CPU.

Mithander
05-18-2011, 05:16 PM
I was running into the same issue. I would get the initial start-up screen, then a program has crashed error message. I found that for me it had to do with what codecs (DirectShow) I had installed. I installed a program called InstalledCodec (http://www.nirsoft.net/utils/installed_codec.html) and used it to disable all of my codecs, then enabled only the Microsoft ones. That fixed my issue and everything worked fine.

I kept enabling codecs until it wouldn't start again, and found it was some codecs from Bandisoft that were causing the issue. I don't remember ever installing them, probably came with some other game sometime in the past. Hope this helps someone.

EbonFreeman
08-06-2011, 05:54 PM
1a.
Leave steam then come back

1b.
Ensure you have the latest version of directx
Check that your computer meets min. requirements.
Update your video drivers
Make sure your card is supported
If you have an nvidia card, to have only one monitor enabled in the control panel->NVIDIA Control Panel
Restart your computer.
Restarting your computer can fix a bunch of stuff.
Note:Rarely a person might have to check their page file

1c.
If your game doesn't work because of minimum settings
http://thecrosstalk.blogspot.com/2007/08/running-oblivion-with-less-than-par.html
I haven't tried it with the steam version yet on my laptop

2.
Disable the sound or music in the oblivion ini file located at
...\Documents\My Games\Oblivion\Oblivion.ini
bmusicenable=0
bSoundEnabled=0

3.
Disable "Enable Steam Community In-Game" under Properties in the right-click context menu in Steam (as in, right-click Oblivion in the Library tab).

4a.
Delete .ini settings then redetect settings

4b.
Restore to your settings to default

4c.
Place settings to the lowest

5.
Make sure all boxes clicked on Oblivion Data Files. I didn't have this problem, but someone said it worked for them.
Note: On mine all except Oblivion.esm is checked

6.
Launch the game without vsync and windowed
wait until game loads.
Close game and start again with fullscreen Enable at options.

7.
Make sure your gcf(Game Cache File) matches
Within steam right click in library on oblivion -> Properties
Under the Local Files <tab> -> Click on "Verify integrity of game cache"
This fixed mine, the download stopped at ~65% and said "it was done at 100%". After I ran a checksum match I had more to download.

8.
Long boring and self explanatory.
Uninstall, download, reinstall

9.
I do not recommend this last method
Patch your game to no end. There are a lot of hacks you can use to "force" the game to work, nor am I going to tell you how to do it.
Hacking the steam version takes forever. Make sure your gcf match before starting.
This may violate the terms of using steam and you may lose your game/account.

EbonFreeman
08-06-2011, 06:18 PM
BTW, mine also got stuck at the legal screen. The first time I ran it, only the Bethesda logo, then I hit escape then it black screens. I checked task manager and it says it isn't responding. So, I got a checksum compared it and reran the gcf and it worked. Although, after I got it to work it behaved oddly. My character was running slowly. It was rendering fast, my character's "dexterity" was a normal animation speed, and when other characters walked it went at normal speed, but I couldn't run as fast as other characters walking. I restarted steam and everything is cool now.

Morsalis
08-07-2011, 05:16 AM
I borrowed my friends retail version of Oblivion, installed it and it runs just fine. So again i was f*cked by steam ...

Leonick
08-07-2011, 07:56 AM
Alright, after trying everything I got working with default+no fullscreen option.

Edit

How to get the game working.

1: Make no changes
2: Launch the game without vsync and no fullscreen.
3: wait until game loads.
4: Close game and start again with fullscreen Enable at options.

This worked for me, well kinda, if I set it to fullscreen again it starts crashing again, so windowed mode for me.

I'm not sure which of the above options I used to get this game working, because I tried many before discovering another issue. If you're running in full screen, you can't have more than one monitor running (Win7 x64) or the game will crash at launch. Go into the display properties and set only one monitor to be the display. Then the game should launch in full screen.

Hope it helps.

And that explains why I have to use windowed mode, sigh how I hate games that have problems with multiple monitors.

parvatiquinta
08-07-2011, 12:36 PM
2.
Disable the sound or music in the oblivion ini file located at
...\Documents\My Games\Oblivion\Oblivion.ini
bmusicenable=0
bSoundEnabled=0

This is what worked for me, with the exception that the game will also work while enabling the sound, thankfully.

I have then tried to install different sound codecs hoping to fix the music, with no luck.

System specs:
OS: MS Windows 7 Home Premium 64-bit SP1
CPU: Intel Core i7 930 @ 2.80GHz
RAM: 8.00 GB Triple-Channel DDR3 @ 534MHz (8-8-8-20)
GPU: ATI Radeon HD 5850
Audio: SB X-Fi Go!

I've tried installing the K-lite Full Codec pack (32 bit) as well as the 64-bit pack, and the Fraunhofer MPEG Layer-3 Decoder, they didn't help in my case but maybe somebody else could find them useful.

(for the record, I bought the pack with Morrowind as well, and I'm experiencing the same crash before main menu issue with Morrowind, except in the latter case I was not able to at least start the game by disabling the audio in the .ini file. Yay.).

Anyone got some more bright ideas to fix the mp3 playing?

EbonFreeman
08-07-2011, 04:03 PM
Yeah, in another game the FFF codec messed with my other computer. Which is usually why you disable the sound, but you could disable the codec in task manager or you might actually have to temporarily uninstall it. This issue really depends on certain systems. I've ran it on my computer using 3 different movies playing, guild wars, super street fighter 4, and it still works. So, I'm not exactly sure how to get that error.

parvatiquinta, do you use onboard audio or seperate card? And have you tried disabling the other device?

parvatiquinta
08-08-2011, 02:20 AM
parvatiquinta, do you use onboard audio or seperate card? And have you tried disabling the other device?

My audio card is not only separate but also external.
I made the mistake of going for onboard audio on purchase, and the Realtek thing worked for all of 20 minutes and then was messed up beyond my capability of fixing it up by Windows Update.
The onboard card is disabled via BIOS and I use the external Creative SB X-Fi Go! as listed in the previous post.

Software wise, I have iTunes and MediaMonkey installed and I am using MediaMonkey to play mp3s. Before installing new codecs I tried resetting Windows Media Player as the default player for mp3 and other media, but this did not help.
On the other hand, bf has got MediaMonkey too on his PC, running Windows 7 64-bit like mine, and his Oblivion works just fine.

parvatiquinta
08-08-2011, 07:49 AM
All right, I dug deeper into the Internet, tampered with my codecs, and it seems to be fixed now.

I explained what I did step by step in this post (http://forums.steampowered.com/forums/showpost.php?p=24209364&postcount=8) and Oblivion now runs with the music too.

noxwyll
08-10-2011, 02:18 AM
Nothing works for me. I press play in the launcher but nothing happens. Mouse displays loading for 5 sec. Then nothing.

galatei
08-10-2011, 06:27 AM
**POSSIBLE FIX**

I was having the exact same problem as everyone here. I was able to fix it by deleting everything in My Documents\My Games\Oblivion folder. Start the game after that and it will redetect everything again. I've at least been able to get to the character creation screen now. Hope it works in-game too.

That FIXED it for me. Thanks a lot.