PDA

View Full Version : CTD after Tyrago


Bigskippy498
04-04-2010, 04:54 AM
Hello all.

Been experiencing a crash to desktop at the end of the Marine USCM Tyrago mission. I get no warnings and no error messages. It happens when I reach the doorway after the lift at the very end of the mission and I get the mission completed stats screen. When I press a key to continue I get the CTD.
Up until this point it was running absolutely fine.
The game is currently fully updated.

My rig is:
Windows 7 Home Premium
Intel Core i7 960 @ 3.20 GHz
6GB RAM
ATI Radeon 5800 Series Crossfirex - driver version 8.660.0.0

I'm at a complete loss as to how to fix it. Any help you could give me would be greatly appreciated since I was loving this game before it died on me.

Thanks in advance.

sirlemonhead
04-04-2010, 03:04 PM
It's a bug in their code. I think someone has a workaround? Hopefully they'll chime in and tell you what to do..

Rochallor
04-04-2010, 09:33 PM
I seem to be having the same error. I had no problem on training, but it crashes on realistic. I obviously don't know if the problem is still there on DC.

Bigskippy498
04-05-2010, 04:01 AM
Thanks for the responses.
I've been getting the problem on Director's Cut, Realistic and Training. Kind of makes it difficult to advance :D

If anyone has this work around I'd be very much appreciative of the heads up.

Rochallor
04-06-2010, 04:48 PM
Found it. My search didn't find anything originally because it was spelled Tyrargo.

http://forums.steampowered.com/forums/showthread.php?t=1111295&page=2&highlight=tyrargo

The simplest way seems to be hit ESC when then score screen comes up to restart the level, and then just select the next level. It still records the level as passed.

Bigskippy498
04-07-2010, 03:58 PM
Thanks for your help. It worked a charm.
Big cudos to you sir :D

bish777
11-30-2011, 01:16 PM
could anyone repost this fix, the link is now dead.

forceNet
12-04-2011, 06:49 PM
could anyone repost this fix, the link is now dead.
once you finish the level and see the summary screen, press ESC to restart it instead of returning to main menu. then just abort the restarted level right away, the game has recorded your progress by now.

also, kudos for using search feature.

Lagatzuo
02-25-2012, 04:19 PM
I just had this same exact problem, and thanks to the search, I found this answer. Thanks for the help - it's too bad this bug is still in the game, but I'm glad you folks have found a painless workaround.

Why these bugs even exist is beyond me. So weird and random!

Mad Max RW
02-25-2012, 05:10 PM
It has to do with Rebellion using bits of code from the fan-made AvP Gold source port by sirlemonhead. The problem is it wasn't designed for Vista, Windows 7, or any 64 bit OS. One or two guys at Rebellion did it as a rush job.
My primary computer is running Windows XP Pro 32 bit and I never had AvP Classic (or the unofficial AvP Gold update) crash at the end of a map. I actually have to try to make the game crash by deliberately breaking things such as critical data files. The original game was designed for Windows 98. The fact it works as well is it does on modern operating systems is a miracle.

sirlemonhead
03-05-2012, 01:55 PM
My codebase definitely did crash at the end of Tyrago. I remember fixing it after classic 2000 was released. It was a sound related bug I believe.

There were some truly horrible bugs in the source code. I remember spending about a week tracking down a particularly nasty crash related to the predator weapon handling code.

Elensar
03-05-2012, 03:37 PM
Rebellion did a good job getting this dinosaur working as well as it does for Win 7 etc, but yes sadly some glitches etc made it through so we have to suffer them.

BUT it is good people get to enjoy this classic game, for me its where it all started bought my first decent graphics card just for this game (A voodoo 3 16MB card lol) so for me this game is special as sad as that sounds.

Glad the work around works well done for finding a way around this issue :)