PDA

View Full Version : Unreachable Ember


AlanS
04-10-2010, 04:43 AM
Not a game-breaking problem here, but it is still mildly annoying. Basically I've got the quest to retrieve the Adamant Ember, but can't reach it because it's stuck behind a table (see http://img710.imageshack.us/img710/8564/stuck.jpg ).

I've tried sending my pet to collect it, going to other floors of the dungeon and then returning, wandering off to do the portal quests, and even the 'ascend' console command used for getting the character unstuck, all in the hope that the dungeon would be 'regenerated' with the ember actually on the table. Still no joy collecting this item, and while I can still carry on with the game, it means I can't complete the ember quests.

Anyone got any ideas how to resolve this?

Cheers

tacc
04-10-2010, 07:19 AM
You could try to cancel the quest. You'll get a new one which might place it somewhere else.

AlanS
04-10-2010, 08:00 AM
Gave that a try, but no joy. Even after cancelling the quest, the ember was still there when I returned to the dungeon. Accepting the quest again didn't change anything unfortunately.

BionicAir
04-10-2010, 03:01 PM
did you try moving the table? lol..i know, i know...only options you'd have is what was already suggested..prob gotta just abandon the quest,and move on,and get the next one..i dunno :/

AlanS
04-10-2010, 06:04 PM
Moving it??? I've tried attacking it :) Unfortunately the table appears to be both sword and fireball proof.

Obviously I can still carry on with the game, but it's annoying just having to leave this item (and all the following ember quests) behind...

Maledict21
04-10-2010, 06:27 PM
I had an issue similar to this. The ember was stuck in the same spot as that goblin trader you see in the dungeons sometimes. It took me nearly 30 minutes to get myself into a position to pick it up.

jc3zx
04-11-2010, 12:13 AM
Send photo plus letter of complaint and request noclip mode instead of refund. You will probably get neither but just another glitch to add to the list.

PirateH
04-11-2010, 11:22 AM
Maybe you can make it appear using the console. That will flag you as a cheater, but I'm pretty sure there's a mod that can remove this flag.
You will need the item ID, just check in the armory:
http://torchlightarmory.com/item?i=218

AlanS
04-11-2010, 04:07 PM
I think this particular map just doesn't like me. I've cancelled the quest and have spent ages wandering around other dungeons, which all regenerate pretty much as soon as I leave them (I'd die, respawn in town, then the dungeon would be full when I went back).

Unfortunately the only map where this doesn't happen is the one with the adamant ember in it :-)

May have to resort to cheating... I'll have to find that mod that removes the cheater flag first though :-/

Thanks for all the suggestions though.

Sweeney47
04-12-2010, 07:51 AM
have you tried shift clicking it (think thats the command)to tell your pet to collect it, maybe he's small enough to move under the table :D

doubt it will work but its worth a shot

KamiShizuka
04-12-2010, 08:12 AM
Is this for the main dungeon or Shadow Vault?
In either case, once a level is generated, it sticks. There might be a way to remove the level from your save file, but I really doubt it.

AlanS
04-12-2010, 11:04 AM
Sending my pet to collect it was the first thing I tried after finding I couldn't collect it myself. He couldn't collect it either, so it's off to the taxidermist for him!

The ember is in the main dungeon, and by the dungeon regenerating what I really meant was the monsters respawning (and hopefully the ember too). Unfortunately it looks like I have to either leave it and abandon the entire ember quest, or look for the relevant console command and resort to cheating :-(

teak
04-12-2010, 11:34 AM
did you try to go one dungeon-level deeper?
perhaps it's filled with monsters if you come back.

i remember, i got hard attacked as i entered a deeper level.
so, i escaped to one dungeon-level higher (which i cleared before).
i was surprised that the dungeon was filled again.
but i can't remember, was it in the main-dungeon or in a map-scroll-dungeon.

AlanS
04-12-2010, 12:06 PM
Yeah, I've tried going deeper, still with no joy.

The dungeon in question is floor 28 of the main dungeon, just before the Lost Fortress (floor 29) where you fight Medea. I've tried using a mod that reduces respawn times, and floor 28 is still as I left it. If I leave floor 30 returning to 29 then instantly go back to floor 30 all the monsters have respawned and the automap is blank. This happens on every floor (due to the mod obviously) with the exception of floor 28. I'm guessing the fact that I haven't collected the ember yet is preventing this from happening(?)

BionicAir
04-13-2010, 03:52 PM
you should report that table to the dev's,for being a big stupid jerk :-p its a shame u cant just skip the quest,like u can for the kill ones from that robot..like if u abandon,and go 1 lvl deeper,you'll get the next quest

mLegion
04-14-2010, 12:25 AM
have you tried using the editor to place an adamant ember in town, then do the quest and remove the 'mod'?

Oaktree99
10-07-2010, 02:48 AM
I have the same issue, only mine is stuck under the goblin trader, and he will not move..

AlanS
10-07-2010, 09:52 AM
At least I'm not the only one with this issue I guess... I never did try using the editor (too much hassle to be honest just to complete a simple quest that should just be one mouse-click away), but thanks for the suggestion.

Shame really, as I stopped playing the game after this problem...