PDA

View Full Version : Ubisoft Updater keeps crashing, cant launch Assassins creed 2


twitchel
04-14-2010, 04:18 PM
Hi All,

Running Assassins Creed 2 on my PC, for some reason Ubisoft Updater keeps trying to update and crashes... now i cant launch the game!

I dont really want to have to delete my local game files and redownload them (im on a terrible ADSL1 connection... I hate Australian ISPs...)

Does anyone know if there is a way to fix this? Could i just find the ubisoft application, delete it, and would it be reinstalled by the game when i try and launch?

(This is why i HATE ubisofts DRM.... it just encourages legitmate buyers to pirate... im sure the pirates out there wouldnt have this issue...)

MomentDEFINED
04-14-2010, 08:44 PM
Delete the files you think are causing you a problem and try to verify the game cache. It should redownload any files that it does not find, or are incorrect.

And try not to start the fires so blatantly.

twitchel
04-14-2010, 08:47 PM
Wasnt trying to start any fires... i was just displaying my resentment for Ubisoft's game authentication methods...

Ill try that out and see how it goes.

Dan

jackcondon
04-15-2010, 01:21 AM
Im having the same problem and have tryed all that. iv been talking to ubi for ahwhile now with no success.

if you find a fix tell me.

twitchel
04-15-2010, 01:54 AM
reinstalling the ubisoft launcher didnt fix it.... :(

what to do! i paid USD$60 for this and now i cant use it! :(

it was just starting to get interesting too... :(

jackcondon
04-15-2010, 02:36 AM
You can do nothing. sucks huh.

ubi after them telling me to reinstall, then sending logs, now this:

"hello,

In order to fully troubleshoot the problem that you are having please try the steps below:

1. Disabling your background applications:

To do this, go to the Start menu on your desktop (or, if using Windows Vista press the Windows key and the letter R at the same time)
Type in MSCONFIG and press Enter.
Go to the tab which says Start Up.
Click the option to Disable All.
Press Apply, then Close then pick the option to Restart.

2. Clearing your temporary files:

To do this, go to the Start menu on your desktop (or, if using Windows Vista press the Windows key and the letter R at the same time)
Type in %TEMP% and press enter.
Go to Edit and Select All.
Go to File and Delete.

Once these steps have been applied, test the game again.

Regards,
Ubisoft Technical Support.

"


Needless to sat, it didnt solve anything. Maybe it will help for you. Ill keep you posted as we have the same error and the support process is usless but you may wanna give it a go.

twitchel
04-15-2010, 04:23 AM
sounds like their support team is following their typical script...

"have you tried turning it off and on again.."

ill giv eit a whirl but ofcourse it will fix nothing


EDIT: yeap... still buggered... thanks for sharing that anyhow mate...

Furious Dre
04-15-2010, 04:35 AM
Do what that guy said and verify your files and try to play the game, if it doesn't work...

Make a backup of AC2 (In Steam , right click on AC2 and click backup game files).

After it's backed up deleted AC2 from your computer.

Go to the Steam Backups folder (Something like C:/Program Files(x86)/Steam/Backups/" and re-install AC2

Lyciax
06-30-2010, 11:23 AM
I did it, but it didn't change anything. I still have the message : Failed to start launcher. Please reinstall.

Help please, I tried a lot of things but nothing works !