PDA

View Full Version : Vsync issues?


Princeps32
04-15-2010, 12:09 PM
This game seems like a great time waster.

Unfortunately, there is one large problem for me. Whenever the light show really gets going, the graphics start flickering a lot, similar to other games I've owned when vsync is turned off, and there doesn't seem to be any graphics adjustment options whatsoever. I have a geforce 9800 and a dual core 2.6 processor, with 6 gigs of RAM.

Is anyone else having this problem, and is there some obvious way to fix it I haven't found? Thanks!

eetcheez
04-15-2010, 12:35 PM
Try forcing it in the Nvidia control panel.

An even better option is to download Rivatuner and use D3DOverrider which will force both V-Sync and Triple Buffering.

Princeps32
04-15-2010, 02:41 PM
Rivatuner worked great, turning Vsync to always on fixed the problem. Thanks for the help!

Now if I could only get the game to not crash all the time :/

Starg
04-15-2010, 02:49 PM
Rivatuner worked great, turning Vsync to always on fixed the problem. Thanks for the help!

Now if I could only get the game to not crash all the time :/

Hi there, I'm the dev. I'm here to help with crashes.
Is it a certain track, or is the game crashing in some other way?
Cheers,
Steve

Princeps32
04-15-2010, 02:59 PM
Hi Starg,


I appreciate the personal time you are taking. I can't tell you exactly what makes certain songs crash. I learned that if I had mp3 files in a folder containing movies, the program could get confused and crash. Some files however I couldnt' tell you the difference. I picked a random song, "Wheels" by Foo Fighters (not a great song, but it gets stuck in my head), and it would crash to desktop. Another would be fine. I can't really tell you what the difference is, they're all mp3s.

Sorry I hope this helps, I don't really have much technical knowledge.

Humo
04-16-2010, 10:36 AM
Having the exact same problem. In case you are working on a fix here's some more info:

-4870 X2 graphics card
-Tried disabling catalyst AI, didnt help.
-The solution that worked for otehr people as in forcing Vsync also was unsuccessful.

Now here comes the weird bit. As you may or may not know, ati tray tools has an FPS counter. I enabled it just for the hell of it and noticed something strange. With forced Vsync I get 60-61FPS which is in line with teh frequency of my monitor. After playing for a few minutes my screen goes black for a split second (like for some other people) and then the screen tearing starts. The FPS meter shoots up to 400+ and stays there til I restart the game. Yes four hundred, not a typo. Hope it helps towards finding the cause of the problem.

freibooter
04-17-2010, 02:16 AM
I got the same issue after about 20 minutes of consecutive gameplay. It just happened randomly and the game become unplayable due to massive screen-tearing.

Nvidia GTS 250, Windows 7 32bit, GeForce 197.45