PDA

View Full Version : DLC Problems


SandvichSpy
04-17-2010, 03:03 PM
Yes. Another thread about this.

I bought the Dragon Age:origins via steam and validated everything correctly. My account is lsited as having those contents registered, it downloaded it but it won't install it. I've read dozens of forums from bioware an here tryign to fix the problem, here's everything i've tried:

Defragmenting, verifying game cache, running everything as administrator, reinstalling the DLC, attempt to install the DLC manually (the .dazip files where NOT FOUND, untill I installed them manually. and when Itried to install them manually they would give an error.) moving the daupdater.xml to the bin file, tried it while logged in, tried it while logged out, Settings are to U.S and keyboard to U.S, asked Morrigan for help (she was busy rescuing kittens from trees), tried deleting the local data (it refreshed itself)tried defragmenting and verifying again and I also went to the services.msc command, and ran the DA updater thing as automatic, stopped it, and started it.

Nothing has worked!

Zimbu
04-17-2010, 05:56 PM
Try downloading the DA Update Service Diagnostic (Beta) (http://supportfiles.bioware.com/dragonage/DAUServiceDiagnostic_beta.exe), which will verify the versions of various files, and ensure that the DA Updater service is installed correctly on your system.

If that doesn't help, there are two very useful threads on the BioWare forums that cover most of the common causes of DLC issues:

Redeemed DLC Troubleshooting and FAQ (http://social.bioware.com/forum/1/topic/58/index/81613)
Dragon Age DLC In-Game Errors FAQ (http://social.bioware.com/forum/1/topic/58/index/759141)

Also, make sure that you're logging in to the same account inside the game that you used to register the DLC on BioWare's site.

There have also been some indications that things might not work properly if you have your "My Documents" folder mapped to a network drive.

SandvichSpy
04-17-2010, 09:11 PM
I tried even more now, Iforced a reinstall of the DLC, deleted DAUpdater fodler and now all that happens is that when I run the cmd thing a start DAUpdatersvc it says the file cannot be found. I do not know how I could change or help fix that "My documents" network'd thing nor do I know how to check if its network'd...its still not working at all

I have the logs that speak of the failed manual installs. I do not really know what they say tho so I dont know whats going wrong

bassmaster
04-18-2010, 05:25 AM
Go to the system manager (control+alt+delete), then go to the services tab, click on the button "services", then look for Dragonage origins or daoupdate something like that click with the right button and put to begin and automatically.
I was having problems with the dlc that wasnt appearing, then it wasnt downloading and that worked for me.

SandvichSpy
04-19-2010, 03:02 PM
But mine Is showing and furthermore, that process you described appears as "Running". I took a picture of what I see when I try to install it.

http://yfrog.com/1865750967p

The "Extracting" part first says "Downloaded" then "Extracting" and finally "Installation failed" you see its not the download because apparently it is detected and visible, what isnt working is the installation itself...

I already did all of the steps pointed out by the guide I had seen before that Zimbu was kind enough to link. I forced a reinstall of the daupdater service and all and nothing works.

SandvichSpy
04-23-2010, 11:48 PM
I was wondering if someone could help me?

of all the troubleshoot things ive attempted to do and all failed to fix it, i've not tried 3.1.1 according to the aforementioned guide (http://social.bioware.com/forum/1/topic/58/index/81613)

Im trying to understand what 3.1.1 means to do, actually, i dont quite get it. There's 3 different files with dragon age stuff in my computer, one weighs 1 giga, the other 15 gigas, the other 300 megas, and the heaviest one is in Steam folder. what do I have to move and where?

I attempted to copy the Documents (Libraries/Documents/Bioware/DragonAge) folders into the Steam/steamapps/common/dragon age origins andm ade sure to not replace anything and to back up in case it was needed and in case it screwed the game compeltely.

it didn't.

But im pretty certain that I didnt apply this 'fix' correctly...any help?

Porkdish
04-24-2010, 12:45 AM
3.1.1 refers to users with unusual installs of the windows operating system. Dragon Age likes its stuff saved in the right place but custom windows installs with the 'My Documents' folder renamed or in a non standard location can effect the way Dragon Age runs (or rather, doesn't run). The tip refers to making a My Documents where its supposed to be in a default install of windows and putting the relevant Dragon Age stuff in there so the main program can find it.

Failure to install DLC could suggests you either haven't quite got the whole file (dazip)? or you don't have the permissions to install their data where they want to go on your system.

To facilitate easy reinstallation I downloaded the dazip files from that very thread, the ones I'm entitled to as determined by my DA version (steam-regular) and those I've purchased via bioware points. If you decide to download, make sure you get the right version for your install type and that it downloads completely.

Below is my official DLC list and their file sizes. I've reinstalled from these and authenticated just fine. Once you install them via the daupdater.exe included with the steam install, you still have to at least once, log in (via dragon age) and authenticate them with your bioware social profile. From then on, if you don't connect to internet they'll work, but if you do play Dragon Age with an active internet connection, then you must log into your social account every time and 'shake hands' again with the EA servers.


DAO_PRC_CP_2 - Stone Prisoner (non offer, works with steam) - 309187 KB
DAO_PRC_PROMO_1 - Memory Band (works with steam) - 57 KB
DAO_PRC_PROMO_EMB - Embri's Many Pockets (works with steam) - 58 KB
DAO_PRC_PROMO_LKS - The Lucky Stone (works with steam) - 35 KB
DAO_PRC_PROMO_ME - Blood Dragon Armor (works with steam) - 6934 KB
DAO_PRC_PROMO_WKD - The Wicked Oath (works with steam) - 54 KB

I hope you get your content working.

SandvichSpy
04-27-2010, 10:23 PM
ok the last attempt I did yielded the followign install fail log

[Saturday Apr 10 19:15:22 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Saturday Apr 10 19:15:22 2010] Dragon Age 1.03 patch installer ran
[Saturday Apr 10 19:15:22 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Saturday Apr 10 19:15:22 2010] Command-line Paramters []
[Saturday Apr 10 19:15:22 2010] MUTEX_GAME already exists.
[Saturday Apr 10 19:15:22 2010] MUTEX_TOOLET_100 already exists.
[Saturday Apr 10 19:15:25 2010] Another DA program was detected running. Abort.
[Saturday Apr 10 19:15:25 2010] .onGUIEnd
[Saturday Apr 10 19:15:25 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Saturday Apr 10 19:15:25 2010] | Dragon Age 1.03 patch install finished
[Saturday Apr 10 19:15:25 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-


[Saturday Apr 10 19:15:43 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Saturday Apr 10 19:15:43 2010] Dragon Age 1.03 patch installer ran
[Saturday Apr 10 19:15:43 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Saturday Apr 10 19:15:43 2010] Command-line Paramters []
[Saturday Apr 10 19:15:51 2010] This patch is not for Steam. Abort.
[Saturday Apr 10 19:15:51 2010] .onGUIEnd
[Saturday Apr 10 19:15:51 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
[Saturday Apr 10 19:15:51 2010] | Dragon Age 1.03 patch install finished
[Saturday Apr 10 19:15:51 2010] -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-



Apparently it is because I do not have the correct dazip? but i only see one possible dazip download link in the unofficial troubleshoting thing and when I try to udpate the game via Steam it tells me its updated correctly. furthermore my account says the thing is linked to a PC account so I do not beleive it is incorrect...how do I make sure that the dazip is a dteam one?

Sigrd
04-30-2010, 12:41 AM
This has been a recurring problem with me for some time now. I've tried reinstalling twice, include a full reinstall of Steam. It's incredibly irritating. All promo codes are redeemed properly through Bioware.

SandvichSpy
05-10-2010, 10:35 AM
A Full reinstall of the game is not working to fix this in the least. What the hell am I supposed to do to get this ♥♥♥♥♥♥♥ed thing working?