PDA

View Full Version : Failed to Find Steam!?


Rilauven
04-20-2010, 02:56 PM
I just got The Deus Ex Package on steam, when trying to lauch Invisible War via steam, it thnks about it for a moemnt then does nothing. The fix for this that's worked for every other game is simply making a shortcut to the executable that runs it with admistrator privledges (I'm running Windows 7 64bit btw) with INcvisible War I get the error Failed to Find Steam.. even though steam's happily running in the background, It then tries to helpfully take me to a page to download steam. -_- HELP!

JG Seven
04-20-2010, 07:38 PM
Having the same issue with Deus Ex GOTY. Anyone have a solution?

BoBo2
04-21-2010, 03:06 AM
Same problem, can't use graphics mods.

Dragoon1
04-21-2010, 04:10 AM
There is a trick to use graphic mods without using a shortcut.
It works for Deus EX, don't know about IW.

Got to your installation folder
Example F:\Steam\steamapps\common\deus ex

Create a new folder, give it any name (as exsample "GraphMod").
Create inside this folder an other one and name it "textures".
Copy your texture files (*.utx) into this folder

Now go to ..\deus ex\System and open the DeusEx.ini with a text editor.

Search for the following string
Paths=..\Textures\*.utx
now add above this a new line and type
Paths=..\GraphMod\Textures\*.utx
It should look like that,

[Core.System]
PurgeCacheDays=30
SavePath=..\Save
CachePath=..\Cache
CacheExt=.uxx
Paths=..\System\*.u
Paths=..\Maps\*.dx
Paths=..\GraphMod\Textures\*.utx
Paths=..\Textures\*.utx

It's important you add the path to your texture mod above
Paths=..\Textures\*.utx
The game will first look in you mod folder for textures, before proceeding to the stock files if missing.

lonewolf1044
04-21-2010, 07:12 PM
Yeah I got the same thing, unfortunately when you buy these Oldies but Goodie games to play on a up to date computer you buy at your own risk and it may require you have some computer savvy. I haven't tried all my tricks yet. But I brought this because I thought Steam had tweaked it. I do have both Deus Ex and Deus Ex Invisible(multiple copies) on CD. Heck, it only cost me $5 for both so no real loss there. Deus Ex GOTY runs fine, just Invisible will not run.

Rilauven
04-24-2010, 12:36 PM
*bump* anyone find a solution for this yet?

Metazare
04-28-2010, 08:08 PM
I'm having the exact same problem, if I'd have known Deus ex 1 wasn't gonna work I wouldn't have bought it. Invisible war works, but who honestly wants to play that anyway?

znokiss
04-29-2010, 01:11 AM
Have you tried to follow the .ini modifications of my tutorial ? It may work : http://forums.steampowered.com/forums/showthread.php?t=1235278

Metazare
04-29-2010, 02:44 AM
No dice.

Apocryphon
06-22-2010, 11:22 PM
Just bought it today. Got the same problem, except with DX GOTY not IW. Fix doesn't work. Any advice?

znokiss
06-23-2010, 01:32 AM
Just bought it today. Got the same problem, except with DX GOTY not IW. Fix doesn't work. Any advice?

Did you install any mod, like HDTP ? HDTP requires to launch the game by using the special "HDTP.exe" instead of "Deus-Ex.exe". And that doesn't work with the steam version.
However, by fixing the "DeusEx.ini", you'll be able to fix that. Try step 5 here : http://forums.steampowered.com/forums/showthread.php?t=1235278

Apocryphon
06-23-2010, 12:59 PM
Editing the .ini files doesn't do anything at all. However, what I always do is Validate Steam file, and they fix two files. This solves the problem, but I must do this every time Deus Ex opens! This problem is very frustrating.

misterbk
12-06-2011, 05:59 PM
Apologies for the thread necomancy, but this thread comes up #1 in a Google search for "failed to find steam deus ex goty", so I figured a solution here would benefit a lot of people.

I believe "Failed to find Steam" happens because the game makes incorrect assumptions about the location of Steam, only looking in the default location for a 32-bit Windows machine:

C:\Program Files\steam

If you have 64-bit Windows or have chosen a custom location, the game will "fail to find Steam" because it's only looking in that location.

Users of 64-bit Windows have Steam located here:

C:\Program Files (x86)\steam

The solution is to add your Steam location to your path. I would love to give thanks to the thread that showed me this solution but it took the mods a day to activate me, and I've lost the link.


Here's how to fix it -without- using copy protection disabling hacked .exe files:


1: Right-click on "Computer" (in XP it was called "My Computer") and click on Properties.

2: in Vista / 7, on the left click on "Advanced System Settings". On XP, Google search for how to change your system path, because I can't quite remember where things were in XP.

3: In the Advanced tab, you'll see a button for "Environment Variables". Click it.

4: In the upper section of that new window, you should see something like "User Variables for [your username]". Scroll through to find the one called "PATH".

5: Highlight the entry for "PATH" and click "Edit...".

6: You'll get a too-small text box that has a field on the top for "Variable Name" and a field under it for "Variable Value". Put your cursor into the "Variable Value" field and hit the [End] key so you know you're not inserting text in the middle of another entry. If you push the right arrow key it should not scroll.

7: Add a semicolon [;] to separate your new entry from the others. This is the key to the right of the 'L' key, without pressing Shift.
Correct -> ;
Incorrect -> :

8: Paste in the path to Steam, which for me on a default-install Windows 7 64 system is:
C:\Program Files (x86)\Steam

9: Press OK, and re-launch Steam so that it gets the new environment variables. (It might work without re-launching, but hey why not.)

10: Run the game!

This should work with any custom location of Steam, for any games that have trouble finding Steam when they launch.

Disclaimer: I do not intend to say that nobody needs to replace the .exe to play Deus Ex GOTY without issues. This solution took me to the point of being able to launch the game via Steam. I may end up needing a patch of some sort to fix other issues, but this solved problem #1.

Aremocwen5
12-14-2011, 04:37 PM
I've had the first and second Deus Ex games for a while now and I beat them both. But now, after a while, I can't play either. It just says "Failed to find Steam". If I try it again it then says that the game is not available. I didn't do anything with graphics mods, though the last time I played I changed the resolution and graphics a bit. Help!

ilumnatr
12-16-2011, 08:04 AM
Similar to misterbk's solution, I fixed this by creating a shortcut at "C:\Program Files\Steam" that points to "C:\Program Files (x86)\Steam".

joethulhu
12-17-2011, 06:23 PM
I'm having this problem too, and I did the solution of editing the Path, and it worked... Until I restarted my computer. Then, I had to perform the fix again. Still, it worked and it wasn't a huge problem. However, after exiting the game again and trying to start it once more some time later, I still got the "failed to find Steam" error. I attempted the shortcut fix, and it had no effect. As an experiment, I even moved all of Deus Ex's files into a Steam folder created under regular Program Files, and copied all of Steam's, but it still did not work.

473NG3R
12-19-2011, 02:09 AM
I just decided to launch Deus Ex and was met with this problem. I am on a 64 bit system which would cause this problem to begin with, and on top of that I have Steam installed on a different drive than windows.

misterbk's solution worked for me, however there was no path variable, I had to add a new environment variable titled PATH and enter H:\Steam for my steam location as it is on another drive. I have yet to reboot, I did have to restart Steam but the first try worked.

Thanks misterbk +rep!!

OJSlaughter
12-20-2011, 01:02 PM
I've had the first and second Deus Ex games for a while now and I beat them both. But now, after a while, I can't play either. It just says "Failed to find Steam". If I try it again it then says that the game is not available. I didn't do anything with graphics mods, though the last time I played I changed the resolution and graphics a bit. Help!

Exactly my problem. Worked when I bought them a few months ago, suddenly do not work! WTF?

xXEldestXx
12-20-2011, 06:26 PM
I bought Deus Ex 1 today, and had the same error. I went into offline mode, played the tutorial, then got off and went back into online mode. now the game works fine. I hope this helps.

ripkun
12-30-2011, 07:57 PM
Thanks misterbk, Deus Ex Goty is now running in my pc thanks to your tip.

For those who are using Win Xp (like me), you can find environment variables in:

My Computer-> Properties -> Advanced tab -> Enviorment variables

BobT36
12-31-2011, 01:06 PM
Apologies for the thread necomancy, but this thread comes up #1 in a Google search for "failed to find steam deus ex goty", so I figured a solution here would benefit a lot of people.

I believe "Failed to find Steam" happens because the game makes incorrect assumptions about the location of Steam, only looking in the default location for a 32-bit Windows machine:

A detailed and informative guide that fixes the problem, thankyou! :)

Moonflight
01-02-2012, 03:47 PM
I bought Deus Ex 1 today, and had the same error. I went into offline mode, played the tutorial, then got off and went back into online mode. now the game works fine. I hope this helps.

I had this issue with both Deus Ex GOTY, and Deus Ex: Invisible War. Also running a 64 bit machine with Steam running from a seperate HD. Eldest's tip of starting them up in Steam's Offline mode worked fine. In fact, all I had to do was go into Offline mode, do a first time run on both games to the main menu, then go back online. Now both games work perfectly in Online mode. Thanks Eldest! :)

ForceMagic
01-24-2012, 09:27 PM
I bought Deus Ex 1 today, and had the same error. I went into offline mode, played the tutorial, then got off and went back into online mode. now the game works fine. I hope this helps.

Worked like a charm for me! I went offline, started the game, quit it, back online and started it again. Thanks.

Seyiji
01-25-2012, 09:40 AM
I had the same problem and I fixed it by first right clicking Steam and running as administrator then exiting Steam and starting the Steam normally.

Warrender
04-06-2012, 10:57 AM
I had the same problem and I fixed it by first right clicking Steam and running as administrator then exiting Steam and starting the Steam normally.

TY TY TY TY!

I was just about at the end of my rope trying to fix the "problem checking steam application" error. Tried all the fixes on this forum and this finally did the trick.

MystMan
04-06-2012, 11:13 AM
The offline mode & administrator and every other tip mentioned aren't what made it work. It's the restarting of steam that fixes this common problem. Many other games also have this issue, the problem lies with the current version of Steam.

Just shut down steam and restart it.

That's it.

jsmith1001
06-22-2012, 11:40 PM
@misterbk it worked. +rep

count_bubba
06-23-2012, 08:06 AM
I had the same problem and I fixed it by first right clicking Steam and running as administrator then exiting Steam and starting the Steam normally.


worked a dream, +rep!

Jancarius
06-24-2012, 11:10 AM
Apologies for the thread necomancy, but this thread comes up #1 in a Google search for "failed to find steam deus ex goty", so I figured a solution here would benefit a lot of people.

I believe "Failed to find Steam" happens because the game makes incorrect assumptions about the location of Steam, only looking in the default location for a 32-bit Windows machine:

C:\Program Files\steam

If you have 64-bit Windows or have chosen a custom location, the game will "fail to find Steam" because it's only looking in that location.

Users of 64-bit Windows have Steam located here:

C:\Program Files (x86)\steam

The solution is to add your Steam location to your path. I would love to give thanks to the thread that showed me this solution but it took the mods a day to activate me, and I've lost the link.


Here's how to fix it -without- using copy protection disabling hacked .exe files:


1: Right-click on "Computer" (in XP it was called "My Computer") and click on Properties.

2: in Vista / 7, on the left click on "Advanced System Settings". On XP, Google search for how to change your system path, because I can't quite remember where things were in XP.

3: In the Advanced tab, you'll see a button for "Environment Variables". Click it.

4: In the upper section of that new window, you should see something like "User Variables for [your username]". Scroll through to find the one called "PATH".

5: Highlight the entry for "PATH" and click "Edit...".

6: You'll get a too-small text box that has a field on the top for "Variable Name" and a field under it for "Variable Value". Put your cursor into the "Variable Value" field and hit the [End] key so you know you're not inserting text in the middle of another entry. If you push the right arrow key it should not scroll.

7: Add a semicolon [;] to separate your new entry from the others. This is the key to the right of the 'L' key, without pressing Shift.
Correct -> ;
Incorrect -> :

8: Paste in the path to Steam, which for me on a default-install Windows 7 64 system is:
C:\Program Files (x86)\Steam

9: Press OK, and re-launch Steam so that it gets the new environment variables. (It might work without re-launching, but hey why not.)

10: Run the game!

This should work with any custom location of Steam, for any games that have trouble finding Steam when they launch.

Disclaimer: I do not intend to say that nobody needs to replace the .exe to play Deus Ex GOTY without issues. This solution took me to the point of being able to launch the game via Steam. I may end up needing a patch of some sort to fix other issues, but this solved problem #1.

Well, now I got it to say "Problem starting up Steam"

Iconf10
06-25-2012, 06:32 AM
SIMPLE FIX: run steam as administrator. I just had the same error, did that, problem solved.

For those that don't know, right click your steam shortcut, run as administrator.

RulingRura
06-25-2012, 08:22 AM
SIMPLE FIX: run steam as administrator. I just had the same error, did that, problem solved.

For those that don't know, right click your steam shortcut, run as administrator.

Tried that. Still doesn't work.

Jancarius
06-28-2012, 10:08 PM
Already doing that, so unfortunately, not the issue. Some of my googling seems to indicate that the HDTP won't work with Steam, has anyone else had this issue?

Andreson
08-25-2012, 07:38 AM
Let's see if it works

yorick141
08-27-2012, 01:30 PM
More then 2 years and still no fix from valve *sigh*...

Stringers
09-10-2012, 01:12 AM
misterbk's fix worked for me, except my Path entry wasn't in the User Variables for my username, it was in the general one below it.

Gamevine
09-11-2012, 10:12 PM
There is no PATH in the upper section of environment variables.

ThresheR 593
09-14-2012, 01:48 AM
Just copy the steam.dll file from the main steam folder (copy it dont cut and paste it) and paste it in the deus ex systems folder and all should be good.

randomanon
09-14-2012, 10:28 AM
Just copy the steam.dll file from the main steam folder (copy it dont cut and paste it) and paste it in the deus ex systems folder and all should be good.

That worked for me.
Thank you for the hint!

Ejemy
03-01-2013, 04:18 PM
I know I'm late to the party so to speak but for future people who have this problem and nothing works, I exited steam then ran it as administrator then deus ex worked.

IndiasMafia
07-08-2014, 10:57 PM
IF NONE OF THESE SOLUTIONS WORKED THIS ONE SHOULD.

Go Into Steam and Right click the name of the game in your game Library

Go to properties

Click on LOCAL FILES and then click on BROWSE LOCAL FILES

If you scroll down you will find 4 .exe files named
JadeEmpire, JadeEmpireLauncher, JadeEmpireConfig, and TestApp

If you are running Windows 7 Right click ALL of these and go to properties

Then Click on the Tab labled Combatibility

Then Under Combatibility Mode Select Run this program in compatability mode: Windows XP (service pack 3)

Save it by clicking apply and repeat this process for all 4 files. Then launch the game from the file Jade Empire. Good Luck