PDA

View Full Version : Unfortunate problem of some importance.


NightmareBros
04-27-2010, 04:33 AM
For some Reason, I cannot play singleplayer in Garrymod, nor can I create a Multiplayer match.

As in, I can click the options to do so, but nothing happens.
This wouldn't be so bad, only that Singleplayer is the mode you needed for baisically making stop motion movies (Multiplayer sandboxes ten to not go well, unless your all in on it), and since I can't create a multiplayer server instead, I can't get aound the problem.

I'm currently rooting through my .lua files to see if anythings wrong with it (for example, I've accidently switched the loading screen into my main background), but with my inexpereince of identifying what is missing from it I'm not making much headway.

kaze
04-27-2010, 05:27 AM
What's the problem with singleplayer?
Does it just refuse to start up or is it crashing in the load?

NightmareBros
04-27-2010, 05:48 AM
Does it just refuse to start up or is it crashing in the load?
It just outright refuses to start up.
It doesn't even give me the options for what map I would want to play on.

Looking through the Garrysmod folder, I've also come across a notepad code called 'gameinfo' that sets me to "type multiplayer_only".

"GameInfo"
{
game "Garry's Mod"
title ""
title2 ""
type multiplayer_only

"developer" "TEAM GARRY"
"developer_url" "http://www.garrysmod.com/"
"manual" "http://www.garrysmod.com/wiki/"

FileSystem
{
SteamAppId 218
ToolsAppId 211

SearchPaths
{
Game |gameinfo_path|.
Game hl2
Game |all_source_engine_paths|hl2
}
}
}
Could this be my problem?

kaze
04-28-2010, 04:08 AM
Nah it says that for everyone.
You could try re-installing Gmod. Or validate the steam files.

NightmareBros
04-28-2010, 06:21 AM
I've already tried Uninstalling and reinstalling. It just comes back as it was before (all the files unchanged).
I don't know if you mean uninstalling it a different way, however (I uninstaled it via deleteing local game content via steam).

Narcotic Clown
04-28-2010, 07:59 AM
Until you can fix the problem, I suggest typing "map MAPNAME" in the console to force a map to load.

spencer314
04-29-2010, 12:11 PM
When you uninstall it, go into your Steam folder->steamapps->*yourname* and delete the folder for GMod so that no files linger around.

spartondan
01-23-2011, 05:46 PM
I am having this same problem, i tried opening a map with 'map <name>', then do 'impulse 101' but it doesent give me the Blue GravGun or the Toolgun, nor when i press Q it opens the tool menu, and also, when i right click my 'Garrys Mod 9' icon in the Library, it does not say validate, even after pressing properties. I have tried reinstalling, does nothing.

If you want to speak with me in IM and if you have a solution, please add 'spartondan', thank you in advanced.

Zekiran
01-23-2011, 06:54 PM
If you're using Garry's Mod 9, you aren't going to get anything helpful here, as it's been discontinued more than 2 years ago. So of course it won't validate. It's completely unsupported.