PDA

View Full Version : Possible fix for graphics issues / crashing to desktop (ATI Users)


ErichK
04-27-2010, 10:39 PM
Hey folks! I have some horrible texture warping going on, flickering, and crashing every short interval, and I use an ATI Radeon HD 4850, suffice to say, Catalyst Control Center was installed.

I uninstalled Control Center and then auto-updated the drivers using the tool in Control Panel > Hardware and Sound > Device Manager, then under "Display Adapters" selected my video card and clicked the "Update Driver Software" button.

No more flickering, stretching, warping, or crashing so far.

Try this out and post your results here - Control Center might be the whole reason for all this hair pulling.

Edit: Also, install this hotfix if you can. Make sure you select "Custom installation" and deselect "Catalyst Control Center" during install!

http://support.amd.com/us/kbarticles...-a-Hotfix.aspx

# Splinter Cell Conviction - Resolves stability issues in the game when using a Windows 7 / Windows Vista / Windows XP

# Splinter Cell Conviction - Resolves performance stuttering issues when using a Windows 7 / Windows Vista / Windows XP


SSC fixes FAQ:
http://forums.steampowered.com/forum....php?t=1244803

ErichK
04-28-2010, 09:25 AM
*Bump* For anyone else that was having flickering textures and stretching. This also helps immensely with the frequency of crashes.

Darkunov
04-28-2010, 03:41 PM
Dude. You're my hero. Before I saw this fix the longest I could play without crashing was about the time it takes you from one checkpoint to another. Now, I don't have any crash.

By the way, I followed your instructions except for one thing. I typed "Catalyst" in the search box and what I found was not Catalyst Control Center, but Catalyst Install Manager. Double-click on this, choose the top option (which should already be selected) and when it's done the actual Catalyst Control Center will be uninstalled. Windows will then ask you to restart now or later, so I clicked now, the comp obviously restarted and from there I followed the rest of your instructions.

Xealot42
04-28-2010, 03:55 PM
I wonder why these fixes weren't included in the official 10.4 release today. Or were they just left out of the release notes?

NFACurious
04-28-2010, 04:31 PM
NM, found it.... sorry!

Zurv
04-28-2010, 04:38 PM
why not just install the driver that fixes that issue? >.<

http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst-10-4-a-Hotfix.aspx

# Splinter Cell Conviction - Resolves stability issues in the game when using a Windows 7 / Windows Vista / Windows XP

# Splinter Cell Conviction - Resolves performance stuttering issues when using a Windows 7 / Windows Vista / Windows XP


SSC fixes FAQ:
http://forums.steampowered.com/forums/showthread.php?t=1244803

NFACurious
04-28-2010, 04:54 PM
What about ATI 4670?

Zurv
04-28-2010, 05:02 PM
my god ppl.. atleast look @ the ati link before asking silly questions...


■Splinter Cell Conviction - Resolves stability issues in the game when using a Windows 7 / Windows Vista / Windows XP based system with an:
◦ATI Radeon HD 3xxx Series of products
■Splinter Cell Conviction - Resolves performance stuttering issues when using a Windows 7 / Windows Vista / Windows XP based system with an:
◦ATI Radeon HD 2xxx Series of products
◦ATI Radeon HD 3xxx Series of products
◦ATI Radeon HD 4xxx Series of products
◦ATI Radeon HD 5xxx Series of products


you don't want to "update" drive from windows anyway. That will just get drivers from windows update and it will be behind what ATI(AMD) has out.

NFACurious
04-28-2010, 06:08 PM
Well, this didn't help my game crashing anyways.

But thanks for the driver update info!

Andy71480
04-28-2010, 06:28 PM
i would love to fix some unstability issues, but mine bonks out soon as the Ubi counter in the loader hits 1.. it blacks out then *poof* gone, like it never loaded ...

ErichK
04-28-2010, 06:43 PM
why not just install the driver that fixes that issue? >.<

http://support.amd.com/us/kbarticles/Pages/ATI-Catalyst-10-4-a-Hotfix.aspx

# Splinter Cell Conviction - Resolves stability issues in the game when using a Windows 7 / Windows Vista / Windows XP

# Splinter Cell Conviction - Resolves performance stuttering issues when using a Windows 7 / Windows Vista / Windows XP


SSC fixes FAQ:
http://forums.steampowered.com/forums/showthread.php?t=1244803
Fix worked great! No flickering, no bugs, no crashing! Wow! Thanks bro!

germanjoe
04-28-2010, 06:54 PM
The official Catalyst 10.4 release, published 04-28-2010 (today), work like a charm. I do recommend uninstalling the 10.3 driver and using DriverCleaner Pro before installing the new driver.

Last night I had all symptoms - flickering and inconsistently partly missing menus, BSOD and CTD - tonight I play with crisp and smooth graphics on my mainstream system (AMD X2 2.8 Ghz, WinXP 32, ATI Radeon 4850, 1680x1050). Sound is still a bit choppy but I have full trust in UbiSoft and the next patch.

http://game.amd.com/us-en/drivers_catalyst.aspx

Cheers,
Joe

nigel5000
04-28-2010, 07:27 PM
This also happened in Borderlands, it WAS a known issue that this and similar iterations of the Unreal Engine didn't work well with ATI Cards...

As a simple rule of thumb, I found a very very reliable technique that works before a hotfix is available...if you DL a fan speed application and keep your GPU temp down, and lower the resolution to 1024x768 (yes, i know it's painful) it does very well to prevent crashing...

Hope that helps and thanks to ATI for 10.4!

germanjoe
04-29-2010, 05:27 AM
Quick update: The 10.4 Catalyst works most of the time. After starting the game 2-3 times since reboot, the menu graphics are distorted again, elements are missing etc.

Still not a stable solution, as a quick workaround I recommend changing the 3d settings back and forth between "balanced" and "performance"- the quality setting most times results in the corruption described in the first paragraph.

Cheers,
Joe

hiccups
04-29-2010, 06:26 AM
STICKY this thread pls!!!

Menace
04-29-2010, 10:56 PM
Control Center might be the whole reason for all this hair pulling.

Edit: Also, install this hotfix if you can. Make sure you select "Custom installation" and deselect "Catalyst Control Center" during install!


This solution worked like a charm, CHAMPION! Unchecking the catalyst control box solved the problem, didnt have to go the long way for installing the driver though.

+Rep