View Full Version : Game runs way too fast, like watching it in fast forward

04-28-2010, 12:23 PM
I had this game for PS2 and loved it, but there was a definite difference when I fired it up on my PC. The game runs about 2x as fast as it should, and it's very annoying: steering and cornering are very jerky, dialog at the beginning a race doesn't sync up (if they do a countdown, you're typically already moving by the time they start counting), and just makes it frustrating to drive.

I did a google search for the issue and didn't come up with much, other than it exists. Does anyone else seem to have this issue and/or know how to fix it? As much as I love watching the NPCs dart around the city like slot cars, it's very annoying trying to keep pace with the game.

04-28-2010, 10:35 PM
Sounds like you're running an operating system with a dual core processor, if not 2x processors. If you're running XP, you'll need a patch. If you're running Vista or above, you'll need to instruct the game to use one of those cores. The first core being #0 and the second as #1. Better to get it to use the second.

You can try to use "Task Manager" when the game runs by pressing CTRL + ALT + DEL. Then select mc2.exe under processes, right click, and set affinity to just 1 out of 2, 3, or 4. Then resume

04-29-2010, 08:19 AM
Sounds like what I was reading when I looked it up the first time; had something to do with most multi-core CPUs downclocking to a lower clock speed under idle conditions, and having the game read the CPU as that speed.

The game gets set up to run on a 800Mhz CPU (which is what mine downclocks to when it's idle), but when the game actually starts mine bumps back to the stock 2.2Ghz clock so the game ends up running much quicker.

I figured out a temporary fix last night, just have to run another game before you start MC2, so the CPU is running at stock speed when MC2 opens. I couldn't find an XP patch, just a bunch for Vista that work for 7 as well, but I'll try assigning a core to it when I get home, tyvm for the tip :)

04-29-2010, 05:45 PM
If it works, come back to this thread. People can hopefully learn from it.

Where there's a will, there's a way :)

04-29-2010, 09:59 PM
the task manager dose work but for some reason my dual core dosen't seem to need it it runs at perfectly normal speed. I say seems since i never played this on the consoles when it first came out.

04-30-2010, 07:25 AM
Turn off Cool&Quiet or whatever the Intel equivelant is, alternatively you might want to look into updating your motherboards BIOS.

If you've got an older system running a x2 CPU the board may "support" it insofar as recognising it but may not handle multithreading correctly, especially on a non 64bit OS.

05-01-2010, 03:56 PM
I just tried the MC2 demo and I get this problem. I have a laptop with a Core 2 Duo processor. I tried doing the task manager thing, but every time I brought it up while the game was running, it would go back to the game after a second so I couldn't change the processor affinity.

EDIT: I also have Vista 64-bit, if that helps any.

05-02-2010, 07:24 PM
Successfully used this for Deus Ex. ImageCFG (http://www.robpol86.com/index.php/ImageCFG)

05-04-2010, 11:43 PM
Successfully used this for Deus Ex. ImageCFG (http://www.robpol86.com/index.php/ImageCFG)

That utility didn't work for me. The problem is still there. Also, I've noticed that the game will slow down (literally, I'm not talking about just a low frame rate) when there is a lot happening on screen.

07-21-2010, 05:42 AM
Having the same issue - 7 ultimate x64. :/

05-29-2012, 11:20 PM
When i try to make it work with 1 core, the game was too slow, when i turn it back in 2 cores, game is too fast .... what i need to do ?

05-29-2012, 11:55 PM

Try using this if you have an Athlon 64.

wazups 2x
05-31-2012, 10:09 PM
I have a Phenom II X4 955 and also having a similar problem. Completely unplayable.

And I already have C&Q disabled.

06-01-2012, 08:42 AM
No wonder that they gave it out for free. It's worthless.