PDA

View Full Version : Portal Major Graphic Glitch - Required Hard reset,


smogsy
05-13-2010, 12:20 AM
firstly thank you for steam for mac.

Secondly im a software tester, by trade so later on i am going to put together a Bug reporting template, to explain bugs easier to the developers.

Subject: Portal Graphic Glitch.

Description: After changing all graphics settings to there highest setting, i recieved a major graphic glitch (see link) this required a hard reset.
http://smogsy.co.uk/Steam/screenshot.png

OS Version: 10.6.3
Software: all updates are done

Mac Used:
Mac Pro 2.26Ghz 12GB ram 4870 512MB

Resolution used:
2560x1600 @ 30" fullscreen mode.

Steam Version used: Built: 12 2010 @ 17:13:43 Steam API:V009

Steps to reproduce: (haven't tried this again yet)
1. load portal
2. go to graphics options and change to 2560x1600
3. go to advanced graphics change every option to highest setting.
4. press apply
5. see graphics glitch http://smogsy.co.uk/Steam/screenshot.png

GHRobson
05-13-2010, 12:47 AM
Im afraid your image doesnt load.

smogsy
05-13-2010, 12:58 AM
works fine for me : )

rbarris
05-13-2010, 01:31 AM
firstly thank you for steam for mac.

Secondly im a software tester, by trade so later on i am going to put together a Bug reporting template, to explain bugs easier to the developers.

Subject: Portal Graphic Glitch.

Description: After changing all graphics settings to there highest setting, i recieved a major graphic glitch (see link) this required a hard reset.
http://smogsy.co.uk/Steam/screenshot.png

OS Version: 10.6.3
Software: all updates are done

Mac Used:
Mac Pro 2.26Ghz 12GB ram 4870 512MB

Resolution used:
2560x1600 @ 30" fullscreen mode.

Steam Version used: Built: 12 2010 @ 17:13:43 Steam API:V009

Steps to reproduce: (haven't tried this again yet)
1. load portal
2. go to graphics options and change to 2560x1600
3. go to advanced graphics change every option to highest setting.
4. press apply
5. see graphics glitch http://smogsy.co.uk/Steam/screenshot.png

I've see failure modes in Mac video card drivers when extreme settings are chosen (max MSAA combined with very high res). Since we can't easily fix drivers from our end, and in many cases cannot detect failures like this from our code, really the only immediate relief is to discontinue usage of all-maxed settings on that config.

smogsy
05-13-2010, 03:16 AM
hi rbarris

i've found the cause, of the glitch changing AA from 4X to 8X causes this no other option, has the same effect.

i do realise it could be on the Apple Driver end, and to be honest 99.9% sure it would be,

im guessing Valve & apple will talk in the future to fix these problems? but wouldn't it be a good idea if this problem continues with many others. to say *not Recommended on the highest settings?


other wise a lot of people could be effected.

im going to run on 4X for now, i will miss the higher options though :(

rbarris
05-13-2010, 03:31 AM
hi rbarris

i've found the cause, of the glitch changing AA from 4X to 8X causes this no other option, has the same effect.

i do realise it could be on the Apple Driver end, and to be honest 99.9% sure it would be,

im guessing Valve & apple will talk in the future to fix these problems? but wouldn't it be a good idea if this problem continues with many others. to say *not Recommended on the highest settings?


other wise a lot of people could be effected.

im going to run on 4X for now, i will miss the higher options though :(

The right thing for us to do is chat with ATI about it and see if they can identify the root issue, and maybe they can fix it.

smogsy
05-13-2010, 04:00 AM
just to update,

i found a way out of the glitch mayhem expose,

if you use expose you can see your desktop unaffected quit the app and carry on with your normally OSX session :)

SpeedFleX
05-13-2010, 06:46 AM
I had this setting to and it was when I maxed out all settings..

iMac with 8gb Ram and ATI Gpu

could not launch portal anymore after that

I just changed the lauch options to -autoconfig, put the aa down and it worked then