PDA

View Full Version : Mass Effect will not load


wedge22
05-13-2010, 02:23 PM
Ok so I have recently upgraded my PC from Windows Vista to Windows 7 64bit, everything has worked well up to now except 2 games on Steam, one of which is Mass Effect. When I click Play to start the game, I get the busy cursor and then nothing, no loading, no config screens or splash screens. I have tried reinstalling to a different hard drive after redownloading the whole game, in fact I wiped my whole HDD with Steam and reinstalled Steam to a new HDD. I have Windows 7 64bit with all the latest drivers for all hardware on my PC. I have also tried running in compatability modes, Vista SP1 and 2 and Windows XP SP3. Any help would be appreciated.

nervog
05-15-2010, 12:43 AM
I had this very same problem I hope this works for you. I have 64bit windows 7 all drivers are up to date have, ran integrity check, hardware pass diagnostic checks (memtest, DFT) and the thing wouldn't run. Dug around in the folders (specifically C:\Program Files (x86)\Steam\steamapps\common\mass effect\Binaries) and found the MassEffect.exe and went to properties and set it to compatibility mode windows xp sp3 and run as admin. This seemed to work for me. Hope this helps.

NilsJ
05-23-2010, 09:34 AM
I have Windows 7 and Mass Effect 1 and 2 both work flawlessly. Not trying to piss you off, just saying that it SHOULD work on Windows 7. Hops you find a way :-)

Fiszy
05-23-2010, 12:32 PM
Both of them work fine for me and I'm running the same OS as you. Excluding the crappy optimization of ME1, though.

wedge22
05-23-2010, 05:00 PM
Thanks for the help guys I did get it working by altering the settings for the Mass Effect.exe this time round and running as an Admin.