PDA

View Full Version : Terrible performance with ATI graphics cards


OmniAtlas
05-13-2010, 07:49 PM
Hi all, anyone else using ATI and having terrible performance?

I thought it would be great if everyone could post their specs to see if this was a universal problem

I'm running on a

Core 2 Duo overclocked to 3ghz, 4 GB ram, ATI 4850 (512 VRAM), Snow Leopard 10.6.3.

Over >100 FPS on my Windows partition, I'm getting between 10-20 FPS on Mac OS, all on high, except AA at 2X, Aniso 8x, color correction and vsync OFF.

--
To check your FPS with source games, enable the console (Options -> Keyboard -> Advance), press tilde ~ in game and type in "net_graph 1" (without quotes).

---

FIX FOR PROBLEM:

My frame rates are now over 60+ FPS ; the problem I had was with Paragon NTFS 7.0 (lets you read Windows partitions) -- it causes SEVERE slowdown. Installed 8.0 version and everything is fixed now.

UPDATE: FPS dropped back down to 20 FPS again, I have no idea what could be causing this. I've uninstalled Paragon and it still persists.

thedreadedgman
05-13-2010, 07:51 PM
yep pretty terrible, 4670 here, read a review online that said I could get nice framerates even on native (1920x1080) but no luck, have to use 1280x720 or so to get good rates, or disable a bunch of stuff.

poopdedoop78
05-13-2010, 08:31 PM
4870 here. game play is pretty bad in OS X compared to windows on the same machine (running in bootcamp)

nano....
05-13-2010, 08:38 PM
Same here. Old-ish iMac 24" with a Mobility Radeon 2600XT HD. Was able to handle Portal very well in Windows, but suffers here.

dreyesceron
05-13-2010, 09:06 PM
Same Here.

2 Ghz Core 2 Duo with 2 GB Memory and an ATI Radeon HD 2400. Portal ran terribly at the start up and settled down once I put most of the setting to their lowest and Portal depth to 0. But even then it runs slower than my PC.

I'm caving and about to run Boot Camp on this Mac to see how the system fares with the Windows XP OS.

FuzzyPuffin
05-13-2010, 09:10 PM
Well, that's weird. I have great performance. ATI 2600 Pro. It's better than the XT but a lot worse than the newer 4xxx and cards.

I played through some of level 19 and the framerate never dropped below high forties/low fifties, except for the fire part where it droped into the twenties. Also there was a bug where I was getting black portals, that probably helped me get a better framerate too.

Anyways, here are my settings if you want to try them.

Everything on High EXCEPT:

Shadows on medium
FSAA off
Filtering set to Trilinear
Vsync off
blur off
color correction off

My resolution was 1680x1050. I have a 2.66 Ghz April 2008 iMac with 4 GB Ram.

BTW, this might sound stupid--but make sure your mouse sensitivity is up. I was thinking it was really, really laggy, and then I noticed that the sensitivity was all the way down!

OmniAtlas
05-13-2010, 09:31 PM
I fixed my performance issues -- it was the paragon 7.0 software I was using (reads windows NTFS). I have no idea why it would slow down FPS. Upgraded to 8.0 and everything is fine now.

At fullsettings (max everything) I'm getting 60-70+ FPS.

ikir
05-14-2010, 03:44 AM
Pretty good on MAcBook Pro 13" with 320M. We have a super fast OS, good graphics card but terrible drivers. This is ATI and Nvidia fault, i hope APple will do more pressure about 3D graphics drivers now that Steam is out.

OmniAtlas
05-14-2010, 05:30 AM
I have no idea what is going on. My FPS drop back down to 20 FPS again. I've uninstalled Paragon 8.0 and I'm still at 20 FPS. So from 60 FPS I've dropped down to 20, 40 FPS drop and I haven't done anything to my system.

Confused!

jeanlain
05-14-2010, 05:50 AM
Some weird, random things happen which may be solved by restarting the game under different settings, and switching back to the previous ones.

Ooomph
05-14-2010, 05:59 AM
Same Here.

2 Ghz Core 2 Duo with 2 GB Memory and an ATI Radeon HD 2400. Portal ran terribly at the start up and settled down once I put most of the setting to their lowest and Portal depth to 0. But even then it runs slower than my PC.

I'm caving and about to run Boot Camp on this Mac to see how the system fares with the Windows XP OS.
That's odd. I have the same card, everything on high, but AA, and it runs at about 30fps, which seems pretty smooth to me. :confused:

poopdedoop78
05-14-2010, 06:15 AM
Anyways, here are my settings if you want to try them.

Everything on High EXCEPT:

Shadows on medium
FSAA off
Filtering set to Trilinear
Vsync off
blur off
color correction off

My resolution was 1680x1050. I have a 2.66 Ghz April 2008 iMac with 4 GB Ram.




FSAA and FILTERING are what will rally bog down the game, and since you have them off/set to low that's why your performance is better.

People shouldn't ave to turn off AA or filtering to e able to play the game at a decent frame rate.

Apple needs to get their act together and make some proper graphics drivers, or let a 3rd party dev make them so we don't have to wait for every major update and hope there will be an improvement.

jeanlain
05-14-2010, 06:39 AM
Filtering doesn't really impact performance on my MBP (dual GPU). AA does.

dreyesceron
05-14-2010, 06:47 AM
Well, after finally taking the time to get Windows installed, Portal definitely performed much better under Boot Camp with Windows XP than Mac OS X. I made sure to play until I reached the 1st Water Pit area and even there, the FPS remained very steady , with all the settings set to their highest, except with Color Correction and AA turned off. I bumped up the Filtering mode to 8x and it still held up fine.

I'm going to give TF2 a shot next and see how it holds.


This sucks. I was hoping to do all my gaming on Mac OS X but I guess I will have to wait until the drivers become optimized. Portal just can't run as well on my Mac currently.

dreyesceron
05-14-2010, 06:49 AM
That's odd. I have the same card, everything on high, but AA, and it runs at about 30fps, which seems pretty smooth to me. :confused:

Strange. I had to bump everything down to Low to even get an ok FPS. And even then it struggled at certain points.

What OS Version are you using? I have 10.5.8.

Ooomph
05-14-2010, 07:07 AM
Strange. I had to bump everything down to Low to even get an ok FPS. And even then it struggled at certain points.

What OS Version are you using? I have 10.5.8.
I have 10.6.3.

dreyesceron
05-14-2010, 07:26 AM
I have 10.6.3.

Well there's the kicker then. I've heard some mention 10.6.3 performs better. At this point, I may as well wait for 10.6.4 to release (If the release isn't too far out).

blobsticks
05-14-2010, 10:09 AM
This lot seems to work for me in Portal, after a lot of fiddling.

24" IMac
OS 10.6.3
3.06ghz
4mb ram
ATI 4850

With these settings I have smooth as silk frame rates (no idea how to check the exact number though) and it has magically got rid of the black portal bug

Resolution: 1344x840
Display Mode: Full Screen
Aspect Ratio: 16:10

Advanced

Model Detail: High
Texture Detail: High
Shader Detail: High
Water Detail: Reflect all ... I've not come across water yet though
Shadow Detail: High
Colour Correction: Disabled

Anti Aliasing Mode: 2x MSAA
Filtering Mode: Anistropic 2x
Wait for Vertical Sync: Enabled
Motion Blur: Disabled
Field of View: 75
Multicore Rendering : N/A

Now I know that's not going to be ideal for everyone, but it makes the game playable for me, I thought you might like to know, maybe it'll help a few people. :)

Although Steam still crashes on exit of Portal.. any solutions for that? :)

smogsy
05-14-2010, 10:29 AM
Mac Pro 2009 2.26Ghx Octcore 12GB ram 4870 512MB 10.6.3

Resolution: 2560x1600

Running at 2560x1600 i get around 90FPS-110 with 4AA 16AF Everything on High (rest on very high)

cant use 8X AA ATI Drivers crash on portal, OS stays as it should.

i havent expericed any problem, other than not working with 8AA

Bubo
05-14-2010, 10:40 AM
Nvidia loves Open source and OpenGL, ATI hates them (Balmer my friend).

ATI drivers where writed by a drunk child.

RUSBoris
05-14-2010, 11:11 AM
Nvidia loves Open source and OpenGL, ATI hates them (Balmer my friend).

ATI drivers where writed by a drunk child.

You got it the other way around. ATI has always been a proponent of OGL. Even their workstation cards are (were?) named FireGL

OmniAtlas
05-15-2010, 05:48 AM
Hm, I'm beginning to think that its just portal / source engine causing the bad frame rates, and not the opengl / ati drivers.

heretic5
05-15-2010, 08:16 PM
iMac7,1
10.6.3
Core 2 Duo 2.4ghz
ATI Radeon HD 2600 Pro 256mb
2 gig ram

If your setup is the same as mine, give these settings a shot. I've been able to run portal perfectly smooth (with the exception of water, which is reported to be a problem on almost all macs w/ ATI cards).

1344x840 (not the native res but the difference is hardly noticeable and it helped me a lot)

Max out EVERYTHING, but turn off color correction and vsync. Keep AA off b/c its an fps friggin hog and if you are going to whine about a few squigglies then you're not too desperate for smooth gameplay. Turn Anisotropic Filtering all the way up (this has nearly no impact on performance for me). Disable motion blur (no problem for me b/c its also an fps hog and I hate it anyway). Water detail doesn't matter, it lags no matter what it's set to. Portal rendering also works ok at 4 for me.

With these settings the only graphics effect you're missing out on is motion blur but big deal. I've gone through the entire game using this setup and it's worked w/ out a hitch. Please tell me if this helped :D or didn't help :(

heretic5
05-15-2010, 08:21 PM
You got it the other way around. ATI has always been a proponent of OGL. Even their workstation cards are (were?) named FireGL

Yeah, well right now their drivers for OSX suck. Period. Not being hostile, being honest.

smoke.tetsu
05-15-2010, 08:31 PM
On my 27 inch iMac (2.6Ghz Core i5, ATI Radeon HD4850 512MB, 4GB RAM).
The best settings for me are 2560x1440, 16x Anisotropic, 2x AA, everything maxed out except color correction and motion blur off (motion blur didn't even seem to do anything compared to in other games that have it).... and that's the best combination of performance and looks on my machine for now. Vsync on.. on my mac it still performs well with it on and the tearing was very distracting with it off... although I've read they most likely use double buffering so I would like for them to put in a triple buffering option.