PDA

View Full Version : Stuck at "Preforming first time setup."


vman777
05-14-2010, 04:26 PM
Edit: This is on a PC, Windows Vista.

So I bought Torchlight because I thought it looked pretty good (and hey, why not at 50% off), but now I'm stuck at:

---
Performing first time setup...

Installing: Microsoft VC Redlist Package (Step 1 of 1)
---

I've tried running as Administrator, going into Torchlight settings and doing SAFEMODE=1, and general troubleshooting that I've found for Torchlight.

Nothing launches past that screen. There's also no "Torchlight.exe" in task manager as I get the "first time setup."

I've left it there for three hours last night as I went to drink at a friend's house. No progress.

Oh, and Portal worked fine.

Help :<

vman777
05-15-2010, 04:18 PM
Nobody knows :/

Kuzoh
05-15-2010, 10:50 PM
I found a couple of tid bits that might have something useful.


Did you set steam to also run as admin in addition to torchlight? Not sure if Vista does this automatically, but I know Windows 7 does.

Also, there was a suggestion to open the application directly in the steam folder at C:\Program Files\Steam\SteamApps\Common\<Game Title> (would be Torchlight.exe I believe).


If I can find more I'll post it here.


Edit:

"Visual C++ 2008 Feature Pack Release" I see this is a possible update for this specific microsoft program. Might be worth a shot.
http://www.microsoft.com/downloads/details.aspx?FamilyId=D466226B-8DAB-445F-A7B4-448B326C48E7&displaylang=en

Either that or this is what I end up getting. These two options seem much more promising tho.
http://www.microsoft.com/downloadS/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en

Sources so far:

1. http://forums.steampowered.com/forums/showthread.php?t=1175302
2. http://forums.steampowered.com/forums/showthread.php?t=998863
3. http://forums.runicgames.com/viewtopic.php?f=24&t=1286&p=21312&hilit=Installing:+Microsoft+VC+Package#p21312
3.a. (the non highlighted version) http://forums.runicgames.com/viewtopic.php?f=24&t=1286&p=21312&

vman777
05-16-2010, 02:36 AM
None of those work. Downloads were already up to date. Trying to launch Torchlight from C:\Program Files\Steam\SteamApps\Common\ as administrator does not launch Torchlight for me.

Kuzoh
05-16-2010, 11:32 AM
I just got Torchlight downloaded via steam as well. Same issue. If I find any solutions that work I'll post em here for ya.


Edit: Unfortunately it eventually worked. I too was stuck on the "Performing first time setup... Installing: Microsoft VC Redlist Package (Step 1 of 1)" for a few minutes, but later finished when I left it running to go get a drink.


I just bumped into this thread which summed up was 1. restarting steam and try again, 2. go into the "steam file and delete ClientRegistry.blob and re-start steam" (located in c/program files/steam/clientregistry.blob)
http://forums.steampowered.com/forums/showthread.php?t=958283


I remember a previous thread talking about deleting torchlight and re-downloading it as well as doing the same to steam and then to his OS (their OS was Win XP tho). Probably a little too extreme.


Edit: Just bumped into this: https://support.steampowered.com/kb_article.php?ref=4595-WEXN-6831
Windows 7/Vista version: https://support.steampowered.com/kb_article.php?ref=5688-IFHZ-2170
From here: http://forum.ea.com/eaforum/posts/list/15/377563.page