PDA

View Full Version : Major graphics errors with Geforce 9400M in MacOSX (works perfect in Bootcamp)


Reaper47
05-16-2010, 08:01 AM
Yea, so, it's just not worth saving the 1,5 minutes it takes to load up Bootcamp. On the same hardware (mid-2009 MBP 13" with a 9400M graphics card, 2.35 GHz C2D, and 2GB of RAM) the game works flawlessly under Windows XP in Boot camp.

On MacOSX:

* All leader faces have a transparency bug that makes them either invisible or draws their teeth and eyeballs on the outside which looks disturbing as hell.

* If you zoom out to a certain point, world tiles are covered in a wrong error texture (looks like a random texture picked from somewhere else).

* Sometimes, when making a move, the game slows down to a crawl, you'd think it just crashed but it's "only" a 60 second lag.

I tried every possible permutation of graphics levels (low, high), anti-aliasing (on/off), terrain detail settings, etc. Nothing fixes this.

I know from the Windows version running on the same laptop, that the hardware can handle the game fine, with maxed out settings, AA and native resolution. It's either the game's fault or that of the crappy MacOSX graphics card drivers (which I see no official, or even unofficial way of replacing).

Either way, I had to give up on the MacOSX version. Until this is fixed, I see no reason to play this game in MacOSX, which is a shame because I was really looking forward to it after all the back and forth in the last few days. :(

the kid
05-16-2010, 09:49 AM
* All leader faces have a transparency bug that makes them either invisible or draws their teeth and eyeballs on the outside which looks disturbing as hell.

I have an early 2008 MBP with a GeForce 8600m GT. I was able to fix this problem by setting anti-aliasing to 0. I know you said you tried that, but it worked for me so I thought I'd share.

muscadine
05-16-2010, 10:04 AM
Turn off AA and it will fix it's self.

Reaper47
05-17-2010, 04:44 AM
I have an early 2008 MBP with a GeForce 8600m GT. I was able to fix this problem by setting anti-aliasing to 0. I know you said you tried that, but it worked for me so I thought I'd share.

I could swear I tried that. But I'll check it again. Thanks for sharing.

Still sucks, but less.

PalmReader
05-22-2010, 10:18 PM
Turn off AA and it will fix it's self.

Thanks. Worked for me.