PDA

View Full Version : Wrong font in all Civ IV OS X games


stevebr
05-16-2010, 12:54 PM
So, Sylfaen isn't being used in any of the Civ IV games on my OS X installations like it is in Windows. From others' screenshots I've seen, this isn't normal for OS X.

Here's what it looks like on my system (http://img23.imageshack.us/img23/5873/civ4wrongfont.png). This replacement font is everywhere in the games and it's a little problematic because it's also a little too big, so there's some overlap in some cases.

sylfaen.ttf is where it should be in the game installation paths. Theme files look good (compared to the windows versions). I'm not using any third-party font mgmt. software and I've tried a few things to troubleshoot already:


Installing and activating Sylfaen with Font Book
Copying sylfaen.ttf from the Windows installation (installing that too -- replacing the other)
Copying over the relevant theme file from Windows
Hand editing the theme file


None of these things worked. I also tried hand editing the theme file with some ridiculous values to see if it's being read by the game at all. It isn't.

Is anyone else experiencing or aware of this problem? Do you know of a solution?

Thanks in advance.