PDA

View Full Version : printer won't install


L.o.D.
05-17-2010, 11:09 AM
I did a fresh install of Win7 x64 before the weekend & am now trying to install my printer which worked fine, without issue, before hand.

Now when I plug the USB cable in, it makes 3 deep sounding beeps.
I tried a manual install of it's drivers that I downloaded from the Canon website & they say they installed ok. But when I open devices & printers, it says it needs a driver, even though t already is installed.
So I run the troubleshooter which searches for a driver, but fails to find one.

Devices & Printers "sees" the printer but has it listed as unspecified.

It's a Canon MP160.

Any ideas??

ester25
05-17-2010, 11:35 AM
1. i assume the driver you got was this:
gdlp01.c-wss.com/gds/3/0900002113/04/mp160win64111ea23.exe from Canon site (http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&fcategoryid=116&modelid=13368#DownloadDetailAct)
2. Try different USB ports
3. Find UVCView x64 utility, its a microsoft utility for troubleshooting USB ports (tells you speed, current, device type etc). I think its part of WDK (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=36a2630f-5d56-43b5-b996-7633f2ec14ff) If you download the ISO and install the tools component, it is located in \WinDDK\7600.16385.1\Tools\avstream\amd64

notavirus.exe
05-17-2010, 11:35 AM
google.com >>> "canon mp160 win7 drivers" >>> look for 64 bit drivers on page.

Download/install >>> success?

specifically this page

http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&fcategoryid=116&modelid=13368#DownloadDetailAct

if you see where it gives you the option to select your OS, make sure you pick 64 bit win 7

L.o.D.
05-17-2010, 11:45 AM
ester, yes that is the installer I used a few times over.
2: Tried all my USB ports that have other devices working fine in them.

When I try to get windows to install a driver, it says it can't find any.

notavirus.exe
05-17-2010, 11:50 AM
download the driver to your desktop. go to printers n devices (where you said you can see it as unspecified) and right click it, I believe there should be an option in there to install the driver.

another option would be in device manager, make sure you dont have any choices there with a yellow yield sign over them. If you do, right click and select update drivers/install drivers (I forget the exact selection, sorry i'm at work using stupid xp so I can't see first hand).

L.o.D.
05-17-2010, 11:54 AM
The only options under right click on the printer icon in device manager is create shortcut, troubleshoot (which still fails to install driver) and properties.

I have tried it through device manager.

notavirus.exe
05-17-2010, 11:58 AM
I know if you do properties there should be a driver tab. Other than that I'm sorry friend, all out of ideas.

I was going to suggest uninstall and reinstall but you don't have anything to uninstall. I bet this is aggravating.

L.o.D.
05-17-2010, 12:03 PM
When I run the installer again, it asks to uninstall the old driver first.

notavirus.exe
05-17-2010, 12:13 PM
where's rotn when I'm drowning in information... LOL

L.o.D.
05-17-2010, 12:18 PM
He was in here as he edited one of your posts.

notavirus.exe
05-17-2010, 12:22 PM
omg ninja admin, lol! I feel like someone is standing behind me and saying, "no son, not that one...there you go! good job!"

the last thing I can think of for that canon is maybe trying their support site, usually big companies have a chat log that you can enter. I do that with kaspersky all the time (i'm attempting to become certified with kaspersky's virus removal).

L.o.D.
05-17-2010, 12:26 PM
I need the printer to print off proof that there is a demand for people in the IT sector for my Second Career application. I need that to get funding for a Computer Networking & Security course which then allows me to write exams for 9 certifications.

Such as CompTIA A+ and Network+, Linux+, security+, MCSE/MCSA, MCDST, CIW Associate, CIW Security Analyst and Cisco CCNA.

rotNdude
05-17-2010, 12:33 PM
You folks are making me giggle. ;) I take them one thing at a time.

Back on topic. Have you tried the simplistic approach of rebooting? It may be the drivers need to initialize properly when the printer is turned on and plugged into the port when the OS loads.

L.o.D.
05-17-2010, 12:36 PM
His ears must have been ringing. LOL

Yes, I have tried that as well.
I am trying yet again & it's acting a bit different now.
Under devices & printers, the icon doesn't have an exclamation point on it and it's still listed as unspecified, even after installing the driver.

No yellow icons in device manager now either.
But I also don't see the printer listed there.

rotNdude
05-17-2010, 12:42 PM
Just install the driver, keep it installed and reboot, reboot, reboot. Don't uninstall the driver. Printer drivers will stay installed until they're actually needed and you can install many different drivers for printers. I know, it seems simplistic, but give it a go.

L.o.D.
05-17-2010, 12:45 PM
I ran the troubleshooter in devices & printers & it told me it cannot identify the problem.

Rebooted twice. No go.
Still nothing listed as a printer in device manager.

Wait, it's listed under universal serial bus controllers.

notavirus.exe
05-17-2010, 12:58 PM
hmm...you have another cord to try? or another computer/laptop to try?

L.o.D.
05-17-2010, 01:01 PM
No other cords.

EDIT: Finally got it.

I uninstalled the hardware from device manager.
Then uninstalled the software.
Installed the software and then unplugged & plugged it back in.
It finally installed as it should.

rotNdude
05-17-2010, 02:04 PM
Glad to see you got it solved. Older printers and Vista/Win7 can be a real pain. I have an HP Laserjet 1300 on our home network (connected with USB). It was always on the Vista computer and shared, but we were always having intermittent issues with the printer working from the other computers. I decided to move it from the Vista machine to an XP machine and share it from that computer. Every time I would try to connect from the Vista machine I would get an error regarding the driver not being correct. I tried everything I could possibly think of including permissions, mapped address, etc. It turns out I had to unistall the drivers from the Vista machine, reinstall the drivers with the printer plugged into the Vista machine, map the printer on a local port that had the IP address of the XP machine and then unplug the printer from the Vista machine and plug it back into the XP machine. That one took me a lot of time to solve.

notavirus.exe
05-17-2010, 02:05 PM
see all that help and you did it yourself...

I'll restate what I said before. I know this is aggravating.