PDA

View Full Version : Very eratic controls


JLMJ
05-23-2010, 06:58 AM
I bought the game yesterday. Now I'm noticing that the game is behaving very strangely. My ship fires when I'm not clicking, mouse steering randomly turns on and off, my thruster fires very often and not when I'm pressing a key. I think it was doing this from the beginning. At first I thought it was how the game played and since there was so much going on I didn't think much of it at first.

So to summarize.. I can spawn into the map and not press any keys or click the mouse and the ship will keep firing until it can't, thrust and mouse steering turns on and off erratically.

My system specs are: q9550 @ stock, ati 4870/512, Gigabyte P35 chipset motherboard, razer 'reclusa' keyboard, MS Intellimouse, Realtec sound driver 6.0.1.6083, Vista 32, newest ATI drivers.

I tried closing the Reclusa tray panel and terminating the process in task manager. No change. No other game I have exhibits this behavior.

Please help.

scraggles
05-23-2010, 07:49 AM
I had several issues with razer keyboards double clickng when I was typing. I would go to type like 'hello' and it came out as hheelllloo

pygmis
05-23-2010, 08:24 AM
Mouse steering comes on when you move your mouse. I had troubles starting the game when my pc tought my old joystick is still installed, do you have another controller on your pc that might interrupt the game?

JLMJ
05-23-2010, 08:46 AM
Mouse steering comes on when you move your mouse. I had troubles starting the game when my pc tought my old joystick is still installed, do you have another controller on your pc that might interrupt the game?

Oh yes I do have a gamepad installed but I disabled it in Altitude's controller options screen. I'll unplug and try again. Thanks for the reminder.

JLMJ
05-23-2010, 11:32 AM
Unplugging the gamepad made no difference. After playing some more I think I've figured out what is going on. If I have the mouse pointer far away, the thruster engages. Also, if I steer with the keyboard, the ship fires whenever the blue bar gets to max, I don't know why yet.

lamster
05-23-2010, 11:35 AM
For now you must use either the mouse or the keyboard to control your plane, hybrid mode is coming in a future patch. To disable mouse mode altogether you can press F1 (to open the console) then type
mouse false

T@F
05-23-2010, 12:59 PM
Hmm can we use a joypad?
Was just about to buy it but i'll wait for an answer now.

lamster
05-23-2010, 01:01 PM
Yes -- gamepads are a great way to play. If you want to see how it handles with your controller of choice please try the free weekend or demo.

T@F
05-23-2010, 01:49 PM
Cool did not bother with demo just bought it instead :D

Denton22
05-23-2010, 03:01 PM
well i use "hybrid" flying with the keyboard and shoot with the mouse.

To deactivate the mouse lock, just type mousecontrol false in the console