PDA

View Full Version : Game hangs at the beginning


KeljuIvan
06-04-2010, 11:05 AM
I can launch the game with no problem and navigate the main menu, but when I start a new game (any scenario or free play), nothing happens. The hour glass during the loading screen animates nicely and loading is completed, after which I only get a static picture of a port. I can see and move the cutlass cursor, but nothing happens no matter where I click or what key I press. I'm using Windows XP and ATI Radeon 4850. Any ideas how to fix this?

skullzyer
06-11-2010, 07:35 PM
Sorry, never had this kind of problem even on my older PC wih WinXP. Maybe you should update graphics drivers, verify game cache or just re-download it.

bajsurban
07-08-2010, 08:48 AM
I got the same problem. Ill try redownload, anything else i should do?

bajsurban
07-08-2010, 01:34 PM
i redownloaded and then i could play 2 games, but when started the third one i got the same thing. I did update my drivers and directX

Narkul
12-05-2010, 07:14 PM
Disabling steam community overlay in steam settings solved this for me.

pauliebowler
09-15-2011, 05:48 PM
I have the exact same problem. I tried reloading it, verified the cache, still nothing. :o

I have Windows Vista and a Nvidia GeForce 9500 GT.

Any ideas anyone?

pauliebowler
10-21-2011, 07:21 PM
After posting this, my friend notified me that he had a copy of Port Royale 1 that I should borrow. I installed the game, and now part 2 works..

Since the games are so similar the 2nd must have used a file from the 1st instead of whichever one was corrupt. Just a guess.