PDA

View Full Version : Crashing on startup


JedEx0dus
06-04-2010, 05:23 PM
I hadn't played this game in ages because the performance was a bit poo on my rig, but when I saw an update optimising the game for lower profile cards I started it up and got this

http://img109.imageshack.us/img109/8199/shatteredhorizon.png

Using an ATI Radeon HD 4550 and an Intel Q6600, latest drivers installed as well. Would be much obliged for anyone who can help me with this

TheIMightyHutch
06-04-2010, 05:28 PM
this is what happens to me too... THE EXACT SAME THING

LoganDougall
06-04-2010, 06:36 PM
crash logs are located:
C:\Users\YOURNAMEHERE\AppData\Local\Futuremark\Sha ttered Horizon\crash_dumps\

Could be useful info to help narrow down cause.

FM_Jarnis
06-04-2010, 08:23 PM
That crash can be solved by (re)installing latest PhysX system software from NVIDIA.com

Lahn
06-05-2010, 02:56 PM
That crash can be solved by (re)installing latest PhysX system software from NVIDIA.com

It did not work for me any one els got an idea on how to fix it?

FM_Jarnis
06-05-2010, 10:51 PM
It did not work for me any one els got an idea on how to fix it?

Well, without seeing what your crash dump looks like, can't say for sure.

StickyMicky200
06-06-2010, 02:41 AM
Umm thanks for that??

Installed the latest and greatest Physx file, game now runs less smooth, and crash still happens upon exit, exactly the same as before.

Application Crash: EXCEPTION_ACCESS_VIOLATION
shattered_horizon.exe build: 29

egg::remove: item name:
fm_online_caller
====== eva::log head BEGIN ======
pwnage::open_archives: 71 archive files found.
program_info: product:'Shattered Horizon', build:'29', exe:'shattered_horizon.exe', company:'Futuremark', exe version:1.2.1.29 , product version:1.2.1.29
program_info: directories: exe:'c:\program files (x86)\steam\steamapps\common\shattered_horizon\cli ent_exe', initial:'c:\program files (x86)\steam\steamapps\common\shattered_horizon', file_input:'c:\program files (x86)\steam\steamapps\common\shattered_horizon\dat a', local data:'C:/Users/M-O/AppData/Local/Futuremark/Shattered Horizon'
program_info: computer name:'M-O-PC', user name:'M-O'
thread_pool configuration: 1 threads per processor with processor mask 14, process mask 15, system mask 15, spin threshold 0, scheduling quantum 0
creating 3 threads
thread: setting affinity to 14; previous affinity was 15
thread: setting affinity to 14; previous affinity was 15
thread: setting affinity to 14; previous affinity was 15
thread_pool configuration: 1 threads per processor with processor mask 1, process mask 15, system mask 15, spin threshold 0, scheduling quantum 0
====== eva::log head END ======
====== eva::log tail BEGIN ======
fresh pool with block size:1024, free block count:0, total: 0 bytes
fresh pool with block size:2048, free block count:0, total: 0 bytes
fresh pool with block size:4096, free block count:0, total: 0 bytes
fresh pool with block size:8192, free block count:0, total: 0 bytes
fresh pool with block size:16384, free block count:0, total: 0 bytes
client_application::cleanup(): d3d10::scoped_thread_debug_acquire
client_application::cleanup(): Starting to clean egg
client_application::cleanup(): Cleaning up game_gui
client_application::cleanup(): Cleaning up egg
Wrote minidump to C:\Users\M-O\AppData\Local\Futuremark\Shattered Horizon\crash_dumps\crash_M-O-PC_2010-06-06 10_31_02_29.dmp
====== eva::log tail END ======
Shattered Horizon encountered a fatal error and will be terminated.

FM_Jarnis
06-06-2010, 02:55 AM
Crash on exit? Are you by any chance running Xfire, which is known to be incompatible with SH...

And for that less smooth thing, if you are running NVIDIA video card, suggest you turn off GPU PhysX in NVIDIA driver settings.

StickyMicky200
06-06-2010, 03:10 AM
So the updated physx drivers mean i have to switch off the physx setting before playing the game?

For what it is worth i did a system restore and removed the new physx stuff, and the gameplay smoothed out.

Yes i have Xfire running as well, will try without and report back.

FM_Jarnis
06-06-2010, 03:11 AM
The point is, PhysX (latest version) by default uses GPU for physics unless you disable that. Since 99% of the time SH is GPU limited, it is usually smoother if you use the spare CPU cycles for physics. I'd venture a guess that the latest PhysX + GPU PhysX disabled = best experience, but whatever you find working best.

StickyMicky200
06-06-2010, 03:13 AM
Without Xfire, closed as normal :)

Although with my old Physx installed, (09.09.0814)it has always been set to = enable