PDA

View Full Version : Fallout 2 not working on Windows 7


Roseveld
06-07-2010, 04:31 AM
Dear,

Fallout 2 is not wroking properly under windows 7.
Many colours are mixing in game, ingame icons, characters, texts and movies show various rainbow colours which makes it impossible to read. :confused: certainly when leveling your character.

Is there a way to fix this?

Goteki-45
06-07-2010, 11:56 AM
Off the top of my head, some older games have problems if your background is a slideshow, any time the wallpaper changes graphics will turn into pixelated rainbows.

I know I've had this issue in StarCraft and Quake 1, disabling the slideshow (one of the easiest methods for doing so is to just set the time between changing the image to one day and set it back afterward) will fix the issue, if this is what is causing it.

Also, you can try editing the shortcut to disable visual themes and desktop composition in the compatibility tab.

Roseveld
06-08-2010, 01:35 AM
Thank you for your reply.
But i have a static wallpaper, not using any slideshows in win7.

I will check to disable visual themes and desktop composition in the compatibility tab and will post result tomorrow

hermpes
06-08-2010, 04:48 PM
I have the same problem

i7
geforce gtx 260
4gb ram
Windows 7

StingingVelvet
06-08-2010, 07:32 PM
Either disable the desktop or alt-tab out of and back into the game once it's running... one of those should work.

Minchi
06-09-2010, 09:53 AM
Just get that fan patch that was mention on the new section and the game will work o3o

mrmotinjo
06-10-2010, 08:11 AM
Yes, that patch should fix it. I have my old CD version running smoothly under Win7 64bit.

Roseveld
06-11-2010, 03:45 PM
what patch??? please provide link!
Compatibility doesnt work steam doesnt allow it. :(

acare84
06-11-2010, 03:52 PM
Get Fallout 2 High Resolution patch this will fix your problem. Also if it won't try to turn of Aero and switch to Windows Classic theme.

For Fallout 2: http://www.nma-fallout.com/forum/dload.php?action=file&file_id=1295

For Fallout: http://www.nma-fallout.com/forum/dload.php?action=file&file_id=1273

Kenko87
06-11-2010, 03:56 PM
1.Go inte game preferences.
2.Press the button at the top of the computer screen saying "Scrn".
3.Activate Dx.9 thingamajig, choose resolution for your game.
4.Check the restart game button and press "Done".

Then it works fine on W7 for me.

Roseveld
06-15-2010, 12:15 PM
Patch doesnt work...
it says during installation I dont have the corerct fallout2.exe

which is the standard Steam one :(

MrSmit
06-16-2010, 02:36 PM
I had the same problem, for the colors fix just go to steamapps/common/fallout 2 and open ddraw.ini
search for [graphics] and below change "mode=0" to "mode=4" for fullscreen dx9 or "mode=5" for windowed dx9.
and the unofficial patch worked for me just install it to the correct path

Sephlyn
06-21-2010, 08:54 PM
Installing Killaps latest Restoration Pack will fix any issues you have with colouration since it comes included with the latest compatible version of Sfall (You may have to change your settings once though)
http://www.nma-fallout.com/forum/viewtopic.php?t=54328
First page download the main then the updates mentioned

gs2099
06-23-2010, 04:00 PM
I had the color corruption problem with Fallout and Fallout 2. Patches don't fix it (although they're worth getting for other issues)!

If you have color/graphical problems running the 'classic' Fallout games under windows 7 here's the only fix:

Right click on the desktop and click 'screen resolution'. Then just leave that window open and launch the game... No more color corruption!!!


Easy peasy. :cool:

McStalins
06-26-2010, 12:57 AM
Right click on the desktop and click 'screen resolution'. Then just leave that window open and launch the game... No more color corruption!!!


Easy peasy. :cool:
It does work! Many thanks!:D

Roseveld
07-29-2010, 08:38 AM
I had the color corruption problem with Fallout and Fallout 2. Patches don't fix it (although they're worth getting for other issues)!

If you have color/graphical problems running the 'classic' Fallout games under windows 7 here's the only fix:

Right click on the desktop and click 'screen resolution'. Then just leave that window open and launch the game... No more color corruption!!!


Easy peasy. :cool:

doesn't work :(

Roseveld
07-29-2010, 08:41 AM
I had the same problem, for the colors fix just go to steamapps/common/fallout 2 and open ddraw.ini
search for [graphics] and below change "mode=0" to "mode=4" for fullscreen dx9 or "mode=5" for windowed dx9.
and the unofficial patch worked for me just install it to the correct path

does this also work for fallout 1?

Drag0nZorD!
07-29-2010, 10:24 AM
Right click on the desktop and click 'screen resolution'. Then just leave that window open and launch the game... No more color corruption!!!


Easy peasy. :cool:

ROFL

it does work. many thanks.

drinkycrow
07-29-2010, 04:41 PM
I would have just said install windows 98 in a vm, but to each their own.

Sableye
07-31-2010, 01:24 PM
I had the same problem, for the colors fix just go to steamapps/common/fallout 2 and open ddraw.ini
search for [graphics] and below change "mode=0" to "mode=4" for fullscreen dx9 or "mode=5" for windowed dx9.
and the unofficial patch worked for me just install it to the correct path

I have the same glitch and this is the only fix that worked

Man Slaughter
09-09-2010, 05:31 PM
I had the same problem, for the colors fix just go to steamapps/common/fallout 2 and open ddraw.ini
search for [graphics] and below change "mode=0" to "mode=4" for fullscreen dx9 or "mode=5" for windowed dx9.
and the unofficial patch worked for me just install it to the correct path

thank you very much MrSmit, youre awesome!

i have win7 64bit and i had the same colour problem. after quitting the game to restart it, it completely crashed my system. It then continued to crash my system every time i tried to load it.

your fix that i quoted solved the problem :) once again youre awesome, thanks!

RStriker69
09-11-2010, 02:47 AM
I had this problem and non of the fixes worked perfectly. The mode 4 fix fixed the colors, but caused corruption in the movies. Eventually I found someone saying Aero in windows 7 was to blame for the color issue.

Following the guide here http://www.howtogeek.com/howto/windows-vista/disable-aero-on-windows-vista/ I changed my setting to windows classic and it completely fixed the color problem without distorting the movies. It's quick and easy to switch back and forth when I want to play. This works for both fallout 1 and 2. Hope it helps someone else.

Jito463
09-12-2010, 06:10 AM
You can set compatibility mode for the game, so it automatically disables Aero when you launch it. After the game closes, it will automatically revert back.

n33dforsp33d
09-12-2010, 02:35 PM
mode= 4 works for me. With this mode the subtitles in the movies go on and off very quickly?

RStriker69
09-13-2010, 07:48 PM
You can set compatibility mode for the game, so it automatically disables Aero when you launch it. After the game closes, it will automatically revert back.

Compatibility mode only worked with xp servicepack 2/3, but didn't do anything to fix the color issues. Any other compatibility modes caused a popup asking me to disable compatibility modes... :)

I had this problem and none of the fixes worked perfectly. I changed my setting to windows classic and it completely fixed the color problem without distorting the movies.

After further testing I found out it still causes the color issue with aero off, unless I have the screen resolution window open (right click desktop -> screen resolution). As long as both aero is off and the resolution window is open I've had a 100% success rate with colors and movies being normal after 50+ tests.

<Edit> Check this out (http://forums.steampowered.com/forums/showpost.php?p=13865793&postcount=19), it's quick, elegant, and gives you better graphics while fixing the colors and movies.

Dr. Bloodmoney
02-23-2011, 10:37 AM
Easy fix, download Sfall it will replace the ddraw.ini files with a new set which will end the colour corruption issue.

TheSkeeve
07-02-2012, 10:41 AM
I had the color corruption problem with Fallout and Fallout 2. Patches don't fix it (although they're worth getting for other issues)!

If you have color/graphical problems running the 'classic' Fallout games under windows 7 here's the only fix:

Right click on the desktop and click 'screen resolution'. Then just leave that window open and launch the game... No more color corruption!!!



This worked for me. Much thanks!

TheSkeeve
07-02-2012, 10:46 AM
... I alt tabbed out to type that message, and messed it up again. Now the screen reso thing won't work anymore either...

*edit*

Ran this patch and got everything working.

http://www.nma-fallout.com/forum/dload.php?action=file&file_id=1371