PDA

View Full Version : Game doesn't run anymore.


Iconoclast XVII
06-11-2010, 06:38 PM
I just got a new computer and redownloaded this game, but it won't run now. I get this error:
http://i145.photobucket.com/albums/r216/alex122790/SS/IGW-Error.png
Any ideas?

flava_clown
06-11-2010, 10:02 PM
since you give us absolutly no infos about your "new" computer i can only guess that you don't have any opengl driver for your graphic card installed. at least that is what i read out of the error message. you could try if a game like warsow works. http://www.warsow.net/

also check this: http://www.warsow.net/wiki/index.php?title=Troubleshooting

Error: “Failed to load opengl32.dll”

Make sure that you have the most recent drivers for your graphics card installed. They should be available on your manufacturer’s homepage. (Most common addresses to get some are NVIDIA and ATI.) If the problem persists, make sure you have a recent version of DirectX installed DX9.


Note: For a Intel graphic card (945GM for example), if you get this error, move your 3D settings to default values. It's known to work in several models.

Note 2: For ATI mobile cards - you can try http://www.driverheaven.net/modtool.php to install the latest catalist mobile drivers on your laptop if your laptop manufacterer doesn't supply newer drivers. In some cases, the shipped ATI driver doesn't include the OpenGL driver. I got this solved by downloading the latest catalist drivers, modify it with modtool (otherwise it refused to install) and ran the setup again. Worked perfectly.


If none of the previous worked, and you know your 3D card is able to run similar games, there is a problem with your Windows install. Reinstalling Windows will solve it. If don't want to reinstall Windows, and you're using win2000 or winXP you can try going to: System Properties(WinKey+Pause/Break)->Advanced->Evnironement Variables In System Variables, modify PATH... if %SYSTEMROOT% or %WINDIR% is properly set (to c:\windows or wherever your windows is installed), it would be best to use %SYSTEMROOT%\system32 (or %WINDIR%\system32 ) , otherwise c:\windows\system32 is fine if there are already other entries in PATH, you must add a semicolon ( before making an addition.

Iconoclast XVII
06-12-2010, 07:16 AM
Oh yeah, always forget the PC stuff...
Processor: AMD Athlon(tm) II X4 630 Processor (4 CPUs), ~2.8GHz
Memory: 4096MB RAM
Hard Drive: 1 TB
Video Card: NVIDIA GeForce 9800 GTX+
Operating System: Windows 7 Professional 64-bit

It's the same graphics card that was in my old one, I just moved it to this one, so I didn't think that was an issue...

flava_clown
06-12-2010, 07:52 AM
mmm... i still don't know if you have directx installed and the latest driver for your nvidia card. i also don't know if you have checked if there is an "opengl32.dll" in your system32 folder (dunno if the 64bit version of win7 could be the prob, i have only the 32bit installed)...
it's just another guess...

uninstall warlord (make a backup 1st so that you don't have to download it again)
close steam
now start steam as administrator
install warlord
run the game and see if it works

could be the reason even if the error message talks only about the opengl problem...

another question, do you use the config.cfg from your old pc? or a new one?
to know the actual desktop resolution could also help.

Iconoclast XVII
06-12-2010, 05:18 PM
Updated the drivers and it works now. Was going to try that earlier but the nvidia site was acting up for some reason.