PDA

View Full Version : Problem with Morrowind Graphics Extender


Benchee91
06-12-2010, 01:35 AM
Hey

I bought the Steam version of Morrowind yesterday.

After playing some hours I wanted to get better graphics so I installed MGE. But if I try to start MGEgui.exe the program says "Unable to find Morrowind registry keys. Please run the game before installing MGE"

I use MGE Version 3.8.2 rev. 0178, I changed the date of the BSA and ESM files to 2002 and 2003 (for Bloodmoon)and I also disabled the Ingame Steam thing. I have Direct X 9.0 c installed, also the Windows C++ thing.

I really don't know what the problem is, after hours of searching in the Internet I found no solution for my problem.

I have Windows 7 64 bit installed and I use the German version of the game.

Any idea what I could do to solve the problem?

jp_bl_68
06-12-2010, 03:54 AM
Which directory did you install mge in to; steamapps/common/morrowind or bethesdasoftware/morrowind? I think it needs to be in the first one.

If that's not the problem then I don't know what it could be.

Abnovitas
06-12-2010, 04:50 AM
Try using MGE 3.8.0 instead of the newest available version.
As far as I know there are issues with newer versions and Steam.

Benchee91
06-13-2010, 02:22 AM
Thank you for your suggestions.
Now it works, if I use the version 3.8.0 B

Ansive
11-18-2010, 03:27 AM
I just installed Morrowind today, along with the code patch, patch project, and MGE 3.8.2 revision 178.

I could not get MGE to run, kept complaining about the registry.
3.80 works, because it knows where to look, but 3.82 isn't as smart.

The problem is that when having UAC activated Morrowind will create the registry entries in another place (since it has no administrator rights)
[HKEY_CURRENT_USER\Software\Classes\VirtualStore\MA CHINE\SOFTWARE\Wow6432Node\Bethesda Softworks]

MGE 3.8.2 will not search there.

To create the registry entries in the proper place Morrowind needs to be started with UAC disabled.

The proper place is
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Bethesda Softworks]

And when I say disabled I really mean disabled, run as administrator will not work (at least it didn't for me). AND, you need to restart the PC or Morrowind.exe will continue to create the registry entries in the wrong place.

So basically if you get "Unable to find Morrowind registry keys. Please run the game before installing MGE", you need to:

1. disable UAC (user account control)
2. run regedit and delete the folder [HKEY_CURRENT_USER\Software\Classes\VirtualStore\MA CHINE\SOFTWARE\Wow6432Node\Bethesda Softworks]
3. restart
4. remove d3d8.dll, dinput8.dll and MGEgui.exe from the Morrowind install directory (..\Steam\steamapps\common\morrowind\)
5. start the game
6. copy the MGE files AGAIN
7. run MGE

If you are unwilling to stop using UAC, MGE 3.80 will have to do, at least until the newer version is smarter.

vtastek
12-12-2010, 02:04 PM
In x64 vista/7:

Right click,
Morrowind.exe
Morrowind Launcher.exe
Mgegui.exe

in their properties under compatibility tab
tick
always run as administrator.

This will make sure they are all looking at the exact same place for game settings etc. Changing install directory somewhere else than program files would also help.(moving/duplicating the folder will work.)

But to make sure the registry settings were created in the first place:
run Morrowind Launcher(as administrator) and set the game resolution back and forth to some temporary resolution(800x600). After that MGEgui will work so you can set new resolutions.

(Don't forget to redate the original data files to 2002.)
This information is accessible in the FAQ of official MGE thread over Bethesda.
http://forums.bethsoft.com/index.php?/topic/1135315-morrowind-graphics-extender-mge/

Happy gaming.