PDA

View Full Version : Doesn't launch!


Mikel_S
06-22-2010, 09:13 PM
I cannot launch this game. I just downloaded it after buying it last week (friday), but we lost internet for the weekend, so I had to wait to an hour ago to download it. Now when I go to play it, it simply brings up the "Launching Dead Space" steam box... Over... and over... and over... and over... and over... but it closes the previous one. No errors, no nothing. If I can't get it to work, I'll just go grab a backup from my sister (who also bought the game friday, and for whom it works fine), and restore it to my system, rather than wait another hour or two to download it...

isamuelson
06-22-2010, 10:08 PM
What anti-virus/firewall program are you using? You might have to add a rule in the firewall allowing Dead Space to have access. I have Avast Internet Security and that's what I had to do.

Mikel_S
06-23-2010, 03:49 AM
My computer is actually an internet-security/health success story. A year has gone since I purchased it, and I have never had any anti-virus on it, and I sent it to the local computer diagnostics place, early last week (had the week off) so he could run a comprehensive checkup on it... No viruses.

So the answer to that question is that there are no anti-viruses blocking it.

Boredom
06-23-2010, 04:35 AM
Try to execute the game / steam as administrator, with Vista.

Edit: sorry, I was giving this suggestion, and I was thinking in Mass Effect 1, which was a game I bought last week, also, and has that requirement for Vista users. But try, who knows?

Mikel_S
06-23-2010, 03:01 PM
Thanks for the suggestion, but by my own error, that doesn't help me; I forgot to mention I'm on Windows 7. And it works. Turns out the problem was that I lost internet for an extended period of time during download. Re-downloading it solved the problem.

MADDOGGE
06-23-2010, 03:24 PM
Honestly with the size of games these days the first thing I do before playing anything the first time is verify. It saves a lot of headaches.