PDA

View Full Version : DMC3 crash on new-game


nemesis519
06-24-2010, 04:01 PM
I'm having a crash whenever starting a new-game in DMC3. Main menu/options screen load fine as does the opening cinematic, but after hitting new game and selecting difficulty/tutorial a complete blue-screen occurs (BSOD):

A problem has been detected and windows has been shut down to prevent damage to your computer.....

Technical Information:
Stop 0x0000007F (0x00000000, 0x00000000, 0x00000000, 0x00000000)

Not too helpful. Nothing further to report in the event log. Anyone run into something similar or find a workaround?

Specs:
WIN XP SP3
Intel Core 2 Duo E6400
Nvidia 9600gt
Audigy 4 SE
2gb ram

I'll try emailing Capcom as well.

Side Note: I enjoyed and just finished DMC4, so figured I'd try out DMC3, but DMC3's not co-operating so far.

nemesis519
06-26-2010, 09:24 AM
I have a partial solution. I loaded up a PC savegame to get access to all levels. Levels 1, 6, 8 always crashed upon selecting them, but I could load into Bloody Palace, Level 2, 3, 4,5,7. I looked at some youtube videos and the game directories to see what levels 1, 6, 8 had in common.

Levels 1, 6, 8 seem to have a .mpg cinematic playing before the level begins. When the game tries to play an .mpg it crashes, even though oddly enough the beginning intro (prior to main menu loading) with the Capcom logo plays fine. But afterwards any .mpg crashes.

Also I noticed there was a game-over.mpg. I tried dying in level 2, and when you get the options "continue, retry mission, end". Continuing and retrying restart the level, but if I select 'end' the game crashes too. I imagine thats when the game-over.mpg plays? Can anyone confirm?

I can play all the .mpgs in windows media player but something seems to be preventing them from playing in the game. Anyone have any suggestions on how to overcome this? I tried replacing the mission 1 cinematic with the capcom logo .mpg, but that crashed the game too, even though the capcom logo always plays fine upon launching the game.

EDIT UPDATE: GuroP.mpg is the capcom intro logo .mpg that plays fine. If I replace that file with any of the other .mpgs the replaced .mpg will play upon the game launch no problem. However if I put GuroP.mpg to play as the mission 1 cinematic, game crashes. So the game seems to run some kind of process differently before playing the .mpgs during the levels, and its doing something differently upon game launch to play the intro. The .mpgs themselves seem fine, but something is messing up right before they launch during the missions.

nemesis519
06-26-2010, 08:37 PM
I seem to have solved my crash issue. Still testing to see if there are any other issues though. Deleting the .mpg's from the Steam\SteamApps\Common\Devil May Cry 3\Mov folder allows levels to load just fine (copy them to another location first as a back-up). Fortunately the cinematics are labeled m01, m02, etc. so you kind of know which mission they should play at and can watch them in media player if desired.