PDA

View Full Version : Game crashes immediately: Window 7 64 bit


Mejwell
06-27-2010, 06:34 PM
I bought this during the sale because I have many fond memories of it years ago. However, it will only run for about 30 seconds before meeting with graphics errors and stuttering before crashing completely. Mea culpa for buying before I knew it would work, but what gives? I'm running Windows 7 64 bit. Does anyone know how to get this game to a playable state?

Deozaan
07-02-2010, 07:36 PM
I'm in a similar boat as you. Just bought it again and it won't play very long before crashing. And even if it does take a long time before it crashes, it's so glitchy and jittery that it's hardly playable.

I'm also in Windows 7 64-bit. No information on the store page saying there are compatibility issues.

This game ran better on a computer I owned 6 years ago. . .

Alkpaz2
07-28-2010, 11:42 AM
Same issue as everyone else here. Win 7 64bit Ulti i7 975 stock GTX 295

Deozaan
07-31-2010, 12:00 AM
Well this is interesting. I just formatted and did a fresh install of Windows 7 (32-bit) and the game still crashes almost immediately when starting the campaign/tutorial.

What's really sad is that my netbook runs this game better than my gaming machine. :(

AMD Athlon64 3500+ (2.4Ghz)
Windows 7 Ultimate 32-bit
2GB RAM
nVidia 6800GTS

The Shoveler
08-06-2010, 12:31 PM
I saw a post on another forum that this was possibly due to nVidia cards under Win7. They suggested trying:

Go into Nvidia Control Panel Settings and under "Manage 3D Settings", enable or turn on "Extension Limit".

See if that helps.

Xile
08-24-2010, 03:00 PM
You all need to go to interplay website (www.interplay.com), then go support up top then customer service and fill in the form makeing them aware that the game they are selling on steam that you purchased does not run in Win7 and needs a patch.

Valve is just the seller, interplay is the only one that can fix it.


*If you set the graphic option to Lowest (instead of Insane) it seems it will run but it will look ugly.

Panimu
01-02-2011, 07:56 PM
Windows 7 64bit here, runs fine. ATI graphics tho.

Mejwell
01-25-2011, 06:09 PM
Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem!

1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.)
2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html
3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system.
4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.)
5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish
6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe)
7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment).
8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.)
9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice!

McSlashed
01-30-2011, 05:48 PM
Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem!

1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.)
2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html
3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system.
4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.)
5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish
6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe)
7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment).
8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.)
9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice!

I can attest that this solution fixed all my problems. Well, most of them. The game stops responding whenever I minimize to use the Steam chat, but other than that this solution worked wonders.

EDIT: It seems to only freeze while I am actually playing the game. If I'm in the menus I have no problem, but in the middle of the game it freezes every time.

aegix drakan
05-24-2011, 04:43 PM
Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem!

1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.)
2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html
3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system.
4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.)
5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish
6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe)
7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment).
8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.)
9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice!

Took a while, but this worked for me. Finally I can get down to slaying beasties.

Thanks!

ZeroTheHero
06-22-2011, 03:44 PM
Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem!
[...]

Great. This seems to have helped.

Thanks!

Khalaq
06-30-2011, 11:10 PM
HOORAY!!! I can finally play Sacrifice without it freezing up and crashing on me! )

Those of us who were running the GOG.com version of Sacrifice were having the same, exact problem. The posted fix noted above solved the problem and now we can play. Sacrifice is truly a classic game and it's wonderful to be able to play it, again. Hats off to Mejwell for bringing this to our attention. )

For the record, I'm running it (after the posted fix) on a quad-core pentium, Windows 7 Pro x64, Nvidia GTX 560ti.


-Khalaq