PDA

View Full Version : How to fix fallout 3 freezing and crashing (worked for me win7 64 bit)


Pages : [1] 2

Stoop!d Monkey
06-28-2010, 12:42 PM
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:

bUseThreadedAI=0

change it to:

bUseThreadedAI=1

Add another line after it and insert:

iNumHWThreads=2

This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

*If the game still crashes write this iNumHWThreads=1

EnJoY!!!

------------------------------------------------------------------------------------

Proof that it works:

You are the man ..... + Rep

I crashed everyt ime I went into a small house until I did this fix.

Windows 7 64 bit, Core I7 930 btw

could an Admin please sticky this? This actually works. I tried it out, and it has not crashed once. Considering how much people crash, it is a very useful piece of info.


I had been looking for a fix to this freezing issue for weeks. I finally gave up and started playing other games. Recently found this post. It is very easy to edit the file, and the game runs awesomely. Thank you very much for the post and I hope other people find your fix.

Crusher
MacBook Pro 15" Core i7
Windows 7 Ultimate x64
Steam's Fallout3 GOTY

This fix works for me in Vista too ^^

sweet:D

Strike_You
07-05-2010, 12:48 PM
You are the man ..... + Rep

I crashed everyt ime I went into a small house until I did this fix.

Windows 7 64 bit, Core I7 930 btw

Stoop!d Monkey
07-06-2010, 02:12 PM
:D you're welcome

RussianWolf
07-06-2010, 03:52 PM
Thank you so much. I've been looking for a fix forever. Would it work for vista 64bit?

RussianWolf
07-08-2010, 08:18 PM
could an Admin please sticky this? This actually works. I tried it out, and it has not crashed once. Considering how much people crash, it is a very useful piece of info.

Strike_You
07-09-2010, 12:46 PM
Thank you so much. I've been looking for a fix forever. Would it work for vista 64bit?

Yes, worked on my friends rig (Vista 64bit)

Stoop!d Monkey
07-11-2010, 12:28 AM
I'm glad that I solved your problems, but there is one thing annoying.
there are about 450 views and 4 comments - PLEASE COMMENT

Jito463
07-11-2010, 05:08 PM
Maybe, just maybe, not everyone has something to say. After all...

A) You're not the only one to have posted this

B) You're not the first one to have posted this

C) Maybe some of the people viewing this, didn't need the fix

tyce
07-15-2010, 09:44 AM
this works. pls sticky. kept freezing and i have win7 64bit ultimate with core i7. it was almost impossible to play. thank you genius monkey.

The Crusher
07-15-2010, 09:29 PM
I had been looking for a fix to this freezing issue for weeks. I finally gave up and started playing other games. Recently found this post. It is very easy to edit the file, and the game runs awesomely. Thank you very much for the post and I hope other people find your fix.

Crusher
MacBook Pro 15" Core i7
Windows 7 Ultimate x64
Steam's Fallout3 GOTY

Stoop!d Monkey
07-16-2010, 04:35 AM
NP! I'm gald that I could help! EnJoY this awsome game!

GoldenShadow
07-16-2010, 07:27 PM
Will this fix work on Oblivion since its the same engine? I have been playing that recently for the first time (on sale) and it crashes to desktop a lot.

ErrantConstruct
07-17-2010, 10:52 PM
Hmmm, when I went to fix this in mine the changes had already been made and it was still giving me framerate stutters and crashes. I guess its outrageous of me to expect a game I pay for to work reasonable well rather than be plagued by constant game crashes. I can't even get past the birthday party when starting a new game.

Chris_Ihao
07-18-2010, 05:31 AM
Hmm. When I had the exact same problems with FO3 crashing on my Win7 64-bit GTX280 setup, it actually turned out to be the gpu overheating with the stock cooler.

It was really difficult to pinpoint as it didnt happen in other games. I eventually installed a custom cooler, even overclocked the 280 quite a bit, and never had any freezing or crashing again.

Perhaps this fix of some reason additionally creates a lower load on the gpu, giving a greater margin before it goes poof? Just an observation.

Stoop!d Monkey
07-18-2010, 06:00 AM
Will this fix work on Oblivion since its the same engine? I have been playing that recently for the first time (on sale) and it crashes to desktop a lot.

You can try...

Spruu
07-18-2010, 11:43 AM
So you're limiting it to 2 threads, is this fix just for quad-core users? Anyone have any luck with this using a dual-core CPU?

I'll test it out tonight. I loved the game until it just started crashing left and right. I still "finished" it but skipped a lot and haven't touched any of the DLC's because of the problems I was having.

AKA Pseudonym
07-18-2010, 01:00 PM
Tried the above fixes but I'm still getting a lot of freezes. It's almost 100% interiors that seem to do it. I'm not sure I've ever froze up while outside. Uneven lighting also seem to be a factor. There are a few troublesome spots that I got through by looking at the floor, but that may have just been luck.

I'm running Windows 7 Home Premium Edition with an Intel i7 CPU. Graphics card is a GeForce GTX 260.

Strike_You
07-18-2010, 03:10 PM
Will this fix work on Oblivion since its the same engine? I have been playing that recently for the first time (on sale) and it crashes to desktop a lot.

What are you playing it on?

I have never had a crash to desktop (or any crash) with Oblivion so I would continue to look for another issue .. although it wouldnt hurt to try :)

ErrantConstruct
07-18-2010, 06:12 PM
I'm curious, how many people are having these freezing problems on Windows 7? I got a response to a support email I sent to Bethesda saying that the game wasn't tested for Windows 7 and there for not supported. Sure enough when I checked the Steam system requirements it only lists Vista and XP. It hadn't occurred to me that that might be the problem since its not that old a game. Thought I'd ask and see if the issues are simply an unsupported OS or if Bethesda is simply blowing smoke.

Strike_You
07-18-2010, 11:53 PM
I'm curious, how many people are having these freezing problems on Windows 7? I got a response to a support email I sent to Bethesda saying that the game wasn't tested for Windows 7 and there for not supported. Sure enough when I checked the Steam system requirements it only lists Vista and XP. It hadn't occurred to me that that might be the problem since its not that old a game. Thought I'd ask and see if the issues are simply an unsupported OS or if Bethesda is simply blowing smoke.

I am running on Windows 7 Pro 64bit w/ an i7. like many, when I went into a small house the game would freeze (sound still playing) .... the OP's ini edit fixed my problem which has to do with this game and quad core procs.

it could be a mix of Windows 7 and Quad Core procs unless someone has had this issue with Vista or XP .. in that case it would be safe to say its just quad core procs :)

HoodedMiracle
07-19-2010, 04:30 AM
I can't find it on mine. Any idea why?

Windows, 64-bit, all that. >_>

AKA Pseudonym
07-19-2010, 11:48 AM
I figured out what I was doing wrong. I was looking in the directory under the Steam folder. There are a few INIs in there for default, low, medium, and high settings. I was just editing them all and thinking I must be getting the right one somewhere. Then I looked under the MyDocuments/Games folder and found the right one. Works like a charm.

Stoop!d Monkey
07-19-2010, 11:50 AM
So you're limiting it to 2 threads, is this fix just for quad-core users? Anyone have any luck with this using a dual-core CPU?

I'll test it out tonight. I loved the game until it just started crashing left and right. I still "finished" it but skipped a lot and haven't touched any of the DLC's because of the problems I was having.

The problem is happens for quad core :p
The fix is limiting the game to use 2 cores only!

If you have dual core you need to limit it to 1 core.

Strike_You
07-19-2010, 02:29 PM
I can't find it on mine. Any idea why?

Windows, 64-bit, all that. >_>

Go to:


My documents - my games - fallout3 - "Fallout"

TecnoBacon
07-20-2010, 09:11 AM
The one thing that gave me the best performance and stability was to turn off the blur shaders, these cause blurring during movement and I have determined that the lag in the process causes instability in the physics thread which is why the cores seem to cause the prob.

in the fallout.ini file

under section
[BlurShader]

find
bUseBlurShader=1

change to
bUseBlurShader=0

Iron-Mike
07-20-2010, 05:03 PM
Does limiting the game to two 2 cores work in Vista 32-bit as well? Most of my crashes come from minimizing the game and then when I go to reopen it crashes or won't let me reopen.

wolfcoala
07-21-2010, 02:52 PM
This fix works for me in Vista too ^^

sweet:D

thekrow
07-22-2010, 05:11 PM
awesome thanks monkey dude seems to have fixed my random freezes! props for you my friend

Marillion
08-05-2010, 12:11 AM
My thanks also, after trying many many many things. When I made this modification "*If the game still crashes write this iNumHWThreads=1". That was what seems to have worked for me. Good stuff.

Edit: Sigh, I guess I spoke too soon. Didn't solve the crashing problem after all.

fisk0
08-06-2010, 07:07 AM
I don't know if this is at all related, but I tried playing the game on my Win Pro 7 64-bit machine with an Athlon II x3 3.0 Ghz processor (3 cores, I did not press the wrong key), ATI HD 4200 (integrated graphics), 4GB RAM, and the first time I start the launcher it works fine, auto-detects settings and stuff, if I then close it down and opens it again it will crash directly at start, and will keep doing that until I verify game cache, and then it will just repeat again - first auto-detect and work fine, and then crash on the next launch.



Edit: Oh, that issue seem to have been because I have two sound cards in my computer, and the one I had set as the default device is a soundcard made mainly for recording and sequencing music, not playing games. When I changed to the integrated sound chip, the Fallout 3 Launcher stopped crashing.
I haven't had any such issues with other games than this one though.

LightOfDarkness
08-09-2010, 03:10 PM
not 100% working, my Fallout 3 still crashes. Although not randomly.

Boscor99
08-14-2010, 08:27 PM
thanks alot! I believe this solved my freezing/crashing issue!

was happening while in megaton a few min after loggin in.

on Win XP btw.

EliteTemptation
08-14-2010, 09:12 PM
i haven't tested this, but today, i was randomly going on a shooting spree (just got the game on pc already had it on xbox) and as soon as i killed one guy the game just froze, is that considered a crash for what you're relating this too?

if so, i'm using core 2 quad @ win 7 x 64

please comment back, if i should still use 2 threads

RipperLord
08-15-2010, 12:08 AM
Nice!

Mods please sticky this thread. :)

KipperFlash
08-15-2010, 12:54 AM
can someone copy/paste the full .ini file contents, because for whatever reason the FALLOUT.INI file is empty - and I've re-installed plenty of times. so naturally, the game crashes on bootup.

thanks to anyone who can help.

PB-DK
08-15-2010, 02:18 AM
i tried this fix but my game still keeps crashing every time i try to use VATS

im using vista 64 on a 4 core rig

viking.dk
08-15-2010, 02:46 AM
Hey...

Fallout 3 crases when i go to game.. The upstart screem comes up. But then i hit play... It loads , and i here 3 sekends music. then windows show " the program frose of some reson "..I tryed the fix here. I diden`t help me... Upgraded my windows and grafic card... Nothing helps... I am getting desperat ! I have AMD phenom 11*4 CPU . Radion 5600 series grafic card (1GB dedicated) . 32 bit windows 7 ... Can anyone help me ??

exTOMex
08-15-2010, 09:25 AM
works perfect thanks alot

habitats
08-15-2010, 10:20 AM
Still crashes for me.

Cry0Tek
08-15-2010, 02:49 PM
So far this has fixed the problem for me, thanks a lot! Im running Windows 7 64-bit and I have a quad core cpu which I do believe is the issue. Thanks again!

Theegnome
08-16-2010, 12:46 AM
Nope... still crashes

ardsmuir
08-17-2010, 11:52 AM
Hey this needs to be a sticky, Fallout 3 is working perfectly for me now after trying every other fix for it i had given up on getting it working,also worked for my friends using a retail copy of the game as well with windows 7 running more then 2 cores.

I am running Windows 7 Ultimate Intel(R) Core(TM) i7 CPU duel ATI Radeon HD 5870 in crossfire with 12GB Ram

Thanks for the fix Stoop!d Monkey:cool:

Cry0Tek
08-17-2010, 01:01 PM
So far this has fixed the problem for me, thanks a lot! Im running Windows 7 64-bit and I have a quad core cpu which I do believe is the issue. Thanks again!

Update: So this worked for a solid 10 hours into the game and now I cant even load a file without the game crashing. I dont get it...$25 wasted. Thanks Bethesda & Steam

KarlMonster
08-17-2010, 08:47 PM
Sorry, but you're going to have to be much more specific about the new problem. Maybe start a new thread and post your system specs?

Its entirely possible that Windows 7 updated itself or an application was installed that affected codecs, or drivers, yada yada.

Cry0Tek
08-17-2010, 10:21 PM
Sorry, but you're going to have to be much more specific about the new problem. Maybe start a new thread and post your system specs?

Its entirely possible that Windows 7 updated itself or an application was installed that affected codecs, or drivers, yada yada.

Doubtful, nothing but MS Defender updates. I got it to work again after restarting my PC and re-validating the games files, even though they were fine. Could've been a glitch in Steam as it was giving me a hard time logging in for w/e reason.

alexplustm
08-20-2010, 01:11 PM
I still am having problems even getting pasted start new game. ]:

Marillion
08-20-2010, 01:20 PM
Well I finally found out the source of my own crashing woes (every 5-10 mins or less while I was playing). After trying innumerable fixes listed in this forum and elsewhere, it turns out when I released Fawkes as my follower the crashes stopped. I am now using Charon with no apparent ill effect after many hours of play.

Otaku_Son
08-24-2010, 05:12 AM
Nope, sorry. Did everything Stoop!d Monkey wrote, and still doesn't work.

http://www.youtube.com/watch?v=Hxc-L7hUZ-s

Got no mods, setting set to lowest...

sup299
08-25-2010, 08:17 PM
Awesome! it works! i was looking for a way to fix this eversince i got the goty edition!:D

sup299
08-25-2010, 08:19 PM
windows 7 64bit

Strike_You
08-26-2010, 12:11 AM
Nope, sorry. Did everything Stoop!d Monkey wrote, and still doesn't work.

http://www.youtube.com/watch?v=Hxc-L7hUZ-s

Got no mods, setting set to lowest...

At first I was like sweet my screen name is on youtube!!
Then I listen to you insulting Stoopid Monkey at the end...

You look and sound like a COMPLETE tool in that video. I hope you get flamed for it. judging by the way the game ran for you "set to lowest" as you stated above... the quad core ini fix not working is the LEAST of your problems.

Dont let this guy stop you from trying the fix, worked for me and MANY other people. Just google the it, or check out ther many other topics on this board talking about this fix.

BangBoomBang
08-26-2010, 01:04 AM
Ok after several hours of reading and testing I found a way to stop the CTD (every 5-10 min) and freezing on my PC and laptop (sorry if this was already posted before but i have little time and just wanted to spread the word because i am happy that FO3 finaly works for me).


Go check http://www.youtube.com/watch?v=MiZ2SPJab-Y and DL the DX9 dll File. Copy to your Fallout3 folder and play the game.

since this "fix" my game runs smooth without any CTD etc.

Maybe this helps some people out there :) If so, maybe OP can copy this on the first page

see you in the wastelands !

StarscreamSWE
08-26-2010, 01:30 AM
Worked fine for me!
THX Stoop!d Monkey!

Otaku_Son
08-26-2010, 05:06 AM
At first I was like sweet my screen name is on youtube!!
Then I listen to you insulting Stoopid Monkey at the end...

You look and sound like a COMPLETE tool in that video. I hope you get flamed for it. judging by the way the game ran for you "set to lowest" as you stated above... the quad core ini fix not working is the LEAST of your problems.

Dont let this guy stop you from trying the fix, worked for me and MANY other people. Just google the it, or check out ther many other topics on this board talking about this fix.Oh, please elaborate more about how I "look and sound like a COMPLETE tool in that video." I followed the instructions, game still freezes. Additionally, what does SnagIt's video capture settings have to do with my quad core ini fix? (pro-tip: my game does not look that craptacular)

Sorry; what?

Nightzirk
09-05-2010, 09:05 PM
Dear Stoop!d Monkey.
You Sir, are a scholar and a saint. May your life be long and your endeavours in life prove fruitful.

Yours truly
The entire gaming community.

antecthinking
09-12-2010, 08:18 PM
How in the fahk did you figure this out!! its working, for the love of Jeebus its working!!! Thank you sexy man/woman!!

eyrarco
09-19-2010, 08:57 AM
Dear Stoop!d Monkey.
Your solution makes my Fallout 3 Goty run on W7/-32, impossible before,many, many,thanks!
Some Crashes whith Training from time to time.="Windows Live"

asurani
09-19-2010, 11:34 PM
WORKED FOR ME!!!!
and i have Intel Core i5
Windows 7 Ultimate 64 Bit

intrepid767
09-20-2010, 05:44 AM
This did not work for my Win7 64-bit machine.. but I have a dual monitor setup.

Log Name: Application
Source: Application Error
Date: 9/20/2010 8:41:36 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Jon-PC
Description:
Faulting application name: Fallout3.exe, version: 1.7.0.3, time stamp: 0x4a40f18b
Faulting module name: Fallout3.exe, version: 1.7.0.3, time stamp: 0x4a40f18b
Exception code: 0xc0000005
Fault offset: 0x00227180
Faulting process id: 0x6dc
Faulting application start time: 0x01cb58c11bed4bf7
Faulting application path: c:\program files (x86)\steam\steamapps\common\fallout 3 goty\Fallout3.exe
Faulting module path: c:\program files (x86)\steam\steamapps\common\fallout 3 goty\Fallout3.exe
Report Id: 6764f3b6-c4b4-11df-9e97-00241d769cfb
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2010-09-20T12:41:36.000000000Z" />
<EventRecordID>18806</EventRecordID>
<Channel>Application</Channel>
<Computer>Jon-PC</Computer>
<Security />
</System>
<EventData>
<Data>Fallout3.exe</Data>
<Data>1.7.0.3</Data>
<Data>4a40f18b</Data>
<Data>Fallout3.exe</Data>
<Data>1.7.0.3</Data>
<Data>4a40f18b</Data>
<Data>c0000005</Data>
<Data>00227180</Data>
<Data>6dc</Data>
<Data>01cb58c11bed4bf7</Data>
<Data>c:\program files (x86)\steam\steamapps\common\fallout 3 goty\Fallout3.exe</Data>
<Data>c:\program files (x86)\steam\steamapps\common\fallout 3 goty\Fallout3.exe</Data>
<Data>6764f3b6-c4b4-11df-9e97-00241d769cfb</Data>
</EventData>
</Event>

turn off the 2nd monitor is the solution in my case.

Deltawarrior367
09-21-2010, 11:51 AM
I've got to say that at first I thought that your posting was just another bs guy trying to sound smart when he had no idea what he was doing but your suggestion really worked. Thank you so much Fallout 3 is my favorite game and I can finally play it again.

Animositisomina
09-21-2010, 03:20 PM
Tried both iNumHWThreads set to 1 and 2. Neither worked; the game still randomly crashes from time to time.

Premo_Maggot
09-25-2010, 03:26 PM
thanks!

mod, sticky this.

JKflipflop
09-27-2010, 12:27 PM
I wasnt having any crashes, but I did get some stuttering from time to time. There are quite a few threading stwitches in the INI file I didnt know about until I read this and went looking. Some other advanced graphics options that make it look even prettier as well. Thanks.

deadboldt
09-30-2010, 02:19 PM
Thank you so much. The crashing/freezing problems that I was having are finally fixed. I am running Vista 64-bit.

Raxzor
10-07-2010, 02:57 AM
Thanks it worked for me to. Before I couldnt go 5 mins in game without a crash been playing now for over a hour with no problems.

Update: I did get a crash when I went into Vault 112. But the game was playable for 3 hours without a crash, also I am modded up to the eyeballs (hires textures, weather cycles, remodeled people etc...) so a mod could have caused a crash.

Still much better than before.

joshualwilliams
10-09-2010, 10:25 AM
I reformated my computer, got all the latest drivers, changed my .ini file as instructed and fallout3.exe still goes into non responding status periodically. Sometimes after 3 minutes, some times after 20. Here's what I see in the event logs on my machine.

AMD 3.0 4x 945
Nvidia GTX 470
4GB's of 1266mhz Ram
(3) 80GB's in Raid 0
Windows 7 Home 64

video and sound drivers are current, and all firmware is up to date.


The program Fallout3.exe version 1.7.0.3 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: e4c
Start Time: 01cb67d1ff7694b8
Termination Time: 203
Application Path: c:\program files (x86)\steam\steamapps\common\fallout 3\Fallout3.exe
Report Id:


incidentally, I also get it for the launcher.

The program FalloutLauncher.exe version 1.1.12.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: cd8
Start Time: 01cb67d29824d4d9
Termination Time: 1
Application Path: c:\program files (x86)\steam\steamapps\common\fallout 3\FalloutLauncher.exe
Report Id: b37ee595-d3c6-11df-b9e0-406186f2a103


no mods or changes to start. I also have 2 copies of this, one is the GOTY edition from steam, and the other is the Vanilla version with the DLC purchased from (ugh) GFWL. Same scenario in both respects.

Animositisomina
10-09-2010, 12:38 PM
no mods or changes to start. I also have 2 copies of this, one is the GOTY edition from steam, and the other is the Vanilla version with the DLC purchased from (ugh) GFWL. Same scenario in both respects.

GFWL has been known to cause crashes with this game. Try this: Games for Windows LIVE Disabler (http://www.fallout3nexus.com/downloads/file.php?id=1086).

joshualwilliams
10-09-2010, 01:41 PM
GFWL has been known to cause crashes with this game. Try this: Games for Windows LIVE Disabler (http://www.fallout3nexus.com/downloads/file.php?id=1086).

It's worth a shot, I'll try it right now.

joshualwilliams
10-09-2010, 01:50 PM
No dice...

This time, instead of locking up and going in to "not responding" and forcing me to ctl alt del to get the program shutdown, it just hard "not responds." and goes to the desktop after the error message. More graceful than before, but it still happens.

However, I enabled the MAD Filter Radio Stutter Fix, and looks like it's related to that. I'll disable it and then test again.

Faulting application name: Fallout3.exe, version: 1.7.0.3, time stamp: 0x4a40f18b
Faulting module name: MADFilter.ax, version: 1.0.0.3, time stamp: 0x3f53bb41
Exception code: 0xc0000005
Fault offset: 0x0000212d
Faulting process id: 0xbb4
Faulting application start time: 0x01cb67f2706d3e33
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\fallout 3\Fallout3.exe
Faulting module path: D:\0-Mods & Patches\Fallout 3\Radio Stutter Fix\New folder\MADFilter.ax
Report Id: 28c68933-d3e6-11df-abbd-406186f2a103

joshualwilliams
10-09-2010, 02:15 PM
wow I actually got 15 minutes where it wasn't crashing. Good fix, but i believe it or not am going to miss my achievements...I wonder if GFW has a fix that I can use that won't disable their platform. This explains why new vegas doesn't have GFWL support...

Animositisomina
10-09-2010, 02:42 PM
wow I actually got 15 minutes where it wasn't crashing. Good fix, but i believe it or not am going to miss my achievements...I wonder if GFW has a fix that I can use that won't disable their platform. This explains why new vegas doesn't have GFWL support...

You can use the disabler to re-enable GFWL, if you want achievement support restored. But then come the crashes and other wonderful bugs caused by GFWL.

bazerka250
10-12-2010, 03:46 PM
I'm glad that I solved your problems, but there is one thing annoying.
there are about 450 views and 4 comments - PLEASE COMMENT

Thank you,Thank you, Thank you
My fallout goty wouldn't play for more than 5 minutes without freezing and becoming unplayable at all.I have a Asus laptop,Windows 7 and I5 processor.After trying everything else and almost giving up I found this.I played last night for A hour with no problems.The same gam played on my old laptop so I knew it wasn't the disc.You are the best.I really appreciate it.

joshualwilliams
10-14-2010, 05:00 PM
You can use the disabler to re-enable GFWL, if you want achievement support restored. But then come the crashes and other wonderful bugs caused by GFWL.


Well my glimmer of hope has been snuffed out. Received the error again after disabling GFWL.

The program Fallout3.exe version 1.7.0.3 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: 920
Start Time: 01cb6bfb03098bcf
Termination Time: 266
Application Path: C:\Program Files (x86)\Steam\steamapps\common\fallout 3 goty\Fallout3.exe
Report Id:

joshualwilliams
10-15-2010, 04:49 AM
bethsoft.tech@aqinc.com to me
show details 8:43 PM (11 hours ago)
Hello,



Please note that the program is not tested or supported in Windows 7. You *may* be able to run the program using compatibility mode in Windows 7, but we cannot guarantee the program will function properly in this new operating system.

Program compatibility is a mode in Windows that lets you run programs written for earlier versions of Windows. Most programs written for Windows XP also work in this version of Windows, but some older programs might run poorly or not run at all. If an older program doesn't run correctly, start the Program Compatibility Wizard to simulate earlier versions of Windows.

To change compatibility settings for a program:

NOTE: Do not use the Program Compatibility Wizard on older antivirus programs, disk utilities, or other system programs, because it might cause data loss or create a security risk.

NOTE: If the Compatibility options are grayed out, then it is a 64 bit program and cannot be changed.

1. Right-click the icon for the program.
2. Click Properties.
3. Click the Compatibility tab.
4. Check the box "Run this program in compatibility mode".
5. Choose the version of Windows the program was made for. For best compatibility, choose the latest Windows version the program was written for. Check the system requirements for the program if you are not sure.
6. It may also be necessary to check the box for "Run this program as an administrator."
7. Click Apply and OK.

Your customer number is 400577636
Please refer to case #:: 401421452 if you have any further questions.

If you need further assistance, you can also reach us online at http://support.bethsoft.com or our technical support staff at (410)-568-3685. Please include all previous replies when/if responding to this message.

Best Regards,
Shonte B. at Bethesda Softworks Technical Support
support04@bethsoft.com

-----------------------
I get this error after the game hang's and freezes. Have to
Alt-Tab out and end the task. CPU is a AMD Deneb x4 Processor. I'm running
Windows 7 64. Tried a variety of things including disabling GFWL and
nothing seems to be working. My video and audio drivers are the latest and
i've updated all of my firmware. Also tried forcing the game to use 1
core, rather than 2, and it doesn't seem to help me either. Here's what I
see in my application event logs.

The program Fallout3.exe version 1.7.0.3 stopped interacting with Windows
and was closed. To see if more information about the problem is available,
check the problem history in the Action Center control panel.
Process ID: 920
Start Time: 01cb6bfb03098bcf
Termination Time: 266
Application Path: C:\Program Files (x86)\Steam\steamapps\common\fallout 3
goty\Fallout3.exe
Report Id:

Direct X is ver 11. Background applications are none, i've disabled
everything to eliminate any possible issues.
Country::USA

Dante2015
10-16-2010, 03:43 AM
I bought the GOTY edition when it was on sale on steam, I loaded it up, then ran it and...it crashed, every time, just after opening the play pen right at the beginning of the game! This has fixed that problem! so thank you very much!

steveconygre
10-16-2010, 10:44 AM
Hi I hope someone can help me? I'm running F3:GOTY and my game crashes after about 5 minutes of play. No graphical glitches or anything, it just stops working (although the sound continues).

I think maybe running it in compatibility mode might help? Now for my stupid question, how do I actually do this? I can't find it in my list of programs when I run the Windows compatibility wizard. If someone can take pity that would be great.

EDIT: Running it on steam.

steveconygre
10-16-2010, 05:28 PM
Well, I edited the ini file as per the instructions and although it hasn't fixed it completely it was a massive help, I managed to run it for a good hour before crashing, but the Autosave means it wasn't too much of a problem.

1N54N3
10-17-2010, 12:14 AM
What I really can't believe is that Bethesda hasn't fixed this dumb bug yet. They're usually more on top of things like this, but I suppose they're too busy watching Obsidian screw up another game to care about FO3 anymore :eek:

joshualwilliams
10-19-2010, 04:31 AM
What I really can't believe is that Bethesda hasn't fixed this dumb bug yet. They're usually more on top of things like this, but I suppose they're too busy watching Obsidian screw up another game to care about FO3 anymore :eek:

Normally you would be right about this. But New Vegas is awesome. AND Obsidian isn't that bad. The only real fail they had was KOTOR2 and that was because of pressures from Lucasarts. I've liked everything they put out. Neverwinter Nights 2, Alpha Protocol. Too bad I have to work today... Got two hours in from 5am-7am though...

joshualwilliams
10-19-2010, 04:37 AM
Can someone explain the logic of posting "it works fine for me" on a forum thread where people are experiencing the problem? That doesn't help anyone get their issues resolved. UNLESS you have the EXACT system specs as some of the people who are having the issues, right down to mobo and firmware, how does this help? Just asking. :)

derpburp
10-19-2010, 06:38 PM
I'm trying to do this with NV and I can't save it as it is only a read file. Can anyone help?

PhamousVegas
10-19-2010, 07:08 PM
I'm trying to do this with NV and I can't save it as it is only a read file. Can anyone help?

Right Click It -> Properties -> Uncheck Read Only -> Click Apply
Edit it
Recheck Read Only

WraithGear
10-20-2010, 08:55 PM
This didn't work for me, but I was able to fix it. I have windows 7 x64. Going to the Fallout3.exe in [C:\Program Files (x86)\Steam\steamapps\common\fallout 3 goty] and right clicking it, then selected properties. In that window I selected the Compatibility tab and checked [Disable visual themes] and [Disable desktop composition].

its not that my system should have problems running this game at all with my rig, but its just something with Windows Aero i guess. \

corwyn77
10-20-2010, 11:23 PM
Normally you would be right about this. But New Vegas is awesome. AND Obsidian isn't that bad. The only real fail they had was KOTOR2 and that was because of pressures from Lucasarts. I've liked everything they put out. ...Alpha Protocol.

Hmmph. Speaking of games which are hit or miss for some systems. I'm still waiting for a fix for the mouse smoothing problem. Workarounds don't work for everyone.

corwyn77
10-20-2010, 11:29 PM
Having problems with FO3 recently as well.

Crashing on startup. I get to main menu and try to load or start new game; goes to black screen window and "Fallout 3 has stopped working." I tried the fix at the beginning of this thread, tried using Task Manager to set up a single core to run it.

Windows 7, 64 bit
Core 2, 2.8 gb
ati 5770

It may be something with the video card. I'm pretty sure I had it working on 7 previously, possibly even through steam. Not much has changed on my system otherwise since I last remember running it. Latest drivers, etc.

Edit: Never mind, I double checked the video drivers and it's working again.

Scribbles
11-14-2010, 04:32 PM
Appears to have fixed me, was able to revisit a couple areas where I crashed so hard it was all I could do to leave again. Too bad I didn't see this until now, would have saved a ton of frustration. Vote to sticky +1.

(Windows 7 64bit, AMD Phenom II x4, ATI Radeon HD4870)

Stoop!d Monkey
12-27-2010, 09:25 PM
-BUMP-

I saw in the forum that more people are having this problem.
Admins, please sticky this so everyone can see.

AWAX
12-28-2010, 05:05 PM
I've tried the fix that the original poster described. So far I've only had one crash after about 3 hours of gameplay, so marked improvement. I haven't tried tinkering with turning the display to Windows 7 Basic, or the autosaves, but I might try that if I get another lock.

Hopeless Savage
12-29-2010, 08:48 AM
I figured out what I was doing wrong. I was looking in the directory under the Steam folder. There are a few INIs in there for default, low, medium, and high settings. I was just editing them all and thinking I must be getting the right one somewhere. Then I looked under the MyDocuments/Games folder and found the right one. Works like a charm.

Thanks very much for pointing this out, AKA Pseudonym. I too failed to read the directions properly, and so lost a lot of time chasing solutions to the problem. The key is changing FALLOUT.ini in My Documents\My Games\Fallout 3. After that, I was able to run the game on normal settings, without using compatibility mode or anything similar.

For the curious, here are my system settings:

Fallout 3: GOTY edition, purchased through Steam.
Windows 7 Professional, 64-bit edition
Lenovo 510e
Intel Core i7, 2.67 GHz
4GB RAM
1600x900 display
NVidia Quadro NVS 3100M Graphics card (512 MB)
NVidia driver 260.99

AWAX
12-30-2010, 06:11 AM
Update,

Played for about 6 hours now, and no crash or stuttering. Change the .ini and disabled autosaves. Seemed to do the trick. Awesome game so far, one of the best I've ever played.

Thanks for all the help!

iKai
12-30-2010, 10:31 AM
The problem is happens for quad core :p
The fix is limiting the game to use 2 cores only!

If you have dual core you need to limit it to 1 core.

So....what about a 6 core?

Hategull
01-02-2011, 11:12 AM
Just wanted to post and say thanks, Monkey. Just bought this game not too long ago and it kept crashing immediately after the intro video when I tried to start a new game. Doing this fixed it.

KarlMonster
01-02-2011, 12:22 PM
iki - 4 cores, 6 cores, "...this goes to 11" ... same thing

All this fix does is add a little code to let the game engine know how to handle a multi-core environment, since the engine for FO3 (and Elder Scrolls: Oblivion) was written long before anyone was dreaming about multiple CPU cores.

NitrousX
01-04-2011, 07:58 AM
I installed this game yesterday and it seems like it crashes every 5-10 minutes. I applied this quick fix and the crashes went way.

i7 860, 4GB RAM, 5870 CF, Windows 7 x64

Edit: Crashes every 30-45 minutes with HWThreads set to 2. Will try again tonight with HWThreads set to 1.

Mr_Static
01-05-2011, 06:58 PM
Doesn't work on my system I have Win 7, running amd and none of the fixes suggested work. Everytime I try to start a new game it begins to load gets to the bottom of the loading circle then crashes and freezes my computer. I looked for the compatibility tab and there is no such tab.

Hive Mind
01-11-2011, 03:11 PM
Worked like a charm. This should be stickied. Have some rep.

Vaines
01-12-2011, 01:31 PM
This worked perfectly, even for my system which has a "fake quadcore" (two are simulated). :) +Rep ^^

androsath
01-16-2011, 03:20 AM
Maybe, just maybe, not everyone has something to say. After all...

A) You're not the only one to have posted this

B) You're not the first one to have posted this

C) Maybe some of the people viewing this, didn't need the fix

D) you jito are an utter asshat >_> I have had issues and sadly this didnt alleviate them but he was the first to post this particular fix in an easy to read and use format from what I have seen so Kudos OP.

Stink you wouldnt happen to know of a fix for the New Game crash error where it starts loading but never makes it into the game itself before going black and popping a "Fallout 3 GOTY has stopped working" thing do you?

I am using vista 32bit and tried everything I could find to no avail even killing this HDD by mistake and having to reformat >_<

SapphireBullets
01-16-2011, 12:32 PM
I'm still getting occasional crashes despite:

-The OP's fix.
-Official Patch
-Unofficial Patch (http://www.fallout3nexus.com/downloads/file.php?id=3808)
-Buying a PC with more than sufficient specs to run Fallout NV, since I knew I'd want to play it at some point.

Most often in small areas like shacks and little shops, but occasionally upon exiting areas while the new one loads.

Occasionally in other situations too.

bazerka250
01-16-2011, 11:32 PM
-BUMP-

I saw in the forum that more people are having this problem.
Admins, please sticky this so everyone can see.

I used your advice for F3 and I went from a unplayable game to no problems in 30 hours of gameplay.I stopped playing NV to play F3.I see people are trying this fix for NV.I know they both run on the same engine but I thought the difference was F3 wasn't meant to be run on windows 7 but NV was.I needed this fix for F3 but not NV.I can play NV but ometimes the game freezes and I get the Fallout New Vegas stopped working as well as all the other bugs everyone else seemed to have.Stoopidmonkey thnks again and I came here to get this solution for someone on a amazon site.This game is good if you can get it to run.

Toa_Vine
01-17-2011, 06:54 AM
Can someone help? Which file is it? I Have 4 different ones. One for each graphical setting.

Toa_Vine
01-17-2011, 06:59 AM
Wait, found it. How far down are the specific lines?

SapphireBullets
01-17-2011, 11:12 AM
Wait, found it. How far down are the specific lines?

Try using Ctrl-F to search for the lines you need to change.

Toa_Vine
01-17-2011, 12:42 PM
Umm, how do i save it? It won't let me.

Toa_Vine
01-17-2011, 03:21 PM
Can anyone tell me how to save the file?

KieranMitchell
01-17-2011, 11:13 PM
The file is probably read-only, so rightclick it and unclick Read-Only. Then youll be able to save the changes. But just like Sapphirebullets, Im having the exact same problems after installing the unofficial patch, entering the changes in the text files and every other so-called fix method under the sun.

♥♥♥♥ing engine! What on earth led them to believe this was a bulletproof engine with no bugs?? What were they testing it on, Skynet?

MattyDienhoff
01-18-2011, 10:01 PM
This solved my problem. Thanks a lot OP!

avp2501
01-21-2011, 05:13 PM
Quad core on vista 64. adding the inum to 2 threads worked a treat cheers.

DblDamage
01-23-2011, 07:26 AM
This also worked for me. Running Windows 7 64 bit, i7 quad core.

Uthboth
02-06-2011, 06:57 PM
Great fix, no more crashing for me. I was crashing about every 30 min, have been running for several hours now with no crashes. +rep for you. :D

P.S. Could a mod please sticky this thread.

CaptainScramble
02-17-2011, 12:10 AM
This didn't work for me unfortunately :(

Win 7 Pro 64-bit i7 860

Herah
02-23-2011, 08:35 PM
Bought Fallout 3 on Steam, as most here have. Was originally running it on a Core 2 Duo with Win 7 64bit without issue (15+ total hrs without a freeze.) New computer, that was finished last week, was freezing every 20-30 min in FO3. Stumbled everywhere trying to find a solution, until seeing this post of the forum.
Once the INI file was edited I started the game back up and viola! Since most of my issues were while I was in combat and outdoors I tested it out using all weapons available to me at the time, as well as blowing myself up on a landmine.:eek:
Thanks to Stoop!d Monkey:D

Win7 Ultimate 64bit
i7 950
GeForce GTX 570 Superclocked

John1986
03-14-2011, 05:53 PM
just tried this myself and i still crash even after a fresh install of this game on steam

incrosshairs
03-14-2011, 08:19 PM
Didn't work for me. As it seems with others with this problem, the real solution to this would be for the game maker to put together a new update (would have thought by now it would be out seeing as so many people have this problem).

I did not have this problem until recently. I have played the full game without crashes, and I have been playing off one of my old saves so I could explore more and play the DLC's. I don't remember this happening until steam's recent big update.

John1986
03-15-2011, 03:42 PM
Didn't work for me. As it seems with others with this problem, the real solution to this would be for the game maker to put together a new update (would have thought by now it would be out seeing as so many people have this problem).

I did not have this problem until recently. I have played the full game without crashes, and I have been playing off one of my old saves so I could explore more and play the DLC's. I don't remember this happening until steam's recent big update.

yep that's how it was for me as well everything worked good for me till they did something now i can't even play the game at the beginning because it crashes everytime it starts a new game for me

Muti Messiah
03-21-2011, 03:00 AM
Works for me

Vista x64 Ultimate, Core 2 Quad 3.2ghz, 8GB Ram, HD4870

OldboyAshton
04-12-2011, 12:59 AM
I'd also like to report that this worked for me, too! Since doing this my game hasn't froze once, which is amazing considering it used to freeze every half hour.

riep2501
04-18-2011, 12:19 PM
ThX to stoop!dmonkey
for those who can't fix it
don't forget to go in FALLOUT.INI (caps) no fallout.default.ini

exanji
04-22-2011, 09:54 PM
Thank you SO much!
This post should be stickied, I'm not sure why it isn't yet, it seems like a lot of people had the same problem as I did.

Also, this solved my problem, it stopped crashing completely, but it was still very laggy. If anyone else has the same problem, when I switched to windowed mode, the lag stopped completely. I can finaly enjoy this great game!
:)

Agegamon
04-24-2011, 09:14 PM
Thanks for the big, easy to find five star on the forum page. STICKY THIS!!!
Also, +Rep man!

This fixes about 95% of all my black screen freezes. FALLOUT.INI and fallout.default.ini are respective to Fallout 3 and Fallout 3 GOTY, so just change whichever one you have.

This should have been patched into the game AGES ago. Perhaps Bethesda isn't perfect after all!

Poly101
04-26-2011, 04:30 AM
So i, like many others still couldnt get this working.
(Im using windows7 64bit, core2duo)

I reinstalled.
I verified the game integrity.
I did the core fix (even though i only have a core2duo)
I removed the SMainMenuIntro stuff, and the video file from the data
I ran it as administrator
I tried it on all sorts of compatibility modes.



Finally, last night i removed it and let steam redownload / re-install it.

This morning i tried to run it, got the same error (start the game, it detects my settings, click play new game, black screen, it crashes).
I did the .dll fix described in this video - http://www.youtube.com/watch?v=c47UXdfWA7s , and the SMainMenuIntro deletion in the latter part of it.

It still didnt work (although it might of enabled the next part to).


The Fix i got worked was -

Launch the Fallout3 launcher (just run it through steam), go to options - now make sure you have the ingame resolution to be set at your desktop resolution (im running 1280x1024, but for some reason it was setting it to 800x600) - i did that and it worked!

Wierdly, i have a nvidia 460 graphics card, and even after reinstalling its still using my old nividia 7900 graphics adapter (the dropdown box above resolution) - any ideas?

icer22x
04-27-2011, 03:13 PM
ATTENTION WIN 7 x64 users:

Just wanted to let you guys know what I've done in relation to the crashing issue. I haven't had a freeze or a lockup so far (knock on wood):

The fix from the OP did not work for me, but I still have it enabled. I am going to disable and see if it makes a difference. But after trying this fix I downloaded the d3d9.dll file and disabled visual themes and desktop composition under the Properties -> Compatibility tab when you right click on your fallout3.exe file.

The only mod I have installed is the stutter fixer (doesn't really help).

Hope this helps for you guys. Maybe it's just the conjunction of all those fixes that got it running stable for me. Good luck.

iKai
04-28-2011, 10:27 PM
ATTENTION WIN 7 x64 users:

Just wanted to let you guys know what I've done in relation to the crashing issue. I haven't had a freeze or a lockup so far (knock on wood):

The fix from the OP did not work for me, but I still have it enabled. I am going to disable and see if it makes a difference. But after trying this fix I downloaded the d3d9.dll file and disabled visual themes and desktop composition under the Properties -> Compatibility tab when you right click on your fallout3.exe file.

The only mod I have installed is the stutter fixer (doesn't really help).

Hope this helps for you guys. Maybe it's just the conjunction of all those fixes that got it running stable for me. Good luck.

In other words you were missing a directx file, re-check the directx set up in F3 directory and run:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3

Robert(UK)
05-09-2011, 08:05 AM
Thanks a lot for this simple fix. I kept on crashing when trying to get into the Small House near the entrance to Vault 101 and your suggestion fixed it!

Thank goodness for forums lol ;)

icer22x
05-10-2011, 05:59 PM
Just wait Robert... you'll probably start crashing again. Lol
I made this tweak and was able to play for hours until I got another crash.

Slyeris
05-11-2011, 06:55 PM
When I start the game up it crashes instantly. Even with the fixes. I'll start up the game, get to the screen, hit new game, then it crashes instantly.

icer22x
05-12-2011, 10:42 AM
When I start the game up it crashes instantly. Even with the fixes. I'll start up the game, get to the screen, hit new game, then it crashes instantly.

Have you downloaded the d3d9.dll file?

Here try this:

http://www.megaupload.com/?d=3DYRVF6I

Put it in your Fallout3 folder.

R13-The2ndType
05-18-2011, 03:18 AM
+ Rep Stoop!d Monkey

Your recomended fix stopped my game from randomly crashing.
Not sure about other players with other issues, but it is working great for me.

soopaman2
05-18-2011, 09:08 AM
I made a forum account just to tell you (OP) that this worked awesomely. (Is that even a word?)

Seems a waste of a good quad core but the game is worth it.

Alt-tab still freezes it up, but the fault is in the game engine itself..

Let's hope they test the next engine on something other than XP next time.

peloneti
05-30-2011, 04:33 PM
Thank you Stoop!d Monkey, itīs works fine for me!!!

Daedalus27
06-02-2011, 02:42 PM
Thanks, hopefully this solves the issue. The crashes are infrequent on my system but the do happen. AMD Phenom II X6 and Windows 7 64bit

AWAX
06-03-2011, 07:57 PM
Anyone run into this problem:

I had trouble crashing inside buildings and rooms. I did the fix that the originator of this topic suggested, and it worked. I played through the entire game without a lock-up. Finished it.

Now, I'm playing the game again with DLC enabled, and I'm locking up in buildings again! I checked the .ini file, my settings are still the same. What gives? Is there another .ini file for the DLC?

Graeystone
06-11-2011, 08:45 PM
For people who still have problems with Quad/Multi Core(Windows 7 x64)-
1)Start game.
2)Start Task Manager.(May have to go Window Mode with 800x600 instead of 'alt+tab' for ease of access.)
3)In Task Manager, click Processes Tab.
4)Click/Right Click FO3 Exe.(May want to click 'Imagine Name' to alphabetize the list to make finding EXE easier.)
5) Right Click and choose 'Affinity'. Deselect the cores you don't want to use.(Usually the higher numbered cores on the list. So with a Quad, it will be numbered 0-3. Deselect cores 2 and 3.)
Please note that Windows will not remember the Affinity Setting(at least I don't think it will in Ultimate 7 x64. I know it won't on XP) and will have be done every time.

AnnieGYG
06-24-2011, 06:22 AM
Great job Stoop!d Monkey, this fix worked for me on Win 7 64 bit with i7 2600 processor.

I kept freezing up at the vault exit from 101.

In addition I had tried turning down graphics and setting my sound to stereo instead of surround sound and downloading the codex light pack as recommended on other forums. So if other users are still having problems it might be worth trying those also as they are pretty basic changes but might just do it.

AWAX
06-30-2011, 08:58 PM
For people who still have problems with Quad/Multi Core(Windows 7 x64)-
1)Start game.
2)Start Task Manager.(May have to go Window Mode with 800x600 instead of 'alt+tab' for ease of access.)
3)In Task Manager, click Processes Tab.
4)Click/Right Click FO3 Exe.(May want to click 'Imagine Name' to alphabetize the list to make finding EXE easier.)
5) Right Click and choose 'Affinity'. Deselect the cores you don't want to use.(Usually the higher numbered cores on the list. So with a Quad, it will be numbered 0-3. Deselect cores 2 and 3.)
Please note that Windows will not remember the Affinity Setting(at least I don't think it will in Ultimate 7 x64. I know it won't on XP) and will have be done every time.

Is there a way to get this to work without using windowed mode?

lawful_fury
07-06-2011, 04:03 AM
Used this fix along with the GFWL disabler. Played for 7 hours straight and no problems.

Although I think the problem lies more in GFWL than the threads. I'm going to experiment a bit and post my results here.

The Mad Russian
07-06-2011, 08:47 AM
I jumped and whooped for joy when this worked. Just got the game about 24 hrs ago, did this trick..Whammo, it works. Monkey, thank you!! :D

FredSRichardson
07-06-2011, 05:59 PM
Well, my crash rate is much lower. Maybe once every 20min instead of once every 3min-4min.

U62
07-08-2011, 03:34 AM
Seems to be working well so far. Cheers!

Wyattcon11
07-11-2011, 05:29 PM
Bump for necessity (the steam sale)

zerrok
07-11-2011, 08:35 PM
If we make the game run on two cores is the game slower?

Like...if I'm running on ultra high settings is switching to two cores really a good idea?

QuietDelusions
07-12-2011, 12:10 AM
Whew - I can now play for more than three minutes without the game crashing! Of course, it's now 2am and I can't play any minutes because I need some sleep.

Thanks for the fix!

addictions
07-12-2011, 02:18 AM
This solved my problem thanks.

Everything runs on ultra high perfectly now.

ArmyOfDarkstep
07-12-2011, 07:03 PM
I'm on XP SP2 32 bit and my processor only has two cores anyway. Will this fix still help me? I'm getting a lot of random crashes and freezing in VATS.

Even New Vegas runs better than the GOTY version of FO3 on my rig. Hell, this game ran better on my PS3 when I played it the first time right after it came out before any patches. I thought the PC version would be better. Beautiful graphics don't mean much when I'm losing hours and hours due to crashes and freezing. Also, GNR has some REALLY BAD sound glitches. Any ideas?

wonderpookie
07-13-2011, 02:09 AM
Have you downloaded the d3d9.dll file?

Here try this:

http://www.megaupload.com/?d=3DYRVF6I

Put it in your Fallout3 folder.

{{{I too am crashing when I start a new game.}}}

Sorry, but which Fallout3 folder do you mean? The one in the Steam folders or the one in My Documents?

Also, would you do that in addition to the fix suggested by the OP?

Thanks.

Blan21
07-13-2011, 09:58 AM
Needs a sticky. Works perfectly, thanks mate ^_^

Somepie
07-14-2011, 09:17 AM
Do people with Core 2 Duo processor need to do this ?

_somaholiday
07-14-2011, 03:50 PM
Thank you so much for posting this! I'm running Windows 7 64-bit also, and this worked great! I'm not tech-savvy at all, so I never would have managed to figure this one out on my own, haha.

theunknifable
07-14-2011, 04:57 PM
Thanks OP!

+rep! :)

FatherGrigori
07-26-2011, 10:44 AM
didnt work for me, heck i didnt even see those in the fallout 3 files

Angrypyro
08-04-2011, 09:27 AM
I had previously uninstalled fallout because it kept crashing on me. By "kept crashing" i mean i couldn't play the game for 5 minutes without it locking up on me and crashing.

Then i found this thread, reinstalled fallout, and did what the OP said and Fallout 3 hasn't crashed once since. PLEASE STICKY THIS THREAD.

Also, to the OP, you are a gentleman and a scholar.

Nitrou$
08-04-2011, 02:39 PM
Another thing...that hasn't been mentioned here, if you haven't done so download and install ffdshow. I tried everything to get new vegas and fallout 3 working but they kept crashing on initial start-up. Drove me crazy, however i didn't have ffdshow installed before and once it was installed both games booted up perfectly fine.
Hope this helps people with similar start-up crashes

todesgurke
08-05-2011, 07:56 AM
You deserve a cookie <3

perchow
08-05-2011, 03:40 PM
i tried everyting mentioned in these comments and nothing seemed to help, then i noticed there was another .ini file in my documents, so i did the same to that one aswell and it worked! Thank you!

alienware M15x
core i7

captchas
08-06-2011, 01:36 PM
Thank you....was having trouble on the DLC Point Lookout, Win 7 quad core...Great now....Now I need to figure out what my problem is in New Vegas.

The Hoovy
08-06-2011, 03:03 PM
This doesn't work.

lolzter
08-07-2011, 12:20 AM
Hmmm, when I went to fix this in mine the changes had already been made and it was still giving me framerate stutters and crashes. I guess its outrageous of me to expect a game I pay for to work reasonable well rather than be plagued by constant game crashes. I can't even get past the birthday party when starting a new game.

Same here I just bought it yesterday and i've done all of this can someone more computer savvy help me?
Processor Information:
Vendor: GenuineIntel
Speed: 2133 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: NVIDIA GeForce 310M
VendorID: 0x10de
DeviceID: 0xa75
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 18.98" x 10.67" (21.73" diag)
48.2cm x 27.1cm (55.2cm diag)

BattleAxe_604
08-07-2011, 03:51 PM
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:

bUseThreadedAI=0

change it to:

bUseThreadedAI=1

Add another line after it and insert:

iNumHWThreads=2

This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

*If the game still crashes write this iNumHWThreads=1

EnJoY!!!

------------------------------------------------------------------------------------

Proof that it works:




Stoop!d Monkey,

I think its great that you decided to post this fix, but I think its pretty lame that you seem to be taking full credit for this fix. You should edit your original post to give credit where it is due since you simply copied and pasted this fix.

Three months before Stoop!d Monkey made this thread, a user named Cult of 62 gave us a link to the place where Stoop!d Monkey copied and pasted this fix. Here is Cult of 62's thread:

http://forums.steampowered.com/forums/showthread.php?t=1209730

Cult of 62's thread reads:

Possible Fix for Freezing Issues - take note Win 7 users
There's a blog post from pdsys.org that provides a possible workaround on solving the constant freezing issues:

http://www.pdsys.org/blog/post/2009/...eps-going.aspx

I've got the 64-bit version of Windows 7 and the game stopped freezing after I applied the changes. It's worth a try...

Original Fix from Nicholas Head's Blog(from the link in Cult of 62's thread)

Ever since Bethesda came out with the 1.1 patch for Fallout 3, I couldn’t play the game anymore. Once I got into the game and started wandering around, I’d randomly “freeze” up… the video would stop updating, but the sounds/music would still play. Keyboard clicks and mouse clicks did nothing, requiring me to ctrl+alt+del and kill the task manually.

It looked like I was stuck until the next patch, but I found some help online:

The game engine has some issues with processors that have more than 2 cores. You can force the game to only use two of them and it will stop the freezing. I haven't had it freeze once since I did this several days ago.

Open up the fallout.ini file in: My Documents\My Games\Fallout3

Find the line:

bUseThreadedAI=0

change it to:

bUseThreadedAI=1

Add another line after it and insert:

iNumHWThreads=2


This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

Surprisingly, this worked like I charm. I do indeed have a quad core processor, so it sounds like this was the culprit. Why 1.1 broke the game for me.. I have no idea. It sounds like Bethesda needs to do some better testing on multi-core processors.

Hopefully this helps someone else out there!


**I just want to thank Nicholas Head for this fix, and state that Stoop!d Monkey should give credit to the people who actually spend the time with trying to come up with these fixes so that everyone can enjoy the games that they spend their hard earned cash on. Nicholas Head published this fix on his blog 4 months before Stoop!d Monkey made this thread. Just to note, Cult of 62's thread was only 3 pages into this forum, not hard to find.**

Animositisomina
08-07-2011, 03:54 PM
Stoop!d Monkey,

I think its great that you decided to post this fix, but I think its pretty lame that you seem to be taking full credit for this fix. You should edit your original post to give credit where it is due since you simply copied and pasted this fix.

OP hasn't posted on the Steam forums since March, so I doubt he really cares. And besides that, why are you now copying/pasting the exact same fix a third time in this thread? If you wanted to, you could just link to Cult's thread. There's no point in pasting the content here as well... especially when you're complaining that someone else did the same thing.

BattleAxe_604
08-07-2011, 04:04 PM
OP hasn't posted on the Steam forums since March, so I doubt he really cares. And besides that, why are you now copying/pasting the exact same fix a third time in this thread? If you wanted to, you could just link to Cult's thread. There's no point in pasting the content here as well... especially when you're complaining that someone else did the same thing.

I'm trying to prove a point. If you find a fix online and you are simply going to copy and paste it, then you should give credit to the person who came up with the fix, which is what I'm doing in my above post. I've got no respect for people who try to claim that they are the ones responsible for the fix, when all they did was "copy and paste". Then Stup!d Monkey goes on to sell the fix by putting "Proof that it works" and then listing a bunch of peoples posts in his posts like he's Sony or Valve putting advertising on the front of a packaged game like "IGN gave this a 9/10". Its just not cool to do things like that, and so I'm just calling this guy out so people will stop praising him like he's some kind of master mind. He didn't even have to hunt around for the fix, it was already in this forum.

Animositisomina
08-07-2011, 04:10 PM
I'm trying to prove a point. If you find a fix online and you are simply going to copy and paste it, then you should give credit to the person who came up with the fix, which is what I'm doing in my above post. I've got no respect for people who try to claim that they are the ones responsible for the fix, when all they did was "copy and paste". Then Stupid Monkey goes on to sell the fix by putting "Proof that it works" and then listing a bunch of peoples posts in his posts like he's Sony or Valve putting advertising on the front of a packaged game like "IGN gave this a 9/10".

You can achieve the same thing by simply linking to Cult's thread, giving him original credit that way. As of now, you're just adding clutter to a thread that Stupid Monkey likely won't even read ever again.

TechNick
08-07-2011, 05:39 PM
I tried the fix that OP posted, but I still crash. The video locks up during the intro cutscene, yet sound still plays. I have to end the task to close it. Is there any other method? This is pretty annoying.

Some specs below:

Intel Core i3 530
nvidia GT 240 1GB DDR3
6GB DDR3 RAM

Coldyron
08-08-2011, 09:11 PM
Oh wow Stoop!d Monkey, thank you so much! I looked everywhere for a fix but the one that you discovered made the game playable! I'm glad we have dedicated people like you willing to figure out how to fix the game for others! Everyone here should give him some rep for figuring out this fix!

Costlyspider
08-08-2011, 11:51 PM
ive tried this but unfortunatly, im one of the ones its still freezes up on. really bums me out, cant even get pass the test, as it freezes up.

Yakamaru
08-09-2011, 04:37 AM
Tried, and failed. Game still doesn't seem to stop crashing when i start it.

Humma Kavula
08-09-2011, 07:33 AM
There's a thread where you're instructed to do this with "fallout_default.ini" in the steam folder aswell.
Does it make a difference?

Double
08-09-2011, 07:50 AM
Not sure if this was mentioned already, but if you're running multiple monitor displays, disable them to one monitor... That solved my crashing issue at launch.

BigNutter
08-09-2011, 09:30 AM
Not sure if this was mentioned already, but if you're running multiple monitor displays, disable them to one monitor... That solved my crashing issue at launch.

Shortcut keys For Vista and 7, you can use Win+P and select Computer Only or Projector only. This will disable one or the other monitor. Extend will restore your Screens back to normal.

TheDarkness73
08-16-2011, 01:06 PM
The only problem with this solution, at least for me, is that it is somewhat laggy for me when im in the capital wasteland, but I am on ultra graphics and have everything on the highest...

myst3701
08-25-2011, 08:56 PM
this works completely thank you for the help glad i can finally play this great game.

Nipaah
08-28-2011, 12:17 AM
Thanks a load, it doesn't remove my freezes completely, but reduce the amount of freezes I get significantly making it much more enjoyable to play. :)

Iconoclast XVII
08-28-2011, 06:37 AM
For me, it did remove the freezing, but now the game just crashes. I can try the iNumHWThreads=1 and see if that helps any.

Shaneluls39199
09-03-2011, 07:27 AM
this change in line of code is what fixed everything for me

Mattrvc
09-06-2011, 05:32 PM
Will this help with the New game crash or just random freezing?

Ms Giggles
09-08-2011, 05:13 AM
This didn't work for me (well not by itself at least), I tried all the compatibility and admin options, edited the ini file, even turned off Aero while it was running and still no joy. Until I downloaded a d3d9.dll file from the description in this youtube video: http://www.youtube.com/watch?v=MiZ2SPJab-Y&feature=search and put it in the main directory of Fallout3 GOTY. I just finished playing it (first run) for 3 hours straight no problems (it even allowed me to run at higher graphics settings). To be fair I haven't tried running it again yet, nor tried activating any DLC either, but fingers crossed that all works too.
I apologise if I have unknowingly breached anything by posting this link but this is the only thing that worked for me.

Win7 64
i3-370m
Nvidia Geforce GT 420M
4gb memory

Edit: I was experiencing the new game crash not the random freezing just to clarify (in case they are separate issues).

mwadlin
09-10-2011, 11:46 PM
Hmm. When I had the exact same problems with FO3 crashing on my Win7 64-bit GTX280 setup, it actually turned out to be the gpu overheating with the stock cooler.

It was really difficult to pinpoint as it didnt happen in other games. I eventually installed a custom cooler, even overclocked the 280 quite a bit, and never had any freezing or crashing again.

Perhaps this fix of some reason additionally creates a lower load on the gpu, giving a greater margin before it goes poof? Just an observation.

I think you are right, Chris, I had the same thing happening with my 280. I installed one of those gadgets to keep an eye on GPU temp and such, and just as it crashed the shader would spike immensely. I have an i7, so there were a lot of processors to keep the GPU busy, maybe more than envisioned when the game was introduced.

golan2072
09-11-2011, 02:00 AM
Is this fix necessary on New Vegas as well, or is it merely a Fallout III problem?

RichLubo
09-11-2011, 06:40 AM
I'm glad that I solved your problems, but there is one thing annoying.
there are about 450 views and 4 comments - PLEASE COMMENT

I am a 60 year old PC gamer, whenever I see someone doing something constructive like this to benefit other gamers, I must offer max Kudos. It is a pleasure seeing someone do something like this rather than just flame or whine in forums.

Keep up the good work.

Richie

Jonny_biohazard
09-11-2011, 08:48 AM
Open up the fallout.ini file in: My Documents\My Games\Fallout3
Find the line:

bUseThreadedAI=0

change it to:

bUseThreadedAI=1

Add another line after it and insert:

iNumHWThreads=2

This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

*If the game still crashes write this iNumHWThreads=1

EnJoY!!!

------------------------------------------------------------------------------------

Proof that it works:







Excellent tip.

Ive been running FO3 for 6months, then for no reason its starts crashing every couple of minutes or when i enter housing. The only thing that changed was that I installed Shogun 2 from steam about a month ago. Im running a 6month old i5 with a very uncluttered system and great gfx card.

This was the easiest and simplest tip I found, it is also the only one that fixed the issue. Had about 2 crashes since over 5 days (which is pretty awesome for FO3).

Thanks Stupidmonkey, you are a saviour.

Hibria
09-17-2011, 03:48 AM
Changing threads to 2 and 1 seemed like it fixed it, but alas, crashed again.

Whole slave town turned on me, starting shooting me, I was shooting back and then bam, crash.

Now using 4 core option, have to wait and see if it causes crashing.

icer22x
09-17-2011, 09:52 AM
I've stopped playing this game. I can't when I know a crash is inevitable. It ruins the experience.

ikinone
09-21-2011, 02:29 AM
Using Win7 Core i3-2100. I used to crash every 10-100 seconds. Not had a crash since I made this change. Thanks so much!

icer22x
09-21-2011, 06:09 AM
I think you guys are posting 5-10 minutes after making this change. Play for DAYS until reporting back. I have similar builds to everyone on here and making this change had no effect for me. I continue to crash about once every hour or two.

fundraiser
10-05-2011, 12:47 PM
crashed after foar.. ♥♥♥♥ing.. seconds

icer22x
10-05-2011, 04:20 PM
crashed after foar.. ♥♥♥♥ing.. seconds

four*

fr0st3dfl4k3
10-07-2011, 12:44 PM
This did NOT work for me, could it be because I am running w7 32-bit? I wouldn't think that would make the game not run for me.

icer22x
10-07-2011, 02:22 PM
I hope Skyrim makes up for this crap.

fundraiser
10-09-2011, 07:29 AM
four*

l2typo

Tanooki Mike
10-12-2011, 05:19 PM
Doesn't limiting the amount of cores used hurt the performance?

xFadedx
10-15-2011, 12:29 PM
I never had a problem until I went to Rivet City and since then my game started to freeze all the time. I could still hear the radio but was unable to hear myself firing a gun and the screen was frozen. I'd have to Ctrl+Alt+Delete out.

I tried the .ini file fix listed, but it still froze with no change.

I updated the Games for Windows Live to the newest version. And every time I launch the game I Alt+Tab out and in the task manager I set the games affinity to the first 2 cores. I kept the .ini file fix in as well. After 25 hours of playing the game has only frozen up three times. Not a complete fix but at least its not as bad as it was. Hope this helps others.



Doesn't limiting the amount of cores used hurt the performance?

It would if this game required 4 cores. I have an i5-760 and have it limited to the first 2 cores. Game maxed out with V-Sync on it never goes above 50% usage for both cores. I'm guessing the game could probably run on a single core fine for the most part.

BigNutter
10-15-2011, 01:06 PM
Doesn't limiting the amount of cores used hurt the performance?

It would if this game required 4 cores. I have an i5-760 and have it limited to the first 2 cores. Game maxed out with V-Sync on it never goes above 50% usage for both cores. I'm guessing the game could probably run on a single core fine for the most part.

The game started selling in October 08, almost exactly 3 years ago. It Minimum requirements is as far as I can tell is for Single core Processor, 2.4 Ghz Intel Pentium 4.

Dual cores were around at the time, I don't think Quad cores where cheap. Remember If the make the game too powerful, no one will buy it. I used to usually think that the PC that is 2 years older than the game will play game, just.. Just so happen that I've got 2 2011 big games on a 3 year old PC!

xFadedx
10-15-2011, 06:29 PM
The game started selling in October 08, almost exactly 3 years ago. It Minimum requirements is as far as I can tell is for Single core Processor, 2.4 Ghz Intel Pentium 4.

Dual cores were around at the time, I don't think Quad cores where cheap. Remember If the make the game too powerful, no one will buy it. I used to usually think that the PC that is 2 years older than the game will play game, just.. Just so happen that I've got 2 2011 big games on a 3 year old PC!

I wasn't harping on the game. I'm impressed that a map this large has such low system requirements. Graphics still look decent to me. Only thing that stands out are the low textures if you look to close. :)

-Random Chatter- 40 hours into fallout 3 so far. Game is pretty crazy. -Possible Spoiler- Some guy's last will recorded on a tape was for me to deliver a package. Some other guy was after this package. Since I found the corpse I had to deliver the package. The package turned out to be bedclothes. Then a guy named lug nut popped up and tried to take them. Dropped off some Quantum to the addicted lady and the guy next door said he's been waiting for those bedclothes for over a year. Makes me wonder if I should've kept them. Got 300 caps for them.

There's all kinds of these crazy side quest. Awesome game so far. :D

PaddyM
10-16-2011, 05:08 AM
None of the .ini tweaks worked for me, so after setting them back to their original states I decided to try installing the K-Lite Codec Pack Basic (http://www.free-codecs.com/k_lite_codec_pack_download.htm) instead and I haven't had a single freeze or crash ever since, even when Alt-tabbing in and out. I've been playing for about 4 days solid now, as well as abusing the game with dozens of console commands/cheats, with no problems whatsoever.

My CPU is an Intel Q6600 Core 2 Quad 2.4GHz and there haven't been any problems regarding AI or hardware thread counts; my .ini file is unedited.

icer22x
10-16-2011, 10:41 AM
None of the .ini tweaks worked for me, so after setting them back to their original states I decided to try installing the K-Lite Codec Pack Basic (http://www.free-codecs.com/k_lite_codec_pack_download.htm) instead and I haven't had a single freeze or crash ever since, even when Alt-tabbing in and out. I've been playing for about 4 days solid now, as well as abusing the game with dozens of console commands/cheats, with no problems whatsoever.

My CPU is an Intel Q6600 Core 2 Quad 2.4GHz and there haven't been any problems regarding AI or hardware thread counts; my .ini file is unedited.

What specifically does that codec pack do Paddy?

PaddyM
10-17-2011, 04:09 AM
What specifically does that codec pack do Paddy?I'm not entirely sure, I think it just contains codecs which are more compatible with Fallout. The ffdshow filter seems to pop up in conversation quite frequently when you search other forums and websites for Fallout fixes, and I notice when I run Fallout and Alt-tab out the AC3Filter configuration icon is present in the system tray (and disappears when I close Fallout).

The K-Lite Pack fix had been suggested in numerous places and I always dismissed it as nonsense, but I tried it as a last-ditch attempt at a fix and it worked like a charm (and taught me a valuable lesson!). Try it out if you've had no luck with any other fix.

By the way, I install the pack pretty much as is and I haven't tweaked any options for any of the codecs included.

icer22x
10-17-2011, 06:00 AM
I'm not entirely sure, I think it just contains codecs which are more compatible with Fallout. The ffdshow filter seems to pop up in conversation quite frequently when you search other forums and websites for Fallout fixes, and I notice when I run Fallout and Alt-tab out the AC3Filter configuration icon is present in the system tray (and disappears when I close Fallout).

The K-Lite Pack fix had been suggested in numerous places and I always dismissed it as nonsense, but I tried it as a last-ditch attempt at a fix and it worked like a charm (and taught me a valuable lesson!). Try it out if you've had no luck with any other fix.

By the way, I install the pack pretty much as is and I haven't tweaked any options for any of the codecs included.

Very nice. I gave up on this game due to crashes. It just couldn't continue to play it knowing that I would inevitably crash. Sometimes I'd spend an hour or two exploring the wastelands and not going into a single door, which means no auto-saving (and I'd also forget to save myself) then crash and lose all my progress.

Maybe this will solve my problem. But with Skyrim coming out soon and me being in the middle of a few games ATM, I think I'll shelve this for the time being. lol

PaddyM
10-17-2011, 07:04 AM
Very nice. I gave up on this game due to crashes. It just couldn't continue to play it knowing that I would inevitably crash. Sometimes I'd spend an hour or two exploring the wastelands and not going into a single door, which means no auto-saving (and I'd also forget to save myself) then crash and lose all my progress.

Maybe this will solve my problem. But with Skyrim coming out soon and me being in the middle of a few games ATM, I think I'll shelve this for the time being. lolHaha I know the feeling, I shelved Fallout 3 for about a year because I just couldn't stand the freezing/crashing every 10 minutes - I only got to play a few hours of it before I gave up. I've been playing it non-stop for about a week now without a single problem, thanks to the K-Lite fix. Wish I had tried it before!

Hope it works for you too man.

Wendigo
10-17-2011, 09:40 AM
What package of K-Lite Codec is required? there are lots of them, like "basic" "standard" and so on.

PaddyM
10-17-2011, 10:10 AM
Basic ;)

I'm sure the others would work too, I just didn't fancy having a tonne of codecs on my system that I'll never use, plus installing codec packs as opposed to individual codecs can be disastrous so I thought it was best to err on the side of caution and just use the basic pack. The Basic one worked fine for me and hasn't adversely affected any other aspect of my media-based capabilities.

FreyaWazHere
10-17-2011, 08:31 PM
Question! So I found a site that gave this advice last year and what did it do? It shut off two of my four cores and left me unable to run any other game without severe lag. I've heard that the issue with Fallout 3 on Win7 is the fact that its not DX11 compatible. And I have issues trying to run it even in compatibility mode for Vista SP1.... are there any techniques that work that don't run the risk of me f*cking up my computer again?

Wendigo
10-18-2011, 07:14 AM
Question! So I found a site that gave this advice last year and what did it do? It shut off two of my four cores and left me unable to run any other game without severe lag. I've heard that the issue with Fallout 3 on Win7 is the fact that its not DX11 compatible. And I have issues trying to run it even in compatibility mode for Vista SP1.... are there any techniques that work that don't run the risk of me f*cking up my computer again?

wtf? if you shut off two cores for fallout 3, it doesnt shut off for any other games. Because the editing is made in the fallout.ini folder.

icer22x
10-18-2011, 08:00 AM
Question! So I found a site that gave this advice last year and what did it do? It shut off two of my four cores and left me unable to run any other game without severe lag. I've heard that the issue with Fallout 3 on Win7 is the fact that its not DX11 compatible. And I have issues trying to run it even in compatibility mode for Vista SP1.... are there any techniques that work that don't run the risk of me f*cking up my computer again?

What Wendigo said. It's impossible that Fallout 3 shut off 2 of your CPU cores. lol

All that "advice" you followed is not a good idea TO follow if you do not understand what it's doing. Just skimming through the list of things to try, you're prone to come across system responses that you have no idea how you got there.

I can guarantee you one of those fixes you followed was to shut off the your core affinity for the game. There is a way to do it in the .ini file and also through Task Manager.

Also, a game does not have to be DX11 compatible when installing on Win7. FYI: Vista also supports DX11. If your OS/graphics card do not support DX11, it will revert to 10 or 9.

Is there anything you can try without running the risk of f***ing up your computer? Yes. Read about what you're doing before trying it. Fallout 3 didn't mess up your settings, you did.

FreyaWazHere
10-18-2011, 11:29 AM
/le shrug

I don't know, I'll admit I'm no good with computers, I just like to play games and don't have an inkling how they run. The advice I'm referring too is the:

BUseThreadedAI=1
iNumHWThreads=2

.ini change. It was the only thing I had done to the fallout files in order to get it to work, all the rest of my efforts last year and now, have involved changing the compatibility, and I still have random crashes every 10 min-an hour......

Edit: My fallout3.ini file is all in caps 'FALLOUT.INI' also I have two other f3 .ini's 'FalloutPrefs.ini' and 'fallout_default.ini' I trust if I do this editing it should only be to the 'FALLOUT.INI' but the fact its all in caps confuses me...

icer22x
10-18-2011, 12:40 PM
/le shrug

I don't know, I'll admit I'm no good with computers, I just like to play games and don't have an inkling how they run. The advice I'm referring too is the:

BUseThreadedAI=1
iNumHWThreads=2

.ini change. It was the only thing I had done to the fallout files in order to get it to work, all the rest of my efforts last year and now, have involved changing the compatibility, and I still have random crashes every 10 min-an hour......

Edit: My fallout3.ini file is all in caps 'FALLOUT.INI' also I have two other f3 .ini's 'FalloutPrefs.ini' and 'fallout_default.ini' I trust if I do this editing it should only be to the 'FALLOUT.INI' but the fact its all in caps confuses me...

It's okay man, that's why forums exist, so you can learn! :)

BUseThreadedAI=1 allows the game's AI to use multithreading which splits the tasks across CPUs with multiple cores. I've read on TweakGuides that Fallout 3 is already multithreaded by default and enabling this option provides little to no improvement. So if I were you, I'd leave it at it's default setting.


iNumHWThreads=2 is restricting the entire game to using the specified amount of threads. People have reported this solving freezing problems (since apparently Fallout 3 doesn't know how to deal with quad core CPUs... IDK), but as for me and some others in this forum, this tweak does nothing to help.

Don't feel like your alone with the crash issue. I've given up on the game due to this crap. It's inexcusable that this game shouldn't be able to run on a modern Win7 system. Bethesda needs to patch it, but that probably won't happen with Skyrim coming out soon. You could try and dual boot with XP and try running it on that.

If you want a great source for Fallout 3 tweaks and explanations, visit www.tweakguides.com and search for his Fallout 3 article. The guy that runs that site is very knowledgeable.

trojanrabbit.gg
10-18-2011, 05:27 PM
I found this the other day and thought it might be helpful for some folks. Its a program that will allow you to easily edit what ever values you want to with the click of a button. (http://modsreloaded.com/fallout-3-configator)

FreyaWazHere
10-19-2011, 12:53 AM
Thanks icer, I ended up creating a system restore point and then just changed the second thread line and boom a little bit of lag when loading into areas on ocassion but played like 9 hours straight or so with no problems.

TBH I have no idea how I did that to my comp last time, I've basically learned I just shouldn't ever try to edit or mod any game unless I want my laptop to commit suicide.

bryonhowley
10-19-2011, 03:31 PM
It is strange I have not had any problems on my rig but my friend with the same system minus the GPU he uses Nvidia does have crashes and this did fix his problem.

I do not see how the GPU could be the problem but it is just strange that because we are running the same hardware and software expect for that one component.

OS: Windows 7 x64
CPU: AMD Phenom II X6 1090T Black Edition : Motherboard: MSI 890FXA-GD70
Case: In Win Dragon Rider : Video Card: 2x SAPPHIRE HD 6950 (flash to 6970) 2GB
Monitors: 3x Asus VK278Q Black 27 : Memory: G.SKILL Ripjaws Series 8GB DDR3 1600
SSD: OCZ Vertex 2 3.5" 90GB : HDD: 4x Western Digital Caviar Green 3TB 64MB Cache
Optical Drive: LG WH10LS30K 10X Blu-ray Burner : Mouse: Logitech Performance Mouse MX
Keyboard: Logitech G19 Gaming Keyboard

kissface9
10-27-2011, 08:55 PM
like no joke this should be on like IGN or something. this needs to be spread out. it woked! lol thanks man

extrems3c
10-30-2011, 12:19 AM
I never had a problem until I went to Rivet City and since then my game started to freeze all the time. I could still hear the radio but was unable to hear myself firing a gun and the screen was frozen. I'd have to Ctrl+Alt+Delete out.

I tried the .ini file fix listed, but it still froze with no change.

I updated the Games for Windows Live to the newest version. And every time I launch the game I Alt+Tab out and in the task manager I set the games affinity to the first 2 cores. I kept the .ini file fix in as well. After 25 hours of playing the game has only frozen up three times. Not a complete fix but at least its not as bad as it was. Hope this helps others.





It would if this game required 4 cores. I have an i5-760 and have it limited to the first 2 cores. Game maxed out with V-Sync on it never goes above 50% usage for both cores. I'm guessing the game could probably run on a single core fine for the most part.

This is exactly what has happened to me! Except I'm running a dual core not a quad... after trying all these attempts I've run out of ideas.

Epiczz115
11-06-2011, 10:20 AM
I really hope this works on windows XP
:I

McBerns
11-17-2011, 07:25 PM
http://www.tech-forums.net/pc/f15/fallout-3-crash-desktop-solution-here-189880/

Wyattcon11
11-20-2011, 08:10 PM
Just need to say...

This worked in:
FO3
FO:NV
and Skyrim

(for me)

Wendigo
11-24-2011, 04:26 PM
Just need to say...

This worked in:
FO3
FO:NV
and Skyrim

(for me)

What worked for you?

..........

Wyattcon11
11-25-2011, 08:53 PM
What worked for you?

..........

The OP's guide

Lucas941
11-26-2011, 03:05 PM
Thank you!

Dreadjaws
12-01-2011, 04:46 PM
Thanks for the fix, OP! It works like a charm!

Stoop!d Monkey
12-09-2011, 07:31 AM
HAD TO BUMP IT BECAUSE I SAW THAT THERE ARE MANY MORE USERS THAT HAVE A PROBLEM WITH THIS. PLEASE STICKY IT, LOOK AT THE COMMENTS - IT WORKS!

icer22x
12-09-2011, 10:09 AM
No it doesn't. Not for everyone. Play about 20+ hours worth of the game after the fix and then report back.

Garrett148363
12-26-2011, 05:51 PM
Trying it now hopefully it works!

Garrett148363
12-26-2011, 06:09 PM
It seems to be working. Using windows 7 64 bit and i5-2500k.

fakiyo
12-26-2011, 06:40 PM
Sticky please?
If it works for me, +15 reps.

fakiyo
12-26-2011, 08:20 PM
+15 reps. Works :)

Bruiserlarue
12-26-2011, 08:53 PM
Thanks soooo much for this tip. Was rather frustrating to get the game loaded and have it promptly crashing. Changing the INI according to your directions made an instant fix. Great job for sharing it! :)

Chibito
12-26-2011, 09:38 PM
Thanks! Worked out just fine.

Beta Version
12-27-2011, 02:17 AM
No luck for me... still crashes when I hit New Game... I can't believe that I was able to run an old game like Knights of the old republic on windows 7 but not fallout 3... thanks anyway for you post.

blkgsr94
12-27-2011, 09:20 AM
I was having the same problems as many of you and finally got F3 to run on my Samsung Series 9 laptop by downloading the d3d9.dll file and copying into the fallout3goty folder.

I had previously tried editing the .ini file like suggested by OP but that didn't fix it (though it did increaes my graphics capability in game), running in compatibiity mode, changing the administrated setting.

aclos
12-27-2011, 10:23 AM
At first, I followed OP's method and altered the .ini files, but to no avail. However, I updated my video card driver, and then F3 worked! Unfortunately after around 9 hours of gameplay, I got the dreaded crash with no solution.

I lurked around and got the K-Lite Codec pack, updated Windows, defragged hard drive, you name it--but nothing worked. Then as a last attempt, I figured I would try blkgsr94's method and downloaded the d3d9.dll file...and it finally worked!

AlizarinCrimson
12-27-2011, 10:33 AM
I have the same problem, had/have it with Oblivion and Fallout NV too. Oblivion crashed about 4 times, until I loaded an older save, then it never crashed again (and I played it a lot). Fallout NV crashed right at the beginning, I started a new game - no crashing so far (fingers crossed...). Fallout 3 crashed tonight - however, I'm glad I could play several hours without any problems.

OP's method didn't work for me, unfortunately.

I just hope someone finds a solution at some point...

mgchild
12-27-2011, 10:36 AM
Make sure that on the Fallout3.exe file, you go into the properties/compatibility and check the box for "disable desktop composition". I tried all the other fixes and they weren't all that successful. This one was. 12 hours, no glitches, crashes or anything else.

TheGaskin
12-27-2011, 06:53 PM
I've tried this and my 'Fallout 3: GOTY' still isn't working, are there any other methods of getting it to work?

goukisodomken
12-27-2011, 06:57 PM
I have a question:

Do the d3d9.dll needed on fallout 3 path in windows 7?

pliny
12-27-2011, 07:03 PM
This worked for me. Thank you. Many hours of frustration, should have checked this forum first.

This should be sticky.

84CubsFan
12-27-2011, 09:13 PM
Worked for me on an i5, ATI 5850 GPU. Why I needed it with only two cores I do not understand, but it seems to have done the trick. Thanks.

blkgsr94
12-27-2011, 10:47 PM
I have a question:

Do the d3d9.dll needed on fallout 3 path in windows 7?

I think you're asking where to place the .dll file, correct me if i'm wrong.

You want to place it in C:/Program Files(x86)/Steam/steamapps/commom/Fallout3 goty

goukisodomken
12-28-2011, 01:00 AM
I think you're asking where to place the .dll file, correct me if i'm wrong.

You want to place it in C:/Program Files(x86)/Steam/steamapps/commom/Fallout3 goty

I also play fallout new vegas, it sometime hang or crash but roughly 85% playing time is OK.

But in fallout 3 it is always hang and screen freeze when playing short time(around 15 -20 mins), so I ask must the d9d3.dll need on windows 7 when playing fallout 3.

blkgsr94
12-28-2011, 09:19 AM
I also play fallout new vegas, it sometime hang or crash but roughly 85% playing time is OK.

But in fallout 3 it is always hang and screen freeze when playing short time(around 15 -20 mins), so I ask must the d9d3.dll need on windows 7 when playing fallout 3.

Well I want to say no, because so many other people on the forums claim to have their copies running fine on their computers without it....BUT I could never get it to run on my laptop (running windows 7) without it.

So if you've tried everything else to get it to run on yours, then I would say give it a try. If it doesn't work then you can just delete the file.

Tatuzka
12-28-2011, 09:56 AM
Tried, and failed. Game still doesn't seem to stop crashing when i start it.

Same here... Srsly people is there anyway to fix this? I cannot start a new game!

blkgsr94
12-28-2011, 10:45 AM
Same here... Srsly people is there anyway to fix this? I cannot start a new game!

Well what fixes exactly have you tried? We need details to help you.

Tatuzka
12-28-2011, 10:56 AM
Well what fixes exactly have you tried? We need details to help you.

I've tried this topic's way and i failed. I've tried to verify the game files and failed to make it work. Tried even downloading a mod installer.. FAIL.. Oh and i tried to run as adminstor but it did not seem to help. Also tried to rename the music folder as backup-music but it did have any positive effect. Checked all of the DLC stuff that i have em selected. And my computer can easily run this game i have no doubt about that.

Sooo... Can you tell me did i miss something? :(

52pickup
12-28-2011, 11:38 AM
Try deleting the CFG file named "Fallout3.exe". I was getting the "Fallout3.exe has stopped working" problem, and this was the only solution that fixed it. Nothing else worked.

Nothing bad happened to me. I didn't notice any negative effects. But you might want to make a copy of the file just in case.

Tatuzka
12-28-2011, 12:59 PM
Try deleting the CFG file named "Fallout3.exe". I was getting the "Fallout3.exe has stopped working" problem, and this was the only solution that fixed it. Nothing else worked.

Nothing bad happened to me. I didn't notice any negative effects. But you might want to make a copy of the file just in case.

Noooo... :( It did not work... What is going on.... :((((

CHUBY90
12-28-2011, 04:25 PM
About the fix...
It's work for me too.:)
Thanks!

blkgsr94
12-28-2011, 05:07 PM
I've tried this topic's way and i failed. I've tried to verify the game files and failed to make it work. Tried even downloading a mod installer.. FAIL.. Oh and i tried to run as adminstor but it did not seem to help. Also tried to rename the music folder as backup-music but it did have any positive effect. Checked all of the DLC stuff that i have em selected. And my computer can easily run this game i have no doubt about that.

Sooo... Can you tell me did i miss something? :(

Did you try placing the d3d9.dll file into the fallout 3 folder?

If not I would try that, then before running it, right click on the Fallout3 application (NOT the file that says Fallout3.exe; the one you want has the Fallout character icon)in that same folder and go to the compatibility tab. Set to run in Windows XP Service Pack 3 and run as administrator.

Then double click the same Fallout3 icon you just right clicked and see what happens. Sometimes the Fallout 3 launcher can cause more problems and I find this an easy way to get around using the launcher.

garyboozy
12-29-2011, 10:24 AM
for anyone using 2 screens (laptop and external here) check this out:

win764 on macbook pro w/bootcamp. was crashing after hitting 'play' on the first mini screen. tried the OP method, wouldnt work. then tried all the other suggestions - codec pack, music folder rename etc - but none worked either.

BUT i saw someone mention that you can try disabling the laptop's screen (with ATI's Catalyst Control Centre here) when using an external monitor. this worked for me so thanks, whoever you were!

and THEN the OP fix here sorted out random ingame freezes.
so the OP method fixes ingame crashes but not the initial launch crash. at least for me.

goukisodomken
12-29-2011, 06:10 PM
After I placing the d3d9.dll file into the fallout 3 GOTY folder, the freezing problem seem fixed. But Anyone have same issue following:

When playing around 5 - 10 mins, I feel the game slow down. After I use FRAPS to check fps, it starting 60 fps and suddenly drop to 25 fps after playing 5 - 10 mins.

Naetholix
12-29-2011, 10:58 PM
Hey,

I just DLed and installed the Game of the Year edition of this game and I haven't even been able to get past the first loading screen. I select "new game" and it will initiate the load screen, and then it will go to a black screen and hang there.

It also does this when I attempt to quit from the main menu. I need to use the task manager to close the program.

I tried Stoop!d Monkey's .ini file fix, I tried using the .dll file in my Fallout3 GOTY folder (in steamapps/common), I tried selecting compatibility modes on the .exe... aaaand I tried multiple combinations of these fixes (subtracting one at a time, using all available combinations), as well as attempting to run at the lowest graphics available.

I have installed ffdshow and configured it to run in stereo. I've uninstalled/reinstalled the game 3 times, and even reinstalled my whole Steam folder onto my C: drive (was previously on my D: drive since I have far more HD space there) in an attempt to fix this.

I'm running Windows 7 Ultimate x64 on:
AMD 6000 dualcore 64bit 3.2GHz CPU
Asus MCP55 Mobo with SoundMAX integrated 7.1 surround sound
7GB DDR2 RAM
nVidia GeForce 9800GTX GPU

All of my drivers are up to-date.

Any help is appreciated.

Thanks!

thegreatwease
12-30-2011, 11:24 AM
I went to My documents then to my games and went into the fallout 3 file but I don't see a fallout.ini file all I see is FALLOUT, FalloutPrefs and Rendererinfo. Is it in any of those files?

pliny
12-30-2011, 09:22 PM
I went to My documents then to my games and went into the fallout 3 file but I don't see a fallout.ini file all I see is FALLOUT, FalloutPrefs and Rendererinfo. Is it in any of those files?

FALLOUT is probably fallout.ini, you just have your Windows Explorer set to hide file extensions. Right click and open FALLOUT in a text editor like wordpad or notepad.

aramdol
12-31-2011, 09:56 AM
didn't work for me, unfortunately

Ashpool
12-31-2011, 12:14 PM
This worked for me! Thank you so much!