PDA

View Full Version : Can't get past loading screen


Chasiubao
06-30-2010, 03:59 AM
I just finished downloading the game and went to run as administrator, says I was missing PhysXloader.dll. I downloaded that then run the game again but it just goes to the loading screen with prime then screen goes away and nothing happens.

Can't figure out what else is wrong, everything has been restarted multiple times already.

Kiljoy66
06-30-2010, 04:13 AM
Maybe run the file check validation(can't remember actual wording, at work) in steam for the game, might fix your issue.

Chasiubao
06-30-2010, 04:33 AM
Tried verifying integrity of cache files and there was nothing wrong there. Don't know how else to check short of having to delete and redownload the entire game -_-

Kiljoy66
06-30-2010, 04:50 AM
I see what you are talking about, reread your OP, try restarting Steam, that's what I had to do after the install, same thing happened to me, refused to go past the splash screen.

If that doesn't work then you might have to redownload unless anyone else has a suggestion.

Chasiubao
06-30-2010, 05:17 AM
Yea, I've restarted steam and pc multiple times and nothing works. Run as admin etc, anything I can think of I've tried. Out of all the games I have on steam this is the first time this has happened -_-;

Kiljoy66
06-30-2010, 05:46 AM
Hmm, it is a strange one, as much as I don't wanna say it, you might have to re-download the game.