PDA

View Full Version : CSS - FPS still like crap


matrud
06-30-2010, 10:35 AM
As i keep saying: running CSS on win xp bootcamp i get over 200 fps and using steam native on mac os Snow leop. is getting the crapy 50 fps...
come on valve!!!! What the hell is going on?? using crossover i get more fps!

BravePumpkins
06-30-2010, 11:02 AM
Post your specs (including specific version of OS X) and...

Since when is 50 fps crappy?

rbarris
06-30-2010, 11:59 AM
@matrud -

I saw your other post - you have an iMac? make sure MSAA is disabled - there is a noticeable bottleneck in MSAA in 10.6.4 and earlier on ATI chipset.

We're working on some other optimizations (note the gl_bufmode thread at top of forum too) - but I would check that one first.

banzorhamzor
06-30-2010, 12:01 PM
@matrud -

I saw your other post - you have an iMac? make sure MSAA is disabled - there is a noticeable bottleneck in MSAA in 10.6.4 and earlier on ATI chipset.

We're working on some other optimizations (note the gl_bufmode thread at top of forum too) - but I would check that one first.

+gl_texclientstorage 1

AtastyTr33t
06-30-2010, 01:40 PM
using late 08 macbook. getting an average of 40FPS in CS:S and ALWAYS 30 or lower on TF2. all on lowest settings. ridiculous

2befine
06-30-2010, 02:51 PM
using crossover i get more fps!

true :) same here.

rahmetli61
06-30-2010, 02:52 PM
Same damn thing for my Macbook Pro.
I get over 150 FPS with Bootcamp but in Mac Os X, I can't get higher than 60 FPS. I reduced all video settings but it didn't help out. What should I try to get 100~ FPS? The game I'm talking about is CS:S. I'll be following this topic to get any help, and especially I'll be waiting for rbarris 's response to that issue.

Macbook Pro 2.8
NVIDIA GForce 9600M GT
4 GB RAM

rahmetli61
06-30-2010, 03:47 PM
gl_disable_forced_vsync 1
This fixed the issue.
Thanks.