PDA

View Full Version : Error on startup


jurassicbond
06-30-2010, 12:59 PM
I just got this game, but whenever I try to run it, I get an error message saying "Failed to create D3D Device". I've tried various display settings(decreasing resolution and unchecking all options) and get the same message no matter what. I've also tried testing Direct 3D in dxdiag and all the tests there check out.

Here's the system information I know.
OS: Windows XP Home Edition (5.1, Build 2600)
Video Card: Intel G33/G31 Express Chipset Family
Ram: 3062 MB
Processor: Intel Pentium Dual CPU E2180 @ 2.00 GHz

The only thing I can think of is that maybe it's my video card. I know that what I have isn't that good, but as far as I can tell it meets all the requirements. One other thing is that I don't have the latest drivers installed because my mom uses Zoomtext which doesn't work with new drivers. I have however temporarily installed the most recent ones as a test and had the same problem. Any help on the problem would be greatly appreciated.

Lurpsukka
06-30-2010, 01:09 PM
Have you updated your graphics drivers?

Latest DirectX?

jurassicbond
06-30-2010, 01:37 PM
I have the latest DirectX, and like I said in the first post I tested it with the latest graphics drivers. I can't keep those drivers installed though as a program my mom needs doesn't work with them.

DaracSjet
06-30-2010, 03:30 PM
Do you have windows service pack 3?

jurassicbond
06-30-2010, 03:39 PM
Yes. Service Pack 3 is installed.

cfisco
06-30-2010, 11:59 PM
jurassicbond, I think we're in the same boat. It looks like you are using an integrated video card, like the one I have on my laptop. According to steam, the game requires a 128MB dedicated video card (e.g. NVIDIA GeForce FX 5600 or ATi Radeon 9600). I was really hoping that I'd be able to play this game on my laptop (which can run Half Life 2 actually), but unless there's some work-around, I think we might be out of luck.