PDA

View Full Version : Just another problem thread


I_soROCK
07-09-2010, 08:29 PM
So I know there are A LOT of threads about the problems this game has but all of them aren't helping me at all. I've done so much trying to fix this game but nothing works for me. I'm pretty sure it's not Win7's fault and I doubt it's my graphics card (which is an NVIDIA GeForce 9400 GT). And i really can't figure out why my video is going faster than the sound. And if tat wasn't enough, some of the objects and stuff aren't where they should be. Like at the beginning when Jade starts running, her eyes are going bonkers. Can anybody tell me something that works... My dad played this game back on the GameCube and I was too young to really understand what was going on. I seriously want to play it...:(

Perducci
07-09-2010, 10:50 PM
I had a similar problem when I tried to play, and hopefully the fix that worked for me will help for you too.

Open Windows Explorer and navigate on your hard drive to your Program Files folder. If there are two Program Files folders just find the one that has a Steam folder in it. From there, go to Steam\steamapps\common\beyond good and evil, and open the file SettingsApplication.exe

You probably ran this configuration when you launched BG&E for the first time on Steam. Go to the Advanced Settings tab and click the box that says "Manual compatibility settings." Then make sure that "HW Vertex Processing" and "W buffer" are unchecked. By default I believe that W buffer is already unchecked but you need to manually uncheck HW Vertex Processing.

Anyway, save the settings and try launching the game now. Hopefully that will cut down on the glitchy graphics. At least it did for me.

For more information (and for the post that helped me) you can read this thread:
http://forums.steampowered.com/forums/showthread.php?t=682893

I_soROCK
07-10-2010, 11:08 PM
*sigh*... I've done this already... it's still not synched up at all and the graphics are still somewhat glitchy...

Perducci
07-11-2010, 09:14 AM
Hmm...I'm not sure what to say then. I only just started playing this game so I don't have much experience with troubleshooting it. I know it warns that Windows 7 isn't supported but at the moment I got it to work for me so there probably is a way somehow.

I guess just make sure your video card drivers are updated. Hopefully someone else on these forums can offer a better suggestion :(

EDIT: Actually I guess I have one more shot in the dark for the video not matching the sound. Go to Control Panel -> Sound, and then right click on your sound device and go to Properties. Then go to Advanced and see what the settings are. Right now I have the quality at 24 bit, 48000 Hz and both boxes are checked for Exclusive Mode (Allowing applications to take exclusive control of this device; and Give exclusive mode applications priority).

I'm not sure if messing around with these will help but I remember when I bought the game Prototype there was a common problem with the sound being too slow or too fast for the video and one fix was to adjust the sound quality. By default if the Exclusive Mode boxes are checked then I don't think you should have to manually change the quality because the application should do it.

Again, I doubt this is part of your problem. It usually would cause your audio to sound twice as fast and like a chipmunk or twice as slow and really deep. If it's just a problem of audio/video synching then that's something else. Anyway, just offering another suggestion.

I_soROCK
07-11-2010, 02:09 PM
Well my sound was set at 16 bit but changing it didn't do anything...

Perducci
07-11-2010, 04:48 PM
Yeah, bit depth wouldn't affect it. The frequency was what I was really looking at.

Well, I tried my best but that's all I can offer at the moment. Maybe someone else will know more. :(

_jema987
07-11-2010, 07:37 PM
I'm not 100% but I think the sync problem is due to your CPU changing frequency which the BG&E engine just cant handle. Try setting your power scheme to 'always on' and give it a go.

If that isn't it then it might be affinity issues, the engine is a bit jaded... Open a command prompt and navigate to your BG&E folder and then run this command "c:\windows\system32\cmd.exe /C start /affinity 1 BGE.exe". I can't guarantee that this will work with the steam version but it works with the versions I have.