PDA

View Full Version : Polygons popping in Dead Space (HD4850), Help!


Astarothell
07-22-2010, 09:45 PM
Hello people, I bought this game in this recent promotion of steam, but after the installation, there was a bug in which the polygons burst across the screen, making it impossible to see anything on the screen. Has anyone had similar problem and knows how to solve?
Here's a screenshot of the bug:

Screenshot 01 (http://img843.imageshack.us/img843/2624/deadspace20100722233657.jpg)
Screenshot 02 (http://img843.imageshack.us/img843/2624/deadspace20100722233657.jpg)

I use Windows 7 and my video card is an HD4850 with Catalyst 10-6 and not any kind of overclocking.

PS: Sorry if it's not here to post this, but my english is terrible...

BionicAir
07-22-2010, 10:35 PM
your english looks fine to me,and it looks like the necromorphs put on one hell of a light show! ok ok,enough humor lol..ive never seen anything like that before..thats just strange..your GPU might be croaking,or its just DS doesent like your card if its not doing it to any other game..have you tried messing around with any video settings? can verify the game cache,and defragment too,i'm not much of a computer whiz,so just throwing out ideas..sorry if im not much of a help to you,but GL on getting that sorted out

Astarothell
07-23-2010, 08:23 AM
your english looks fine to me,and it looks like the necromorphs put on one hell of a light show! ok ok,enough humor lol..ive never seen anything like that before..thats just strange..your GPU might be croaking,or its just DS doesent like your card if its not doing it to any other game..have you tried messing around with any video settings? can verify the game cache,and defragment too,i'm not much of a computer whiz,so just throwing out ideas..sorry if im not much of a help to you,but GL on getting that sorted out


Believe me, my english IS horrible. Just something I understand thanks to google translator.
In fact had not even noticed that it seems like a nightclub from hell (hehehehe)!
I did it everything you had, but nothing worked. This problem also occurred in Singularity, but only on the grass.

Question: Did these two games use the same engine?
Question: Can someone pass me the link to EA's U.S. tech support, since the EA in Brazil (I am Brazilian!) Does not support the game only because I bought it for steam.

I thank everyone who helped.

BionicAir
07-23-2010, 03:46 PM
sounds like a bad card to me :/ have you tried uninstalling your drivers,and then reinstalling?

DidierSachs
07-23-2010, 06:09 PM
Try going back to an earlier Catalyst driver, 10.3 or 10.4, because 10.6 seem a bit flakey with certain hardware configs, or so I've read.

Astarothell
07-23-2010, 06:32 PM
sounds like a bad card to me :/ have you tried uninstalling your drivers,and then reinstalling?

Yes, I did it (about 4x). Even so, thanks.

Try going back to an earlier Catalyst driver, 10.3 or 10.4, because 10.6 seem a bit flakey with certain hardware configs, or so I've read.

I'll do this today. Then post the result.

Xpheyel
07-28-2010, 11:18 AM
That looks amazing. Like playing in the middle of a laser rave. :eek:

Astarothell
07-28-2010, 09:23 PM
Already returned the driver and nothing ...
I turned off all effects and nothing ...
I tried to talk to tech support and nothing ...
I've prayed and nothing ...

Personally, I think I will file a lawsuit against EA because the system requirements my PC this setting.

chkdsk1991
07-29-2010, 02:10 PM
Try going back to an earlier Catalyst driver, 10.3 or 10.4, because 10.6 seem a bit flakey with certain hardware configs, or so I've read.

Absolutely with that catalyst i had a lot of artifacts on other games such as COD4 and Gta4.
I rolled back to 10.3 and they're all gone :cool:

proto1000
08-06-2010, 10:08 PM
Believe me, my english IS horrible. Just something I understand thanks to google translator.
In fact had not even noticed that it seems like a nightclub from hell (hehehehe)!
I did it everything you had, but nothing worked. This problem also occurred in Singularity, but only on the grass.

Question: Did these two games use the same engine?
Question: Can someone pass me the link to EA's U.S. tech support, since the EA in Brazil (I am Brazilian!) Does not support the game only because I bought it for steam.

I thank everyone who helped.
No. Singularity uses the UT3 Engine (Unreal Tournament 3), Dead Space does not.
EA Tech support:
http://support.ea.com/

I have an ATI 4850 and ran both these games fine. I always keep my drivers & CCC up to date.

kebabsoup
01-03-2011, 06:00 PM
Hello people, I bought this game in this recent promotion of steam, but after the installation, there was a bug in which the polygons burst across the screen, making it impossible to see anything on the screen. Has anyone had similar problem and knows how to solve?
Here's a screenshot of the bug:

Screenshot 01 (http://img843.imageshack.us/img843/2624/deadspace20100722233657.jpg)
Screenshot 02 (http://img843.imageshack.us/img843/2624/deadspace20100722233657.jpg)

I use Windows 7 and my video card is an HD4850 with Catalyst 10-6 and not any kind of overclocking.

PS: Sorry if it's not here to post this, but my english is terrible...

Sorry bumping up an old thread, but this is still kinda unresolved and I found a solution that worked in my case.

I just signed up on steam and downloaded a bunch of games for the upcoming year, including dead space. My steam-experience didn't start very well as I rapidly encountered this weird 60' disco-light artifact flickering glitch. I'm running win7 64x with a HD5770, stock clock with Catalyst 10-6 too.

And in fact, the problem was with the catalyst CCC. I tried to mess around with the v-sync config in both game and CCC, without any chance. And then, I clicked "option>preferences>restore factory default" and tadaaaa the glitch disappeared and the game worked like a charm.

Hope it can help prevent some headache.

Peace.