PDA

View Full Version : Fullscreen?


Dread1021
08-06-2010, 10:19 AM
Riven won't run in fullscreen for me. I have a 2 monitor setup, and it's running in a tiny little box on monitor 2 (but weirdly, when I press option to bring up the menu, the menu box pops up on my first monitor). I know it runs at a tiny resolution, but I still want it fullscreen if possible.

Arucard
08-06-2010, 11:21 AM
The only way to get some what full sreen is to ether change your monitor res to 800 x 600 or lower or check the option in the menue to 640 x 480 and even then it still has black bars if your useing a 16:9 monitor or at least it does for me. The other thing you might need to do is turn off you second monitor if that doesn't work.

dragossh
08-07-2010, 05:34 AM
Check your graphics card's settings for a stretching option.

ShadowHawk81
08-11-2010, 08:52 PM
I get full screen as far as black border. But the resolution stays 640x480.

I dont really want to stretch the display to my full 17" wide.

Didn't Riven fill a whole 15x15" monitor back in the day? Why cant it go to that size these days?

I really dont remember playing the game on such a small size.

ShadowHawk81
08-12-2010, 06:46 AM
I HAVE GOOD NEWS FOR ALL WANTING TO PLAY THE GAME AT ORIGINAL SIZE! WHICH ACTUALLY DID LOOK LARGER THAN WHAT 640x480 LOOKS ON TODAYS MONITOR.

By now we should all know that the games resolution is default to 640x480. You can't change that part. You can, however, tweak your video card settings to make it work. This is a little more detailed than the last post on this topic, so check it out. It was actually Dragossh who got me testing it, so thanks :D

Here is the step by step method I figured out. If you follow this, it should work.

1) With the game running, actually check 640x480 resolution, so it is enabled. Make sure your not running in window mode. I don't mean the black border I mean, seeing the desktop.

2) Exit the game, making sure these settings are saved.

(Hopefully your video card control panal has the same or similar options, for the following)
3) Desktop resolution: You can keep your desktop resolution at its max, options under - desktop properties - then use the slide bar to set and apply your max resolution.

4) Go to your video card control panal. For me it's an Nvidia. Called Nvidia Properties (or) Nvidia Control Panal. Could be the same for ATI, I hope that helps.

5) There should be a tab or pull down menu labeled as DISPLAY. Under that, you will hopefully find a scaling option, seperate from a screen resolution option.

6) for me, I selected a pulldown menu called - Change Flat Panel Scaling. I actually have a 17" wide flat panel.

7) Under Change Flat Panel Scaling one of my options say "When using resolution lower than my native (default) display do this."

8) There might be 4 options. For me it is:
Use Nvidia Scaling (distorts the display to stretch unconstrained to your screen. If you have a wide screen, this will cause objects in Riven to appear slightly distorted almost like fisheye without the bulge.)
Use Nvidia Scaling, with fixed aspect ratio (stretches the display to the hight of your monitor, keeping aspect ratio the same)
Use my displays built in scaling (grayed out for me)
Do not scale (this is the option to which the game looks small on the screen with a black fill all around it)

9) So, choose Use Nvidia Scaling, with fixed aspect ratio. Or whatever it might be listed as for your video card. Make sure you save the options. Aspect Ratio scaling should be the key words.

10) Load up the game, and it should be working. (Note) I did actually have to load the game a second time for some reason, but it worked. So, don't be discouraged if you dont see it the first time you load.

*One thing I should mention, the game always had some scale of a black border around it. Just on older screens it appeared much smaller. So, to get rid of it, would involve a lot more technical work, and might also stretch it to look over pixelated. Also, using fixed aspect ratio on a larger than 1440x900 screen should still keep the game at it's original size. I noticed it seemed to fit only the 15" space of my screen, like it should. (that inludes the games black border, like it should look)

Here is a screenshots of before and after. I hope this helps. If not, hopefully it motivated you to figure out a similar solution. (In case your thinking, but wait those look like 640x480.... The screens are no longer 1440x900 res, but at least give an idea) Open them in seperate tabs, and do a comparison, by clicking each tab.

BEFORE
http://farm5.static.flickr.com/4101/4885353506_b76d054c31_z.jpg

AFTER
http://farm5.static.flickr.com/4100/4885353500_83ceccab7f_z.jpg


*Remember, even pixelated games like this were pretty impressive back then. Not much you can do to change that. At least its only videos that seem most pixelated. If you really want sharp detail though, you'll have to sacrifce larger scale, for sharpness. my solution, dont sit so close to the screen. That seems to help LOL