PDA

View Full Version : Render problem- leak in a displacement?


Doomwaffle
08-11-2010, 11:45 PM
See this youtube video- When I look down and the game locks up, it is really drawing what nodraw or a leak looks like- the ground texture trailing, etc. (sorry the video got a bit out of sync, source likes to do that sometimes with startmovie)

http://www.youtube.com/watch?v=lwOGB1RM8hg (if you're just reading this post, the text I'm saying will also give a better explanation- wait for the video to process if it still looks like crap!)

Any idea on how to fix this? When someone falls down there, I don't want them to see a funky nodraw vis glitch. Any ideas? Thanks in advance.

psihomir2
08-12-2010, 03:06 AM
Hm, that's very weird indeed. Only thing I would guess could be happening is if the player falls in a visleaf that's adjacent to far too many other visleafs and the game is suddenly forced to render a lot, but I doubt this would be the case... could we get a screenshot (2D views mostly) of that pit and its surrounding area?

StickZer0
08-12-2010, 03:53 AM
I can't really see your problem in that video, but suggestions I can make; clip the bottom of the displacement so the camera never has a chance to look through, and make sure you've got a nodraw box around the displacement sealing it from the void - there's always the chance you have a nasty leak down there because displacements don't seal leaks.

KamiofLunacy
08-12-2010, 01:03 PM
Displacements don't seal the map off from the Viod. Do you have a brush under the displacement?

Doomwaffle
08-12-2010, 04:36 PM
Thanks for posting. I'll put a clip block there and nodraw- I have skybox above and around, but not on the sides and very bottom- indeed this must be my problem.